Install locks up on Andy's Ham Radio Linux distro

Just seeing if anyone has noticed this problem. I just installed “Andy’s Ham Radio Linux” on my laptop. I got it running well, but I find that the older version of WFView is 1.2e that is installed. When I run the installer script, it all starts up fine but then it totally locks up after a few minutes and computer needs to do a forced shutdown since it’s totally locked up.
Has anyone tried this? The distro uses Xubuntu and has a lot of good radio stuff pre-installled, and wanting to try this out. 1.2e will work fine, but I want to keep all the software updated obviously.



Hey Tom,

Why not try the latest release from their site?

I have played with Andy’s distro - works well. However, you can roll your own and have fun learning as well.



Hi Tom,

When you run the installer script for the latest version, where does it freeze up? Can you share the output?

Also how much ram do you have on the computer?

de W6EL

Hi Glenn,

I think he is trying to install the latest version. I recommend this over the 1.5 binary release. The binary releases sometimes have odd compatibility issues which are difficult to diagnose. Plus we are on version 1.53 now :-).

de W6EL

The computer is a Dell i7 with 4Gb of memory. It’s an older EliteBook 8540W. Yeah, I should get a new one eventually, but just one of my laptops I have lying around. I usually play with Linux on them so horsepower hasn’t been much of an issue vs. Windows!
I run WFview flawlessly on a Raspberry Pi 4 and 400, and also got it running fine on one of those $30 Quadra computers. I do upgrade often using the install script and keep my PI’s on the latest version.
I’ll run the install again and capture a screenshot of where it locks up.

Running it again. It’s still going. I’m running from my other machine through SSH so I can see what’s happening. I wonder if the power save on the laptop killed it off? I changed the settings this time.
It’s taking a LONG time, and still hear the drive running so it’s working on something. Strange that a Pi or other wimpy little computer just takes a few minutes.
When trying yesterday, I did have a second SSH connection to monitor the processes using ‘top’. It went up to 8 on the load, so it was working hard at something.

Hi Tom,

You may want to try forcing it to use only one CPU core during the compile. I have seen some computers either run out of ram or overexert their power supply and die on big builds.

The change to the script is a single line (approximately line 159, depending upon how fresh your script is):

The text that says:
time make -j2
Should be changed to:
time make

That may do the trick. It’ll take a while but it should come out ok.

I have a Core2 Duo with 3 GB of ram in my kitchen, with linux mint. I use the blackbox window manager, which uses only 3 MB of ram. It runs wfview fine and it’s one of my favorite test machines. But compiling is not fast! System updates are basically an excuse to grab a coffee and walk a mile around the neighborhood.

de W6EL

Ok. Giving that a try!

I had it running but could have walked about 5 miles with a very large coffee - then a refill. Killed it, edited the file and trying again.


That did the trick. 1.53 installed in just a few very short minutes. I’ll have to remember this fix somewhere since I’m always playing with different Linux distros.
Thanks Elliott, I hope this helps others that may run into this challenge. :slight_smile:
73, KA7VIK

(thanks for the work on this software, I’ve said a few times already how much I like it).