LAN connection via Raspberry Pi

I admit to being a newbie when itt comes to wfview, I only heard about it two days ago.
I have installed in on the raspberry pi 4B and getting the waterfall. Control work.
I also installed it on the laptop and set up the client.
I have assuumed that the IP address, user name and password are for the Pi. After much mucking about with Incorrect Username/password, I got a connection, indicated by Blue and Green dots, and some sort of packet counter ticking over.
However, it shows NONE for the rig, so I’m not seeing or hearing anything.

the user/pass are the ones you have defined in the settings in the pi.

What rig are you conected to by the way?

It is an Icom IC-7300


Hi Roeland,

I find I can get everything working on the Pi using VNC. I can’t get the Client working on the laptop.

Maybe I don’t fully understand what wfview is supposed to do. Is it a remote tool like flrig? It seems to have some of that functionality, but I haven’t explored it fully. I don’t see AGC for instance.

I use flrig and fldigi for some modes. I also use iflrig with JS8Call. I can’t run either if wfview is running. I have written some shell scripts that control the 7300. You can see them here: They won’t run either as the /dev/ttyUSB0 is busy. I can use all three programs and scripts usually.

I found I had to Unlink from Remote to get the waterfall. I’m not sure what this does.

I tried running JS8Call with wfview running, set the radio to IC-7300 and got the same Port busy error message. So, how is wfview supposed to work, apart from showing me the waterfall?

73 de


Hi Paul,

You can have one copy of wfview connect to another. One copy can run as a “server” with a physical connection to the 7300. The other could by on your laptop as a client. The server has to be enabled to be a server, and the client has to connect in with the correct information.

Once you get that set, you’ll want to take a look at the User Manual and see how to share control of the rig with other programs. Wfview provides both a pseudo-terminal device (a “fake” serial port) and a TCP/IP interface compatible with rigctld (part of hamlib). Using one of these two methods will let you run other programs at the same time, such as fldigi. You can also redirect the audio from wfview (yes, it streams audio from the rig) into any digital programs like fldigi.

We don’t have AGC in yet, but it’s on our list.

de W6EL

unlink from remote:

you have USB (“high speed”) as well as a serial connection (“slow speed”). the latter is called “remote” and is on the back of the transceiver. The remote connection cannot handle the required speed to carry the waterfall data.

“link to remote” means that the data on the USB port is te same as on the remote connector. So if it’s selected, the rig won’t send waterfall data to the repote port and consequently also not to the USB port.

So “unlink from remote” disconnects the remote port from the USB port. That means that the waterfall can be sent over USB.


link to remote: no waterfall available over USB
unlink from remote: waterfall avalble over USB


yes that’s missing. For the data settings you currently need to select to AGC FAST on the rig. As Elliott
it’s on the roadmap.

(And don’t fall for the AGC off while using DATA modes)

Thanks Elliot for that information. I will read, mark and inwardly digest! More challenges!

73 de



Hi Roland,

When you do agc, here is one I prepared earlier :blush:

pi@raspi4:~/bin $ cat agc


set +x



stty raw 19200

case $1 in

#set AGC off

OFF) echo -n -e “\xfe\xfe\x94\xe0\x16\x12\x00\xfd” ;;

fast>FAST) echo -n -e “\xfe\xfe\x94\xe0\x16\x12\x01\xfd” ;;

mid>MID) echo -n -e “\xfe\xfe\x94\xe0\x16\x12\x02\xfd” ;;

slow>SLOW) echo -n -e “\xfe\xfe\x94\xe0\x16\x12\x03\xfd” ;;


) < $DEV > $DEV

Now, what did you mean by “(And don’t fall for the AGC off while using DATA modes)”

I do that for JS8, so what happens?

73 de



Hi Elliot,

I have the 7300 connected to the raspi4 and with Unlink to remote, I get the waterfall. The raspi4 is on the LAN with IP address

In Radio Server, I have Username and password set.

In the Windows program, I have the IP address of the raspi4, username and password.

I get no response. The Bottom RH corner shows NONE.


win10, win11?

do you see an user/pass error?

some windows systems use the same ports as rsba1 (and wfview) so moving to 50011/12/13 is also an option.

Which version (see about box, version, git has)?

(re agc – I get back on that)

Hi Roeland,

The About box tells me v1.1. I should have said it is Win10.

When I first tried a few days ago I got User/pass error, but nothing now.

The Linux version on the Pi is 1.2e.

I am using VNC to drive the Pi, so don’t have sound.

I tried changing the port numbers to those you suggested but no difference is seen.

When I click on Connect on the Windows wfview, the message at the bottom of the screen is

Searching CI-V bus for connected radios.

On the RHS at bottom of screen are messages about rx latency, rtt, loss: Here the appears to be a counter of some sort.

When I click on Radio Status on the Pi, the fields are blank.

When I Exit Program (W10), it hangs.




definitely would suggest using

for a start. There may be incompatibilities between the versions you use. While there haven’t been releases for some time, we have made major changes to the codebase.

Hi Roeland,
I have installed the new Win10 version (had to jump through a few hoops). It no longer hangs on exit. But I still get -NONE- at lower RHS of screen. I have tried changing Port numbers and enabling/disabling rigctld all to no effect.
I also tried changing the Rx Tx codecs, same result.
The ever increasing counter seems to indicate there is some sort of connection happening. What is it?


A screen shot.

Hi Paul,

Are you 100% sure that the login information you are entering is the wfview user account, and is not the raspberry pi system’s user account? They are not the same. wfview server user accounts are setup inside wfview on the copy of wfview running as the server, under Settings in the “Radio Server” section.

If this was not your issue, please send us the log file from the server. It should show if there are connection attempts.

Here is how to find the log file. I think the server side is where we will understand what’s happening, but you could send the server and client logs just to be thorough.

de W6EL

Hi Elliot,

Well it looks like something is connecting.



wfview.log (96.8 KB)

Hi Paul,

I agree, it is connecting!

My guess, looking at your log file, is some kind of issue between different versions of wfview. But I am not sure. Phil will have to take a look, he is the wizard behind the networking control.

de W6EL