Linux Audio settings for LAN

Wfview on Linux Mint 20.1 amd64 works nice over LAN to Wfview on Win7 x86 via USB to IC7300 (although the latter crashes after some minutes of its Server work - a memory leak??).

But I can not set Audio Output / Input in Settings on the Linux Wfview (empty list).
My first test is to hear the audio from the rig in Linux Wfview in the speakers.

I also tried to set in wfview.conf:

  • or AudioInput=hw:CARD=“HDA Intel PCH”
    but that is not reflected in Wfview after restart.

In alsamixer command, I can see several audio outputs and inputs.

  • How do I connect audio to the Linux Wfview (on LAN)?

(I have the loopback interfaces for wsjt-x ready but that is next step).


I have two-way audio (rig-to-computer) working fine with Debian 10.9 amd64.

I used the pulse audio controller GUI (pavucontrol) to make the computer-end settings, though they’re basically all defaults.In wfview, I have Modulation Input and Data Mod Input both set to LAN. Audio Output and Audio Input are set to:



That’s all it needed. The only “audio” feature that’s missing is VOX, and that’s apparently a shortcoming of the Icom microphone/VOX circuitry.

… Rich W2RG

Hi Rich
Strange. On the Linux side, Modulation Input and Data Mod Input selections are Mic,USB,ACC
regardless of Connect over LAN or disconnected.

How did you get the values LAN and alsa_… into the four fields?

(Perhaps I should clarify: My Linux Wfview works via LAN to a Wfview on a separate Win7 with Server activated. These two talk. The Win7 Wfview talks USB to the IC7300)

Hi Poul.

That sounds like you don’t have QTMultimedia installed, which method did you use for installation? If it was the pre-compiled binary, you might want to try compiling it yourself using the instructions here: · master · Elliott Liggett / wfview · GitLab

Manually changing the config file will not help you as if the input/output audio boxes are empty it means no audio devices have been detected.

You can also look in the log file Log file | wfview which may show something?

73 Phil M0VSE

LAN as an input type is only available with rigs that have a LAN connection (9700, 7610 705 etc.) for the 7300 you would use USB.

73 Phil

OK, thanks Phil
In log tile I find
INF audio: No audio device was found. You probably need to install libqt5multimedia-plugins.

I tried
sudo apt-get install libqt5multimedia5-plugins

and audio selections appeared in Linux Wfview!
Now sound comes from speakers in Linux.

Thank you so much.
And Very exciting product, kudos

1 Like


I see that Phil had some good advice on this, so I have little or nothing to add at this point.

I assumed that you’re using a 7610 based on the success you mentioned with Win7. LAN capability must be built into the rig (such as the 7610), that and using all of the corrrect lib’s when compiling the code are essential.

‘LAN’ should be an option when you click on the Modulation Input and Data Mod Input boxes. The same is true with the alsa_… options - they will appear in a drop-down box.

… Rich

Hi Rich,

If you run a separate wfview as a server, then you can have remote audio and control with an IC-7300 over LAN!


de W6EL

I’m not sure I understand this, and I don’t have a 7300 to try it, but …

So you would connect the 7300 to a “rig computer” that runs a wfview server using USB, run another wfview on a second computer that’s on the same LAN, and tell that “other” wfview to connect to the rig computer instead of the rig itself (which it cannot do)?

… Rich W2RG


That “rig computer” can even be a $35 Raspberry Pi.

de W6EL