No waterfall IC-705 network macOS Big Sur 11.5.2 + Wfviewv 1.2d

I have just setup my IC-705 on the WiFi Lan using Wfview 1.2d build b1ef680 and everything is working except for the waterfall display. I can hear the audio and transmit no problem. One slight adjustment that I did not see in the documentation – I had to set my audio devices to run at 48,000 Hz to eliminate a stutter sound since a sample rate of 44,100 Hz is not a possibility with the Wfview build. With this slight adjustment, the sound is good.

The only thing I see that looks unusual is this line in the log file.

… INF system: Cannot prepare WF view without rigCaps. Waiting on this.




think I forgot to mention that my new radio is an Icom R8600.

Robert Rose

Hi John,

Most likely, CI-V transceive got turned off. Check the radio menus and see if you can turn it on. This will also make other aspects of the program run more cleanly.

Does the bottom-right show “NONE” or “IC-705”? My guess is that it says “NONE” right now.

de W6EL

Hi Bob with the R8600,

Were you having the same problem as John, or did you get mixed into the wrong thread?

de W6EL

Elliott, The CI-V Transceive is set to ON. I saw that mentioned in many threads, but you are right, it does in fact say “NONE” in the bottom-right corner. What does that indicate?


“NONE” means we did not get a reply to our Rig-ID query. This almost always means CI-V transceive was disabled.

Have you specified the CI-V address manually in wfview, or did you put it on automatic? I recommend automatic, this is how we have designed wfview to detect radios connected.

de W6EL

I have put the CI-V address, A4, in manually. I will leave it blank and post my result.


Definitely try automatic (instead of manual). We put a lot of work into automatic, and if CI-V Transceive is enabled, it should work very nicely.

de W6EL

First, I want to thank you, Elliott, for your support, and second, I apologize in advance for this lengthy message. I have set the CI-V to blank, unchecked the manual entry button, and saved the settings.

The situation is more complicated than it at first seemed. As I was tuning the settings, I assumed that the results I got were a result of the settings, but I have found that without changing any settings at all, the system responds differently each time I run Wfview, and there is a loop of length three that I have found to be repeatable.

The first time I run Wfview, there is no sound, the waterfall does not function, and the bottom of the screen shows “NONE” were the device name would appear. I stress, without making any changes, I exit the program and restart it.

The second time I run Wfview, there is sound; however, the waterfall does not function, and the bottom of the screen still shows “NONE.” Again, I exit the program without making any changes to the settings and restart it. This is the behavior I noticed when the CI-V was set manually to A4 to represent my IC-705 radio.

The third time I run Wfview, there is sound, the waterfall functions, and the bottom of the screen shows “IC-705”. The program quickly overloads the capacity of my CPU and shows a CPU usage of 103% or more; it is not possible to click on any user interface button and get a response other than the mac’s spinning ball. System activity monitor shows Wfview as “not responding,” even though the sound does continue.

After a few minutes, I force quit Wfview, and the cycle begins anew from number one above.

Good Morning John,
You have described my experience setting up my HP probook running windows 10 with my IC 7300.
After 4 forced shutdowns I was able to keep the program running and made adjustments to reduce CPU time.
I am very happy with the performance of WFview and expect that it will continue to improve as more people add ideas to the group.

Good Luck with Wfview,

Steve Dunkle - KE3PL

I wish I could tell the forum what I did to fix this, but it remains very strange behavior and has now vanished. After rebooting my computer instead of just force quiting the WFview program, it began to work. I am now down to one remaining issue, and I think I should open another thread for that one. If the waterfall does not work, reboot your computer. Sorry, that’s the best advice I can give after fighting this for a couple of days.


John, NV9A