NoMachine Audio

I am trying to get NoMachine running with audio for ssb operation. NoMachine itself works, but I do not receive any audio on my Android tablet.

The current setup is a Raspberry 4 @home with Bullseye exclusively for the IC7300. Next to WFView it has FLDigi and WSJT-X installed, plus a couple of not radio related tools. The client is a Samsung Tablet with Android and NoMachine.

Sound does generally work with Mumble in this setup.

Any idea, what could be wrong?

Thomas, DL3EL

I used RemotePC. Nomachine and the others did not work for me.

I found NoMachine cumbersome and frustrating to the point that I removed it entirely and went back to Linux | X11. If you are running a headless workstation, you may need an HDMI dummy or working monitor when the workstation powers up to coerce the computer to operate with an attached display. Otherwise it may virtualize the session and cause issues.

I’m not using WfView on a Linux box, but I do have it on a Windows laptop that works great. I also have an android tablet, but it’s clear that Apple has won the tablet battle …Samsung has decent tablets, but not enough Android apps are designed for tablets which is a pain…

That said…

I’m using NoMachine to access my Inovato Quadra micro PC that is the core of the Innovato HamClock solution (https://inovato.com).

Inovato installs the standard X11 remote access tool but I found that clunky and as a newbie Linux user, I prefer a nice GUI over the command line. But fortunately, Inovato includes a Nomachine setup file in the Armbian build and with a little help from Inovato, I was able to get it installed on both the Quadra PC and my Windows station PC.

This way, I can view the HamClock running in a window on my PC rather than consuming an entire monitor. It also allows me to access the Armbian desktop so I can practice my Linux skills. Working great!

PS: The Inovato HamClock is an awesome solution and is only about $60 with shipping. A great alternative to a Raspberry PI. And it includes everything you need, even the case, power supply, fan, USB hub and USB cable. A high speed USB WiFi/Bluetooth adapter is an extra $11 (Quadra has a built in lower speed WiFi adapter)!

nomachine home and work-user – the remote ends are always X11.

If you don’t forget to enable audio – it works just fine.

I sometimes run my 7851/9700/705 on one of the remote laptops (wfview) and use nx nomachine to look and listen to it with my samsung tablet. It works fine using built-in mic and speakers as well as a headset or the AKG wired stuff.

1 Like

I’m curious – what is the cumbersome part with nx nomachine?
it works fine for bothe linux/X11 here as well as under windows.

Hardly discernable loss of video quality and audo works out of the box (you can enable/disable sound at first connection and/or later in the config). I use nx nomachine over ssh. https works file too by the way)

So curious…

any idea what could be wrong?
Raspberry @ IC7300 with WFView Server

  1. sound via Mumble works on tablet
  2. switch off Mumble, start nomachine, no sound on tablet

be sure you enable sound on the “server” side and also select it on the client’s side.
I sometimes disable it because if I do remore wsjtx, I don’t want the sound on the client, but leave it to wsjtx.

but again: enable sound - left click open menu panel. check if the speakers and mic are disabled or not. And the same for the client where you can do it via the menu as well (don’t remember where but I can look that up 4 you too

thanks, Ihave activated audio,where I found it, seescreenshots from server and client. Am I missing something?



Just didn’t work. Been a year ago. I forgot. RemotePC flawless for dummies. 73

I constantly had to reconfigure settings for both the client/server agents and the underlaying audio sources. I liked the idea of using a single tool for remote access between MacOS, Linux and Windows, but it was a kludge. I wanted a headless server close to radio that I could operate from the other side of the house. I experimented with JACK audio but it is too complicated. The computer integration overtakes the hobby with many of these “solutions” and feels like endless troubleshooting.

1 Like

Amen to that. I experienced the same but the, voila, it’s all been working for quite some time now.

Good luck to you.

2 Likes

I don’t know how the mac stuff goes here but:

windows: generally always works.
linux: depends on your setup, audio-wise. It has many many things to choose from.

and above is purely the server side. for the client side it’s just enable audio and that’s it.

When I have some time I may document how to have youtube/wfview/mplayer (etc) feed the stream into nx nomachine.

I understood, that I need pulse audio. According to the log it looks like, that it is installed (I believe so, because I have pavucontrol available). How can I enforce wfview to use it. According to the log, it is using the default, which seems not to be pulse:

2024-04-08 13:23:16.108 INF gui: Got Audio Output from Settings: “pulse”
2024-04-08 13:23:16.108 INF gui: Got Audio Input from Settings: “pulse”
2024-04-08 13:23:16.123 INF cw: “Sidetone Output: alsa_output.usb-Burr-Brown_from_TI_USB_Audio_CODEC-00.iec958-stereo (volume: 0 rate: 44100 size: 16 type: 1)”
2024-04-08 13:23:16.123 INF audio: Audio device(s) found (*=default)
2024-04-08 13:23:16.832 INF audio: * ( 0 “alsa” ) Input Device : “default”
2024-04-08 13:23:16.833 INF audio: ( 1 “alsa” ) Input Device : “lavrate”
2024-04-08 13:23:16.833 INF audio: ( 2 “alsa” ) Input Device : “samplerate”
2024-04-08 13:23:16.833 INF audio: ( 3 “alsa” ) Input Device : “speexrate”
2024-04-08 13:23:16.833 INF audio: ( 4 “alsa” ) Input Device : “jack”
2024-04-08 13:23:16.834 INF audio: ( 5 “alsa” ) Input Device : “oss”
2024-04-08 13:23:16.834 INF audio: ( 6 “alsa” ) Input Device : “pulse”
2024-04-08 13:23:16.834 INF audio: ( 7 “alsa” ) Input Device : “upmix”
2024-04-08 13:23:16.834 INF audio: ( 8 “alsa” ) Input Device : “vdownmix”
2024-04-08 13:23:16.834 INF audio: ( 9 “alsa” ) Input Device : “usbstream:CARD=b1”
2024-04-08 13:23:16.834 INF audio: ( 10 “alsa” ) Input Device : “usbstream:CARD=Headphones”
2024-04-08 13:23:16.834 INF audio: ( 11 “alsa” ) Input Device : “hw:CARD=CODEC,DEV=0”
2024-04-08 13:23:16.834 INF audio: ( 12 “alsa” ) Input Device : “plughw:CARD=CODEC,DEV=0”
2024-04-08 13:23:16.835 INF audio: ( 13 “alsa” ) Input Device : “sysdefault:CARD=CODEC”
2024-04-08 13:23:16.835 INF audio: ( 14 “alsa” ) Input Device : “front:CARD=CODEC,DEV=0”
2024-04-08 13:23:16.835 INF audio: ( 15 “alsa” ) Input Device : “dsnoop:CARD=CODEC,DEV=0”
2024-04-08 13:23:16.835 INF audio: ( 16 “alsa” ) Input Device : “usbstream:CARD=CODEC”
2024-04-08 13:23:16.835 INF audio: ( 17 “default” ) Input Device : “alsa_input.usb-Burr-Brown_from_TI_USB_Audio_CODEC-00.analog-stereo”
2024-04-08 13:23:16.835 INF audio: ( 18 “default” ) Input Device : “alsa_output.usb-Burr-Brown_from_TI_USB_Audio_CODEC-00.iec958-stereo.monitor”
2024-04-08 13:23:16.835 INF audio: ( 19 “default” ) Input Device : “alsa_output.platform-bcm2835_audio.digital-stereo.monitor”
2024-04-08 13:23:16.835 INF audio: ( 20 “default” ) Input Device : “alsa_output.platform-bcm2835_audio.analog-stereo.monitor”
2024-04-08 13:23:18.191 INF audio: * ( 0 “alsa” ) Output Device : “default”
2024-04-08 13:23:18.192 INF audio: ( 1 “alsa” ) Output Device : “lavrate”
2024-04-08 13:23:18.192 INF audio: ( 2 “alsa” ) Output Device : “samplerate”
2024-04-08 13:23:18.193 INF audio: ( 3 “alsa” ) Output Device : “speexrate”
2024-04-08 13:23:18.193 INF audio: ( 4 “alsa” ) Output Device : “jack”
2024-04-08 13:23:18.193 INF audio: ( 5 “alsa” ) Output Device : “oss”
2024-04-08 13:23:18.193 INF audio: ( 6 “alsa” ) Output Device : “pulse”
2024-04-08 13:23:18.193 INF audio: ( 7 “alsa” ) Output Device : “upmix”
2024-04-08 13:23:18.193 INF audio: ( 8 “alsa” ) Output Device : “vdownmix”
2024-04-08 13:23:18.193 INF audio: ( 9 “alsa” ) Output Device : “hw:CARD=b1,DEV=0”
2024-04-08 13:23:18.193 INF audio: ( 10 “alsa” ) Output Device : “hw:CARD=b1,DEV=1”
2024-04-08 13:23:18.193 INF audio: ( 11 “alsa” ) Output Device : “plughw:CARD=b1,DEV=0”
2024-04-08 13:23:18.193 INF audio: ( 12 “alsa” ) Output Device : “plughw:CARD=b1,DEV=1”
2024-04-08 13:23:18.194 INF audio: ( 13 “alsa” ) Output Device : “sysdefault:CARD=b1”
2024-04-08 13:23:18.194 INF audio: ( 14 “alsa” ) Output Device : “dmix:CARD=b1,DEV=0”
2024-04-08 13:23:18.194 INF audio: ( 15 “alsa” ) Output Device : “dmix:CARD=b1,DEV=1”
2024-04-08 13:23:18.194 INF audio: ( 16 “alsa” ) Output Device : “usbstream:CARD=b1”
2024-04-08 13:23:18.194 INF audio: ( 17 “alsa” ) Output Device : “hw:CARD=Headphones,DEV=0”
2024-04-08 13:23:18.194 INF audio: ( 18 “alsa” ) Output Device : “plughw:CARD=Headphones,DEV=0”
2024-04-08 13:23:18.194 INF audio: ( 19 “alsa” ) Output Device : “sysdefault:CARD=Headphones”
2024-04-08 13:23:18.194 INF audio: ( 20 “alsa” ) Output Device : “dmix:CARD=Headphones,DEV=0”
2024-04-08 13:23:18.195 INF audio: ( 21 “alsa” ) Output Device : “usbstream:CARD=Headphones”
2024-04-08 13:23:18.195 INF audio: ( 22 “alsa” ) Output Device : “hw:CARD=CODEC,DEV=0”
2024-04-08 13:23:18.195 INF audio: ( 23 “alsa” ) Output Device : “plughw:CARD=CODEC,DEV=0”
2024-04-08 13:23:18.195 INF audio: ( 24 “alsa” ) Output Device : “sysdefault:CARD=CODEC”
2024-04-08 13:23:18.195 INF audio: ( 25 “alsa” ) Output Device : “front:CARD=CODEC,DEV=0”
2024-04-08 13:23:18.195 INF audio: ( 26 “alsa” ) Output Device : “surround21:CARD=CODEC,DEV=0”
2024-04-08 13:23:18.195 INF audio: ( 27 “alsa” ) Output Device : “surround40:CARD=CODEC,DEV=0”
2024-04-08 13:23:18.195 INF audio: ( 28 “alsa” ) Output Device : “surround41:CARD=CODEC,DEV=0”
2024-04-08 13:23:18.195 INF audio: ( 29 “alsa” ) Output Device : “surround50:CARD=CODEC,DEV=0”
2024-04-08 13:23:18.196 INF audio: ( 30 “alsa” ) Output Device : “surround51:CARD=CODEC,DEV=0”
2024-04-08 13:23:18.196 INF audio: ( 31 “alsa” ) Output Device : “surround71:CARD=CODEC,DEV=0”
2024-04-08 13:23:18.196 INF audio: ( 32 “alsa” ) Output Device : “iec958:CARD=CODEC,DEV=0”
2024-04-08 13:23:18.196 INF audio: ( 33 “alsa” ) Output Device : “dmix:CARD=CODEC,DEV=0”
2024-04-08 13:23:18.196 INF audio: ( 34 “alsa” ) Output Device : “usbstream:CARD=CODEC”
2024-04-08 13:23:18.196 INF audio: ( 35 “default” ) Output Device : “alsa_output.usb-Burr-Brown_from_TI_USB_Audio_CODEC-00.iec958-stereo”
2024-04-08 13:23:18.196 INF audio: ( 36 “default” ) Output Device : “alsa_output.platform-bcm2835_audio.digital-stereo”
2024-04-08 13:23:18.196 INF audio: ( 37 “default” ) Output Device : “alsa_output.platform-bcm2835_audio.analog-stereo”
2024-04-08 13:23:18.197 INF default: Looking for inputs
2024-04-08 13:23:18.199 INF audio: "Client Audio input device pulse found! "
2024-04-08 13:23:18.199 INF default: Looking for outputs
2024-04-08 13:23:18.200 INF audio: "Client Audio output device pulse found! "
2024-04-08 13:23:18.203 INF audio: "Server Audio input device default found! "
2024-04-08 13:23:18.204 INF audio: "Server Audio output device default found! "

I now have a setup where pulse audio works with nomachine in that way, that audio from vlc on the raspberry is available on my android tablet. However, with WFView no luck. According to the log it shold be fine:
2024-04-09 12:50:30.994 INF gui: Got Audio Output from Settings: “pulse”
2024-04-09 12:50:30.994 INF gui: Got Audio Input from Settings: “pulse”

2024-04-09 12:50:31.236 INF audio: "Client Audio input device pulse found! "
2024-04-09 12:50:31.236 INF default: Looking for outputs
2024-04-09 12:50:31.239 INF audio: "Client Audio output device pulse found! "
2024-04-09 12:50:31.254 INF audio: "Server Audio input device pulse found! "
2024-04-09 12:50:31.255 INF audio: "Server Audio output device pulse found! "

2024-04-09 12:50:32.396 INF audio: Audio Input device “pulse”
2024-04-09 12:50:32.397 INF audio: Audio Output device “pulse”

The only difference to vlc is, that vlc is listed as a device in pavucontrol and wfview is not.

Any ideas?

Thomas, DL3EL

I Use WFVIEW with DWService. DWService provides RX audio and remote start of WFVIEW.

Whatever works best for you.

John
N0QJA

never heard of. Thanks, will try in the next days