NoMachine for remote access?

In several topics I read that Anydesk is causing problems to get wfview working properly and after removing Anydesk there are still leftovers that Harms wfview.
As Teamviewer considers you to be a professional user after using it a couple of time, I wonder if NoMachine as remote access program is wfview friendly? To my idea NoMachine does not have usage restrictions.
Is anyone using NoMachine together with wfview?

73, Fred

I’m using nomachine myself. Works well. Even on a phone or tablet.

I have it for windows and linux myself and it’s also available for mac’s. My personal feeling is that it outperforms other solutions I tried/know.

I use NoMachine all the time to connect to my IC-7300 wired to a Raspberry Pi 400 using USB. I wrote an article for QEX you can find at . Also, see my tech notes at which I need to update for wfview.

NoMachine connects to PulseAudio to remotely stream audio. I wrote a Perl script to 1) probe you Linux system for PulseAudio sinks and sources and 2) write a bash script to connect the desired sink/source to PulseAudio. This is available at .

Because you’re using PulseAudio to stream audio, you need to use pauvcontrol to control audio levels, not wfview.

This all gets complex quickly, and I developed this before I learned of wfview. If there’s a simpler way to stream audio, I’d be very interested in hearing about it.

Harry Bloomberg W3YJ

Hi Harry,

Before Phil wrote the wfview audio client/server code (which is great and makes what you’re about to hear obsolete), I set up an icecast2 server for audio. I’d then stream to it using ffmpeg and the monitor the audio using either VLC or mpg123. It worked, but it was annoying to set up and it had significantly more latency than wfview’s native audio tools. You can actually stream the wfview audio over to icecast2 if you’re so inclined, and then it makes it simple to embed a little code on a website for “click here to listen to my radio stream”.

Again, if you’re reading this, wfview has a built-in audio server and client, so the above is only a curiosity. wfview’s remote control is definitely easier than, say, socat and ffmpeg.

de W6EL

I try to setup a NoMachine server/cliënt connection between two Windows 10 PC’s. At the client side I see the server but when I try to connect it’s asking for a username and password. At the server side I see no option to create a user account. Did Some searching on the NoMachine website and watched some YouTube movies but here the accounts they use already exist and don’t explain how to create one.
Anybody who can point me to the right direction how to create a user account?

73, Fred

it’s the user and the pass you log on to normally. so if your local account is

blah and your password is “batterycar” – you use these to log in as user blah. so it checks the windows side for user/passwords.

Means also that unknown users cannot log in as they do not exit in windows, linux, mac

Roeland, do I need to create an user account in Windows 10?
When I power on my pc it comes up with a user and I enter a four digit pincode, no username/password.
I noticed in Windows 10 that you can creeate a user account without having a Microsoft account, maybe this is the trick?
This user requires Administrator rights I guess?

Use your Microsoft name/password that was used to set up the pin.

like what Gary said. and no you don’t need admin rights to access. You do to fiddle with accouts though

Roeland, I am getting to learn more and more about NoMachine and how to use.
I created a new user on my Windows pc and able to logon using my laptop as client. I noticed the server was asking for a confirmation for access. That’s ok when you are close to the server pc but not when you’re hundreds of kilometers away. I changed the rights of the user to administrator and now I can login w/o intervention. So in that perspective a administrator account is needed.
Next challenge is to access the server outside my network.

73, Fred

basically nomachie out of the box is set up so that you cannot take over anyone’s desktop. sound, devices etc w/o permission. However, there is a way to disable that – useful when you are controlling your own devices.

You can change that behaviour in the server settings

right click the NX icon → show main window → settings → server settings → security

there you will find the options like request . permissiopns to remote connect – disable and you’re set.