Operation question with IC-7300

Greetings,

I downloaded the Windows Test Build (2021-05-02) and installed the MicroSoft Visual C++ Runtime (x64).

My IC-7300 Silicon Labs CP210x USB to UART Bridge (COM5) works fine with other programs,

I start the wfview application and under Settings Enable USB (serial) Serial Device and select COM5. I return to View and have no response.

Do I have to start the application or enable another setting?

If this is helpful - there are GREEN and BLUE circles at the lower right hand corner and the word NONE.

Mike N2MS

Hi Mike,

Have you enabled CIV Transceive in the rig as if not that is likely the problem? Wfview requires that it is enabled and some programs will disable it.

73 Phil

Phil,

CIV Transceive was on. It is now responding after I disconnected and reconnected the USB cable. Maybe the USB port was still allocated to the previous program.

Mike N2MS

I am having issues connecting my Win 10 machine to the 7300. I have the RT systems rt-42 USB cable. Same one that I use for the programming of the 7300. I cannot seem to get the radio and the program to communicate. I have followed the getting started portion of the manual and there is no comms. Is there an issue with that RT42 usb cable that is not compatible?

Hi Scott.

The RT-42 is just a standard USB cable so it should be fine. Can you check the Windows Device Manager? If you right-click on the Windows ‘start’ button, you can select Device Manager.

Under Ports (COM & LPT) you should be able to see the device called something like “Silicon Labs CP210x USB to UART Bridge”. After the name, it should say (COMx) and that is the port you need to select in wfview.

If you haven’t used the IC7300 on this computer before, you may need to install the Icom USB driver which is available from: IC-7100/IC-7200/IC-7300/IC-7410/IC-7600/IC-7610/IC-7850/IC-7851/IC-9100/IC-R8600 | Firmware / Software | Support | Icom Inc.

73 Phil M0VSE

Ok thank you. That was the issue, the USB driver. Installed, restarted the machine and voila!
Thanks!

I am seeing the same thing on my ICOM 7300 with my Windows 10 machine. I have the driver installed and WSJT-X works fine and I’m able to control the rig with it. I don’t have it open when I try to use Wfview and I only get the blue and green circle on the bottom bar after setting the COM Port explicitly. This was after I got the app to successfully work on my M1 MacBook Pro with the Universal Binary without changing any rig settings. I did power cycle the rig just to make sure nothing else was strange after that.

Hi Steven.

I see from the other thread that you got it working by factory resetting your IC7300. If you are using WSJT-X then it is most likely because Hamlib is disabling CI-V transceive mode on your rig. This needs to be enabled for wfview to work.

73 Phil M0VSE

Ok. I was able to get it to work on Windows 10 by turning CI-V transceive off, power cycling the radio, turning CI-V transceive on and power cycling the radio one more time. I’m not sure if those power cycles were necessary, but I was able to control the rig remotely after that. After using wfview and using the radio I was unable to connect to the Com Port with WSJT-X after that without power cycling the radio. This program looks awesome though and I look forward to it getting better and better. :slight_smile:

I have to edit this post as I’m a new user and it won’t let me reply again so I hope you see this.

I manually set my baud rate to 115,200 on the 7300 and after running WSJT-X I have to disconnect / reconnect the rig for Wfview to connect the rig. No power cycling is necessary. After running Wfview, I get “Rig Control Error” trying to open WSJT-X. The error is:

Hamlib error: Command rejected by the rig
set_cache_freq: set VFR=VFOB to freq=0

So it seems like neither program leaves the radio in a workable state for each other. Is this something that I could build the app locally and get you and additional debug info? Would that be helpful?

Hi! I just downloaded wfview to my Win10 computer and tried to use it with my IC-7300. Wfview does not see the rig. I successfully use WSJT-X, Logger32, and MMSSTV over the USB connection with no problems. I have tried all of the things mentioned in the dialog above to no avail. Any further suggestions?

Hi Don.

Have you enabled CI-V Transcieve mode on the radio? It is required for wfview auto-detection to work.

73 Phil

Hi Phil,

Yes. I also tried the suggested sequence of turning off the rig power between changing those settings. It was in the ON mode when I started, BTW. I saw the note about that on the web pages and checked it before installing wfview. I also tried rebooting the computer. The USB drivers are installed and look correct.

Don

Hi Don,

Are you sure no other programs are trying to use the device at the same time?

Are you using the default baud rate of 115200?

I have a 7300 here, and this is how I set up the radio:

Let us know if that helps.

Thanks,

–E
de W6EL

Hi Elliot,

There is one difference in my IC-7300 setup and the settings in your slides. You have CI-V USB Port set to “Unlink from [REMOTE].” Mine is set to “Link to [REMOTE].” I changed that setting, but still no connection to the rig from wfview. However, all of my other apps stopped working properly. I changed it back to my previous setting.

Don

Hi Don,

You have to unlink first, and then it will actually let you set the baud to 115200. If it is set to “link”, then it won’t actually set the baud.

The newest firmware for the 7300 defaults to “unlink” for this reason, but if you ran your rig prior, it stays at whatever setting you have used before. So try setting the UNLINK and then set the baud rate and see what happens.

–E
de W6EL

Hi Elliot,

The baud rate was set to 115200 when I tried it in UNLINK mode in my previous message (I failed to mention that). And no other programs are running that would access the rig port. At one point I rebooted Win10 to make sure there wasn’t some befuddled port locking mechanism. I’m happy to work with you to debug this, so please let me know anything you’d like to try.

Hi Don.

We are probably at the point of checking the log file, Log file | wfview shows how to view it. You are mainly looking for lines headed “Serial” as we want to make sure wfview is opening the serial port successfully.

73 Phil M0VSE

Here’s the output of that command. It was repeated on every line differentiated only by the time stamp, so I left out the stuff in the middle.

PS C:\Users\don> Get-Content $env:TEMP\wfview.log -Wait -Tail 30
2021-05-11 17:50:53.064 WRN default: QIODevice::write (QSerialPort): device not open

2021-05-11 17:51:00.324 WRN default: QIODevice::write (QSerialPort): device not open

Hi Don.

That is telling us that wfview couldn’t open the serial port. Are you certain that nothing else has the serial port open? Omni-rig can often be a culprit here, if you have any programs that use it, Omni-rig will connect to your rig(s) in the background.

73 Phil M0VSE

~WRD0001.jpg

This is really weird. I just relaunched wfview and it started working. I have changed nothing since the last attempt. Will play with it and let you know how it goes.

Don

P.S. here is the log data for the startup that worked in case it is of use to you…

2021-05-11 18:53:33.831 INF system: Starting wfview
2021-05-11 18:53:34.944 DBG system: Loading settings from “\HKEY_CURRENT_USER\Software\wfview\wfview”
2021-05-11 18:53:34.975 DBG gui: Got Audio Output: “Default Output Device”
2021-05-11 18:53:34.975 DBG gui: Got Audio Input: “Default Input Device”
2021-05-11 18:53:34.990 DBG default: Getting server config
2021-05-11 18:53:34.990 DBG default: setState 1
2021-05-11 18:53:34.990 DBG default: setState 0
2021-05-11 18:53:34.990 DBG default: setState 1
2021-05-11 18:53:35.189 DBG serial: Opened port: “COM3”
2021-05-11 18:53:35.189 DBG serial: Could not open pseudo terminal port, please restart.
2021-05-11 18:53:35.314 DBG system: Received CommReady!!
2021-05-11 18:53:35.330 DBG rig: Using incomingCIVAddr: (int): 148 hex: 94
2021-05-11 18:53:35.330 DBG rig: Have rig ID: decimal: 148
2021-05-11 18:53:36.417 DBG system: Could not find modulation input: 2
2021-05-11 18:53:37.617 DBG system: Could not find modulation input: 2
2021-05-11 18:53:38.711 DBG rig: Received 0x15 center span data: for frequency 2500

1 Like