Password bug?

In the Client PC if I change the RX codec and TX codec to LPCM 1ch 16 from Opus 1 and restart Wfview, it comes up with a box “the password is wrong” and then I must change it in the Server under Settings> Radio server. The server Password has the same number of characters so it did not change itself, I enter the same password and it then works.

WFview 1.61 in both server and client. Win11 Server, Win10 Client

Can you enter that same password, press “Save Settings” and re-launch wfview? Maybe there’s an issue with the stored format.

de W6EL

Yes thats what I tried to say. I can use the same password again and it works. The problem is if I was away from home I would have no access to the server to change the password.

Hi Ken,

On the client side, can you enter that same password, press “Save Settings” and re-launch wfview? Maybe there’s an issue with the stored format.

I recommend doing this procedure on each side once, just to make sure wfview has a current password saved from the current version of wfview.

de W6EL

Hi Elliot,
Today when I fired up the server and client I reentered the client password and it worked as normal. I then changed from LPCM 1ch 16 bit to Opus 1 and it still worked. I then went back to LPCM and it still worked with no password errors. Yesterday 3 times I had the password error!
I had changed the Codecs because I have no Tx Audio at the Radio. I have full audio on the client Tx meter. I see no audio on the server meter at all. Not sure why I lost it? Controls and waterfall work remote and local.

Well, I ain’t complaining about that!

Glad it’s working, but do keep us posted if you see any odd behavior.

de W6EL

I dont have any TX Audio, that was why I was changing codecs!
Is the server TX Audio meter supposed to show audio when the remote is used?

The server side will not show any audio. Make sure the server side has the correct audio device chosen prior to a client connecting in (change the device when nobody is connected). Use the QT Audio system by default on both sides, it is most likely going to work without problems.

de W6EL

I still have a no transmit audio. However while troubleshooting I was able to replicate the Password problem.
I ran the server and client and at one point I ran another 2 copies of Wfview as a server on the local PC the second one opened with an error box about the port. The remote client when started pops the password error! I had to reenter the password in the server to fix it. I don’t know if this is what happened last night as I dont recall running two copies but I could be wrong. If this is the issue it would be good if it could be fixed as it is easy to mistakenly run another instance.

Still no joy with the Tx audio.


Do not run two servers at the same time, there’s no point and it will not work.

Make sure to switch the radio’s modulation source to “USB”. You can do this with the radio’s menus or by going into wfview’s Radio Settings page.

de W6EL

Of course I wouldn’t run two servers at the same time intentionally but it is easy to not notice that Wfview is running if it is minimized to the tool bar and click the run icon. If this happens and you are not at the server PC you cannot get the link up again. Murphys law!
Thanks for the help!