Problem with Debug

Greetings to all

I wanted to ask for an explanation, I find myself a problem in the debugging phase, at first it gave me dll errors but then solved it by copying the Wfvieu installation files from the directory where the software is installed, but then Visual Studio automatically downloaded all the missing components (Kernel, Dll etc). Now after it takes several minutes to download everything you need and then debugging had to start, the following error appears to me: (This application failed to start because no Qt platform plugin fault be initialize. Reinstalling the application may fix this problem) I have not understood which application it refers to (wfview or Visual studio) Visual studio I don’t think has any problems in this regard because I use it daily without problems.

Another thing once I load the .Sin visual studio file should also see the Form of the project, without this I cannot perform any debugging.

73 Ale


As I said when the form is missing, it does not load the QT5core.dll file

Hi Ale.

You shouldn’t manually copy the files, if you have Qt5 installed, you need to run:

windeployqt wfview.exe 

from the directory that contains wfview.exe as this will copy the necessary files from your Qt installation.

you will also need to install the Qt VS tools from Qt Visual Studio Tools - Visual Studio Marketplace

Compiling for Windows is quite a complex process at the moment.

73 Phil

Ok Phil I follow your suggestion and do tests.

Thanks 73 Ale

Phil I have already installed the QT for visual studio 2019 installation went well, previous errors I don’t see anymore

but I forgot to say that an error that I still find myself and the following: (MSB8066 here speaks of a personalized compilation problem and refers to an instruction (item-List)).

Now I see if I can solve it.

73 Ale

This is the instance of the error: ( < CustomBuild Condition = " ‘@ (_CustomBuild)’ != ‘’ "

Hi Ale.

Maybe try recreating the VC++ project:.Extensions menu, Qt VS Tools, Open Qt project file (.pro) and select the file. This will regenerate the project as it is possible your environment has differences to mine.

73 Phil

Hi Phil

Ok tomorrow I’ll try.

Thanks 73 Ale

Greetings to all

One question, today finally after so many commitments I managed to download qt creator, I wanted to ask which libraries I have to install in order to view the WF project? with Visual studio I tried everything but everything went wrong, in the sense that when I open the .sin project file it always gives me a design error at the root of QT5. Now I would like to try QT Creator and convert to visual Studio.

Thanks for your attention

73 Ale

If you are in Windows, and I think you are, you will need QT (of course), and you will also need to download qcustomplot and place it in a directory called “qcustomplot” in the directory before wfview. That is, “…/qcustomplot” should place one from the wfview code directory into the qcustomplot directory.

My install process (I did this recently) was:

  1. Visual Studio 2019 with c++ and debugging. 32 bit.
  2. QT, 32-bit, with debugging, with qt creator. The qt version was one that supported VS 2019. I think it was 5.15.2, which is not available in an offline installer – you need a qt account and to use the qt online installer.
  3. git commands, in path
  4. gzip (so I could unpack qcustomplot), in path
  5. qcustomplot

With this mix, I am able to build it either from the command line or from within qt creator. You could probably go all 64 bit if you wanted, we just used 32 bit for maximum compatibility.

de W6EL

Hi Elliot, it’s a pleasure to read you…

I confirm I am on windows 10 environment but now I tell you that I managed to load the project
with qt creator, now the only problem I find myself just launching the debug gives me an error of this type: (FILE Makefile doesn’t existi) now, this file that is looking for creator I don’t know where it is located, or where to go to get it. a little while ago I read on a forum that a check on the configuration of the downloaded files should be done but at this moment I don’t know where to go and look because I don’t know Creator, it had been a visual studio problem I would have already solved.

For the rest, the graphical interface with designer 6.1.2 loaded it and the graphic design is clearly visible (in practice the form). Now I see if I can somehow solve this mistake.

Thanks for your attention
73 Ale IZ4OSH