RC-28 Not detect in Mint WFview V 1.63

Please provide the following information with your question:

  1. Operating System: Linux Mint Mate 64 v21.1
  2. Method of download attempted (from wfview.org, package manager, source code, etc): Source
  3. Radio Model: Icom IC-7300
  4. Method of radio connectivity (USB, WiFi, Ethernet, etc): 7300 <–>USB Pi Mint <— Lenovo I5 Mint Ethernet
  5. Did you check the FAQ and read the manual? Yes

Hello, good morning, I have a Raspberry Pi 3 connected through the network to a remote Lenovo I5 computer (8 Gb Ram and 500 Gb HDD) and to which I have connected an Icom RC-28 Encoder, but Vfview does not recognize the device, it says (Not Connected), the S.O. seems so, everything else works WONDERFULLY WELL.
Could you offer me some help, I have to load some driver in RS-BA1.2 works correctly.
Thank you so much
Francisco EA4HPM


The fact that it shows-up means it has been detected, but your user does not have permission to access it, as per Using the RC-28, ShuttleXpress, and ShuttlePRO controllers | wfview you will need to either run wfview as root (not a good idea) or add udev rules to make it accessible from a non-root user.

I don’t know the vendor/device IDs for the RC28 offhand but you need to add them into a udev rules file (the vendor/device IDs should be displayed in the wfview log file.)

Or check if the user is in the dialout group maybe?

It works perfectly! Now all that remains is to configure the buttons, little by little…
Thanks a lot

1 Like

What did you do to fix? May be a handy ref for others

Just run: sudo wfview
But now I don’t have audio, the codecs I used have disappeared, I’m doing tests to see if I can get a configuration that works, as soon as I do, I’ll put it for others.
thanks for your help

Don’t run as root. Did you check if the user is I the dialout group?

Runnins something as root when not intended can give you permission issues later. Fix. Not circumvent issues

Don’t run it as root. This will be an enforced requirement in future versions. Desktop audio requires you to be the same user.

de W6EL

Ok, I have deleted the user created in Mint, but now I never get the menu with the drivers with which the audio worked (Alic…) again if I run the program as administrator the Encoder works but if I run it in normal mode it doesn’t
I configure everything in default, although I have tried other options and I do not configure CVI as it told me, and I always see Waterfall but I do not hear anything and if I do not enter as root the encoder does not work, I have looked at the installation and the drivers appear there sound

Let’s say this again.

ROOT (administrator)

Just Don’t. the root user is not to fix stuff this way. the fact that the rc28 works as root tells you that the user has no permissions apparently to talk/listen to the rc28.

create an user, add the user to the dialout group and tell us if the rc28 works or not.

Following your indication, that was what I did, I created a user, and added it to the “dialout" group and the RC-28 does NOT work and I have also lost the sound



Hi Francisco,

The linked howto shows a line in udev. You need a similar line in udev for the RC-28. Since I do not have an RC-28 myself, you will probably have to use google to see how to set the attributes in udev. There are utilities out there that will show you the attributes for a given device connected over usb.

From there, you can develop your own udev line, which sets the USB device permissions.

Again, read over this page carefully and then google how to get the idProduct and idVendor from a connected usb device. Then build a udev rule, and then re-insert the RC-28.

de W6EL

We have already done it but the link light does not turn on. link lights up when we run sudo chmod a+w /dev/bus/usb/001/011

On the Rasperry Pi there are many unnecessary rules that are misleading. A bad solution, but one solution is to enter the file 50-udev-default rules and in line 50 change the mode to 666, the default rule for usb devices. (do not think that I know something about this, I am surrounded by linuxists)

Roeland and Elliott are ABSOLUTELY correct, here is the udev rule that I have created, this supports both the Contour Shuttle and RC28.


# for newer Shuttle PRO model
ATTRS{name}=="Contour Design ShuttlePro" MODE="0644"
# for older PRO model
ATTRS{name}=="Contour Design ShuttlePRO v2" MODE="0644"
# for the Xpress model
ATTRS{name}=="Contour Design ShuttleXpress" MODE="0644"
# for Icom RC-28      
ATTRS{name}=="Icom RC-28 REMOTE ENCODER" MODE="0644"
SUBSYSTEM=="usb", ATTRS{idVendor}=="0b33", ATTRS{idProduct}=="0020", MODE="0666"
SUBSYSTEM=="usb", ATTRS{idVendor}=="0b33", ATTRS{idProduct}=="0030", MODE="0666"
SUBSYSTEM=="usb", ATTRS{idVendor}=="0c26", ATTRS{idProduct}=="001e", MODE="0666"

Once done, you must disconnect/reconnect the RC28 for it to be recognised.

Hi Phil
das war es…perfekt hab lange gezaudert mit WFVIEW und Windows starten.
Hab es so gemacht und BINGO
Danke 73 Heinz
schöne Ostern

1 Like