Remote client audio mac os

Please provide the following information with your question:

  1. Operating System: Mac OS 14+ on server. Mac OS 13 on client
  2. Method of download attempted (from, package manager, source code, etc): link.
  3. Radio Model: IC 7300
  4. Method of radio connectivity (USB, WiFi, Ethernet, etc): USB to mac mini server. Wfview v 1.6. Macbook client wfview v 1.2
  5. Did you check the FAQ and read the manual? Yes.

Server controls Ic 7300 fine. Client links to server and controls Ic 7300. But no audio on client. Tried changing from Audio Qt to Port Audio on server but no client audio.

Will try to send log files later.

Great software! Apprecuate the efforts by all concerned. Steve ac5ll

Hi Steve.

Firstly, v1.2 is very old. I would definitely recommend installing the latest from Download | wfview

Also, the most likely cause of no client audio is if the server audio devices are incorrectly configured, on the server in settings → Radio Server make sure that the IC7300 USB audio devices are selected.


Phil, I have server set to USB Audio Codec on both Rx and TX. Ports 50001, 50002, 50003. Qt Audio, 48000 sample rate. Baud rate 115,200.

Rx codes and TX codes lpcm 1ch 16 bit on both.

I know v 1.2 is old, but I can’t update my MacBook past 10.13.6 High Sierra. What’s the most recent wfview that can load on HS?

I am at a loss here because I’m not a programmer and don’t understand how these programs work…

Thanks Phil,

I’m learning.

Steve AC5LL

Set for same on

How old is your MacBook as anything newer than 2009/2010 can run Mojave (10.14) which is the minimum requirement for all recent wfview versions?

It’s almost impossible to tell without logs from both the client and server, but we may be able to spot a configuration issue with just the server log.

The server side of wfview has had very limited testing on MacOS though so there may be an issue that we aren’t aware of?

73 Phil

Apple says I can’t upgrade to10.15.3 but found a work around on YouTube. Upgrading now…

Well, this is frustrating and I see I’m not the only one with audio problems on the client side with Mac OS. Here’s where I’m at now:

  1. Upgraded to Catalina through He has a patch that is a work around for older macs/macbooks. Running fine there.

  2. Installed wfview v1.62 on both server and client.

  3. Server still working just fine.

  4. Server input is USB

  5. Server output is USB.

Now I could use some help on which choices out of the many combos to use.

I’ve installed Soundflower on the macbook client and have those as choices but none of the choices has made any difference in sound out of the client speakers.

All suggestions welcome.


Steve AC5LL

The majority of audio problems are caused by mis-configuration, as I have said before, we can probably tell you what the problem is if you upload your log to termbin and post the URL here.


Hi Phil:

Here’s the log link from my client computer.

Been running all night on the server and still connects this morning.

Please let me know what else you need from me and I’ll get it to you!



And the server log too please…

Hi Roeland!

My Internet is running very slow today. My shack is in my backyard about 75’ or so from my router. I connect via WiFi. I have set the server, a mac mini running Ventura 13.2 to the following:

Qt Audio.
Input: usb
Rx: LPCM1Ch16bit
Tx: LPCM1Ch16bit

Set the client the same:

Macbook Pro running Catalina
Both Wfview are V 1.62

Ct and Server connect just fine and I have all the functionality except for sound out of the ct speakers.

I will send Ct log in next email.

Thanks so much my friend!



Here’s the client log link…

Both computers are set to the same settings.


Sadly I can’t (immediately) see any issues with your configuration. All I would say is you are getting a lot of packet loss.

UDP audio streaming is VERY intensive, relying on sending an audio packet every 20ms. It is possible that the WiFi connection isn’t able to keep-up with this level of traffic and too many of the UDP packets are being lost.

Where possible, I always recommend either a wired connection or a commercial grade Wireless AP, as many domestic access points are not designed for high packet count UDP traffic, they are generally better suited to TCP traffic.

Wfview uses the same method of loss detection/retransmission as the Icom servers, but there is a limit to how effective it can be, and if significant loss is occurring, that may explain your lack of audio?

It is also possible that there is an issue with the Mac audio implementation within wfview. This is less likely as the client and server use the same basic audio handler code, and the client definitely works. I’m not sure how many people use the server function on MacOS though?

73 Phil M0VSE

I also noticed that the server connection seems to be coming from 50800,50801 and 50802 rather than 50001,50002 and 50003, do any of the devices between the client and server perform any form of NAT (network address translation)? If this isn’t truly bidirectional, that may explain why so much traffic is being lost.


Good call Phil. Yes, my WiFi connection is a bit far from my shack to my house. But maybe the port address problem is the main culprit. I will try to change that on my client side. I have an SDR using CubicSDR and that may have added additional ports.

More experimentation as time allows!

Thanks so much.

I’ll report back.



I have different ports still on the next start up. 56693, etc…

I am going to have to get a lot more familiar with how my mac runs to fix this. I started up CubicSDR to connect to the 7300 and it connects fine, but has the same sound problem. I can see the inputs on USB moving, but no sound out of the speakers.

As this is not a wfview problem specifically, I don’t really expect your support but any pointing in the right direction is appreciated!

I’m just stumbling around the Internet at the moment…


Hi Steve.

Yes that is the difference between local and remote port. The client will always select a random local port (I suspect it was a coincidence when it was 5080x so you can probably ignore this)

73 Phil