Remote control of IC7300 over LAN

I’m a complete noobie here so bear with me please. I have an IC7300 in an outside workshop connected to wfview on a Raspberry Pi400. This works great. However, when I try to get remote control over LAN from a Win10 PC in the house I cannot get a connection.

CI-V transceive is set to ON on the rig. The control port is 50001 as standard. The rig CI-V address is unchanged at x94. A network user name and password are set up on the server end and the same details are in the client. Pressing the client connect button produces a message saying wfview is using the CI-V address of x94 but no connection results.

Netstat on the Pi shows ports 50001, 50002 and 50003 as in use by wfview but the state column is blank. A similar check on the PC does not list anything as using these ports.

I’m obviously missing something somewhere. Any pointers would be greatly appreciated.

Roger G8JWT

HI Roger.

Try disabling ‘manual CIV’ on both the client and server and allow wfview to auto-detect it. I find that sometimes the remote client cannot detect the rig type if manual CIV is enabled.

73 Phil M0VSE

Hi Phil. Thanks for your reply.

I tried disabling manual CI-V on both client and server but it made no difference. Playing around with the client settings I found that enabling manual CI-V and “use as model too” together enabled the client to think it is connected and it shows “IC-7300” in the bottom right of the screen. However, the server end says there is no connection and indeed the client View tab doesn’t show any signs of control.


I had at my Raspi for remote access Any Desk running and as far as I remember I had to use an other port than 50001 => used 50004 to be able to connect. Check for similar Problem. Use other ports.
73, Michael

Hi Michael, thanks. I changed the ports to 50011, 50012 and 50013 and that worked. Something else must have been using the original ports despite me looking for that. The only other thing running is VNC so maybe that was it.

I now have control over the IC7300 and can see the waterfall but I don’t have any audio at the client end.

Appreciate your patience!


Hello Roger,

at the client side you need “virtual audio cables” VAC to connect audio endpoints of wfview to/from speaker/microphone.
If you have at client side running wsjt-x it will work, but without monitoring audio to speaker.
In case you want to do that a repeater has to be installed additionally to the VAC.
This splits the audio output endpoint of wfview to 2 extra endpoints, one for wsjt-x and one for the speaker.

73, Michael

Hi again.

I’ve installed VB Audio Cable and on the client side the audio output is set to CABLE Input (VB-Audio Virtual Cable). On the W10 Control Panel I have Speakers selected under the Playback tab and Cable Output on the Recording tab. I guess something is wrong or missing because there’s no audio from the PC?


Hi Roger.

You only need VB Cable if you want to route audio to a 3rd party application (like wsjt-x). Otherwise, the audio output just wants to be your usual speakers.

On the server machine, you need to select the USB codec of the radio for the audio input/output devices as that is the only way that wfview server can route the audio. Once done you save the settings and restart the wfview (server)



Hi again Phil.

On the server side I now have the audio input set to alsa_input_usb etc and the audio output set to alsa_output_usb etc. I don’t see any means of setting the codec on the server side if it uses a USB connection as the IC7300 does.

On the client side I have the audio output set to Speakers (USB2.0 Device) which is my normal USB speaker. The codec is set to LPCM 1ch 16 bit. In Control Panel I have the audio output set to the USB speaker.

Still no sound.


Hi Roger.

The client always requests the Codec/sample rate no there is no way to select that on the server. It may be worth restarting the server machine and make sure that the correct ‘input’ device is selected as there may be an output ‘monitor’ device as well?

73 Phil M0VSE

Is there a way to check that the Pi is receiving audio from the IC7300?


Hi Roger,

I could be incorrect here, but on my version of wfview which I am running as a server for my 7300, the audio devices are named something like “alsa_output.usb-Burr-Brown_from_TI…”. So I would check to see if you have some devices named like that which you could pick from. Since we’re running a slightly different OS, you may already have selected it and it just has a different naming scheme than me.

If you wanted to test out the audio, I would close wfview and then open a program that can record audio such as Audacity (you may need to install it first using the software center aka “Add/Remove Programs” or using apt-get). You could then try to record a little bit from the correct device and see if you can play it back or at least see if you can “see” the waveform was recorded.

de W6EL


Those are the settings I have on the Pi but no audio results. As an experiment I’ve just set up a W10 PC as the server and that worked first time with audio at the client end (also a W10 PC). I would prefer to use the Pi due to its low power consumption but I can’t seem to navigate the Linux issues.