Remote tx audio

Hi – First of all Wfview is a great achievement – getting it to work fully for my case is proving difficult –
IC 7300 – Raspberry pi 4b – wfview acting to connect and as network server.
remote is laptop running lubuntu jellyfish -
Actual control is awesome audio received now works well – had to install an audio loopback before it fully worked – and had to jack op the 7300 usb audio to 75% – but all good.
TX – before loopback it worked very badly jittery echo +++
Now I cannot find a stream that gets back to the server loopback or otherwise.
I have tested all 30odd audio streams – for the audio input stream on this remote laptop — zero- zip zilch.
Any help with tracking down this one issue would be fantastic – very happy otherwise. PS I thought is was working – until i realized i was close to the 7300 radio and the microphone was still plugged in , as i was activating tx from the laptop and audio we softly getting through. Pulled the microphone – zero .


Hi Lew,

You should not need a loopback device to use a microphone and speakers. That is quite unusual. I think you would be better served to not use the loopback and to simply try each of the three available Autio Systems. Remember that you must disconnect, select a different codec, and then reconnect. The server will follow whatever codec is selected by the client. Different hardware and operating systems work better with various selections. You can also try changing the sample rate. I really recommend just selecting the mic and speaker in wfview and then trying the different Audio Systems. Since you’re using wfview to wfview, you can also use the Opus codec, which is much better as it contains some forward error correction and uses less bandwidth.

Otherwise, make sure “USB” is the selected Transmit Modulation Source on the 7300. That way the microphone at the radio won’t be involved at all. Select “TxRx Audio” on your client to monitor your computer’s microphone. If that meter doesn’t move, then you need to check the mic gain on the computer and make sure the correct source is selected. Sometimes linux will give you a few similar choices but generally only one is going to work correctly. Don’t forget to disconnect, change, and reconnect. You can also help things along, sometimes, by selecting the microphone in your desktop environment as the default input. Sometimes that helps.

de W6EL

And don’t forget to save your settings when you have a good working setup

Thanks heaps.

The request I made was a very short version of what I have tried. Thank you I will save my settings and I must have tried over 100different combinations but I always disconnect change settings save then reconnect.

I will now go back to a fresh Linux install and try again as I have seriously messed with the audio system to get where I am.

Thanks again

Still love the work that has been put into it.

Great job.

PS I am a programmer I do know just how much work this has taken.


All reset - still no tx audio I must be missing something.

Best receive setup so far

Server ras-pi :

Radio access screen:

Serial USB

Serial device : /dev/usb0

Baud rate 115200

Serial connection area not used.

UserInterface :

When tuning - checked

Auto SSB - checked

Enable ptt- checked

Auto polling- checked

Radio settings (tab,):

Modulation input - USB

Data mod input - USB

Radio Server:

Enabled - checked

Ports standard.

Audio system : both RTAudio & Port audio appear to work.

Full User is assigned.

External control (tab)

Enable rig control - not checked.

Enable USB controllers - not checked


ACC/USB output select ------AF

ACC/USB af output level —73%

All other levels 50%

Remote HP i5 laptop —client:

Settings :

Radio connection – network checked

CI-V not checked

Host name

Control port 50001

User name Lew password xxxxxxx(not that naturally)

Rx latency 271 tx latency 219

Rx Codec Opus 1ch

Tx codec Opus 1ch

Sample rate - 8000

Audio system - PortAudio

RT audio won’t work - Qt Audio - sends everything into jitters -Pulse audio playback screen is total jitters in this mode.

Audio output -seversl settings work

Audio input - no settings work.

Laptop has plugged in headset.

Pulse audio input device is Microphone- plugged in.

Pulse audio output device is

Headphones - plugged in.

Can anyone see what I have missed please.



Have you set the secondary meter to RxTxAudio? Do you see your audio on the secondary meter when you transmit?

de W6EL

Thanks for that -

Client :-

secondary meter - set .

Tx audio - ( no audio on tx)

Yep found audio setting for that - works

But still no tx happening.

No audio on the server meter.

The server meter will never show any audio.

If you have audio meter moving on your client, please make sure your radio is set to use USB as the modulation source. Do it from wfview under Radio Settings. Then go to the main wfview tab and turn up the USB slider until you see some modulation.

de W6EL

I must have a weird hardware issue.

Neither the laptop nor the upstairs terminal ( both Intel i5 running lubuntu jellyfish)

Will respond to this USB is set and slider full boar - nothing) the pi server is also set as specified.

Both tx audio meters can be microphone pushed to full scale.on the terminals.

But the ic7300 will not produce any output power at all – zero.



All working thanks heaps .

Something was wrong with the raspberry pi .

I installed a new system and setup from the beginning .

Super impressed it is working very well.

Thanks again to everyone for all the hard work .



What do you reckon would be the chances of saving the selected vfo step rate with the rest of the save settings guys.

This is something that I have already added in my development branch, but it isn’t ready for general use yet.


That would be great!! I have no clue why it took me so long to set up Wfview with a 7300. But now everything just works on both the host Mac and the remote Mac.

I now understand the patience the dev team needs to deal with me.

Many thanks for doing so.


Edmond, Oklahoma

Sorry(thinking more about it) in a way it is not necessary to save that setting. I am sure it would be perfectly acceptable (and a lot easier) to copy what ICOM have done on the latest IC7300 software patch, and set the default to 1khz as they do with the multi task dial.

Again super happy with WFview you have done an awesome job, thanks heaps.

It is Fabulous.

Regards an 73


We will probably keep/remember the settings.

After reading through the manual several times, My suggestion is to break it up a little more. Make three sections out of if with three different setups. One for a stand alone setup of Wfview that will be used on a desktop only. A section to setup the server for the various OS’s and lastly a section for the various OS’s on the clients. Give examples. As written, I follow what is trying to be accomplished. There are place in the manual where the various setups run into each other and it is a little hard to decipher if you are setting up a single computer vs a client/server/internet connection. Maybe take a look at interfacing with other programs like FLDIGI. Some information took me a little while to digest. I got it but, it wasn’t quite clear enough.

Just some food for thought as I see a lot of the emails are about missing audio especially from a network connection…

John Kosobucki