Rigctld compatibility

I use the software Cqrlog that sends the command “fmv” to rigctld in a client server setup with wfview. This command is not answered, so I get no running updates of frequency in Cqrlog. However the command “f” is answered correctly with the rig frequency if I enter it as a telnet command (in my case “telnet 4532” followed by “f”). But a stacked command “fmv” does not work as a telnet command.

Wfview version is 1.2e, rigctdl version is 4.5.

Is this a compatibility issue between wfview and rigctld?

Hi Jan.

We don’t currently support these kinds of compound commands, We did receive a merge request to address this issue but unfortunately, it broke support for some other commands so we weren’t able to accept it.


This is something that we will look at again in the future, but no timeframe at the moment.

73 Phil M0VSE

registered here:

Hi Jan.

Have you tried setting up CQRLOG rig control using your radio and ~/rig-pty1 as the device. That should work.

You can also use Flrig with the device of ~/rig-pty1 then use Flrig as the radio in CQRLOG.

For CQRLOG Rig control in conjunction with WSJT-X then you would use Flrig as shown above and use Flrig as the radio in WSJT-X and CQRLOG. That works also.

Carl - WC4H

I just tested this selecting 2: Hamlib rigctl for the radio. Then for the DEVICE enter and make the port 4533 to match Wfview.

Works just fine.

Carl - WC4H

I’m following this with great interest, having just moved to Linux in the shack.

Using Carl’s setup (Hamlib NET rigcrtl as the radio), controls TO the radio work (band and mode changes), but not frequency polling.

Once upon a time, i saw something to the effect of -p (device address) -P RTS as an “extra command line argument” but that didn’t help either.

The software WSJTX does update the rig frequency dynamically over my remote raspberry connection, but CQRLOG does not. The settings in WSJTX is Hamlib NET rigctl as Rig, and (in my case) as Network server.

I don`t understand why this is so.

Hi Janne. You have to make sure that CQRLOG has the same port as WFVIEW. WFVIEW uses 4533. Both WSJT-X and CQRLOG work here. JTDX Also works with it.

Make sure that in the Network Server field you have as the entry.

Carl - WC4H

I am not sure I understand, I have a server-client setup. Rigctld is only running on the server, where it talks to the transceiver. On the client side, where I run CQRLOG, there is no rigctld running if I try to call it on localhost.

As I understand it, CQRLOG talks to the rigctld on the server, which in turn talks to the transceiver. But the command “fmv” from CQRLOG is not answered, because that command is not supported by Wfview, that is supposed to send it to the transceiver, but does not.

The same thing happens if I use a telnet command on the client side, directed to the ip-adress of the server and port 4532. The command “f” is answered correctly, but not the command “fmv”.

Am I missing something here? Is there another way for CQRLOG to talk to the transceiver from the client to the server?

As I said WSJT-X gets the frequency of the transceiver from client to server, as I understand it through rigctld running on the server side. But perhaps that software does use a single command “f” instead of a stacked command that rigctld can´t handle?

Hi Jan,

I’m not sure how much clearer we can make it, but I will repeat myself for added emphasis:

“We don’t currently support these kinds of compound commands, We did receive a merge request to address this issue but unfortunately, it broke support for some other commands so we weren’t able to accept it.”

I have tested many different programs with the wfview rigctld server and NONE of them use the compound (fmv) command that CQRLOG uses. Therefore at this current time, wfview does not support CQRLOG!

If another user has been able to get CQRLOG to communicate with wfview over rigctld, I don’t know how as I have confirmed that this doesn’t work (and I wrote the wfview rigctld daemon).

73 Phil M0VSE

1 Like

Thanks Phil,
I understood you very well, and your answer did explain the issue clearly.
My intent was to answer Carl, who suggested a fix that I did not quite understand.

Kind regards,

Hi Jan.
I was suggesting a way for CQRLOG to be able to read the frequency direcltly with rigctld… that works (should work) whether or not you have Dfview.

So in the New QSO window / File / Preferences / TRX Control tab:
Rig Model: 2 Hamlib Net rigctl
Device: the IP address where radio is connected
Poll rate: 500
Port: 4533

If you try that, in theory, you should be able to get CQRLOG trx control to talk to the radio regardless of what Wfview is doing.

If I have misnunderstood your goal, then I apologize.

Carl - WC4H