Split mode, IC-9700 and WSJT-X

Brief summary of problem (put in title as well): Split mode, IC-9700 and WSJT-X
Radio Model: IC-9700, firmware 1.41
Connectivity (USB/Ethernet/Wifi/Other): Ethernet
Operating System: Windows 10, latest updates
wfview version (press “About”): 1.62
Checked the wfview manual (Y/N): y
Checked the wfview FAQ (Y/N): y
Tried to google it (Y/N/NA): y

What I did:
Cloned my IC-9700 USB-connected configuration in WSJT-X, then in the new config for using wfview I just changed the rig type to Hamlib NET rigctl and CAT control to Also changed the Audio connections to use my virtual audio cables.

Expected behavior:
With Split Operation in WSJT-X set to Rig, TX frequency should change somewhat depending on what offset I’m using for TX. RX frequency should stay the same.

Observed behavior:
Decodes work fine. But as I TX with various offsets the frequency of the two VFOs, at least the one used for RX, walk around; it becomes a mess. If I change the Split Operation in WSJT-X to Fake It, proper TX behavior results; this is a reasonable workaround, but the rig-based split operation is definitely buggy. Unsure if wfview is putting the TX frequency in VFO A instead of VFO B, or what.


Further experimentation makes it appear as the frequency assignments to VFO A/B are reversed, but only in Split mode. When I switch to “Rig” split mode in WSJT-X, then on the rig itself I see the TX frequency has been put into VFO A and the RX on VFO B.

It gets even more curious if I exercise a couple TX cycles via the Tune button in WSJT-X. The frequency in VFO B stays the same, but the frequency in VFO A keeps being changed upwards by the difference of the intended RX/TX split.

For instance, say I have WSJT-X in FT8 mode with a frequency of 144.174 selected, I select a TX offset of 2300Hz which causes WSJT-X to want to TX 500Hz higher than the RX frequency. Enabling “Rig” split mode results in 144.174 being placed in VFO B, 144.174500 in VFO A. Each time the Tune button is cycled, the frequency in VFO A is increased by 500Hz, so after a couple cycles 144.175500 is in VFO A.

1 Like

I haven’t seen a comment on this. Known bug? Offhand it doesn’t seem like a timing issue, might be similar to some other split problem someone was seeing. Not urgent for me as “fake it” mode in WSJT-X works fine for me, in any case I’ll test for any change with the next release of Wfview.

Thanks for the mentioning. Currently some big rewrites etc are going on. I never split or fake.

The reason for split mode, real or faked, being used in WSJT-X is so that the TX is done with the signal around the middle of the transmitter’s passband. The intent is to TX as clean a signal as possible.

Updated the firmware on my IC-9700 to the latest, v1.44, no change in the split behavior. VFO A in the rig immediately set to what VFO B should be when I enable rig split mode and select a frequency in WSJT-X. Fake split mode continues to work fine.