Switching Local/Serial vs Remote/Network Operational Modes

In learning how to setup wfview, I have found that if I set it up for remote, while my 7300 is working locally, the settings change to the new needed settings and it works just fine. However, when I stop wfview, the 7300 remains in that mode and I cannot use my transceiver in a non-wfview local mode, and in particular the microphone.

Is there a quick way to switch between local/serial operation and remote/network operation, and back? If not, is there a setting that would allow me to put my 7300 back into the mode it was when I started wfview for remote operation?

Thanks, Don

Hi Don,

If I drill your question down a bit, are you asking how to switch from USB Audio to Mic Audio?

What do you define as “non-wfview local mode”?


de W6EL

I know how to change from network to local use in wfview, from USB audio to Mike audio. That isn’t the thing I am wondering about. The method to do that means disabling remote access in wfview, or digging around in 7300 configs to undo the change made by wfview.

By non-wfview local mode I mean using the 7300 in native mode with no computer.

I am unaware of a way for wfview to restore the 7300 config on exit. Maybe it exists, I hope, but right now it is leaving the raw 7300 unusable via the Mike or whatever on exit, requiring other remedial actions so other modes and methods can be used.

73 Don

Hi Don,

wfview doesn’t make any changes to the radio. The user can elect to change the MOD input using the menus on the 7300 or the convenience menus under Radio Settings in wfview, for example, from MIC to USB. We also enable the spectrum output over CI-V. You can disable the spectrum any time by un-checking the “Enable WF” checkbox.

Beyond that… I’m not really sure what you’re asking. wfview doesn’t alter the radio’s operation at all, we’re just sending and receiving data over CI-V just like any other ham radio program.

de W6EL

Break ! Something possibly related im not sure - myself and one other ZL user of the latest version 1.5 using the 7300 experienced an issue where the 7300 would no longer work with the front microphone port after using it remotely and experiencing a Client audio issue. YES- we both did turn DATA MODE OFF back to MIC and checked levels . Not only did it do this to the 7300 i was using twice , but another ZL reported it did it to him too , and hes an absolute whizz on these things. He too like me had been using Win10 as a client , but his server was different in the fact that he has a windows server , i was using Pi3 B . Now i turned the 7300 off twice , double tripple checked everything i could , but no modulation at all could be returned without a minimum of a Partial reset being performed. Thankfully the reset returned it to normal working state. Levels were 50% , all functions were fine, just no a dicky bird on the scope in response to audio from the mic , no current modulation with audio to backup any aspect of a scope setting. Nothing heard on a remote SDR we were using for audio checks. This issue happened when the Remote audio also went quiet and then you start trouble shooting drivers …and i personally think the two disturbances are related.
Just thought i should report this, as i was not alone in this experience and we were both using 1.5 and experimenting independantly . I only learnt about the ZL experiences when i was prasing the software on an 80mtr net , when he asked me about had it locked up the mic… We both initially thought that we had faulty microphone plug/socket issues …but not the case… so maybe a command does go rougue ?
I hope this can be helpful if anyone else has experienced this

I don’t know if this will help
I set my IC7300 up to work with wfview and then save that configuration to my SD Card.
I set my radio up for standard SSB (voice) communication and save that configuration to the SD Card.

When I want to switch between the two operating modes, I just load that the configuration that I want to use, Standard Operating or wfview.

Just my way of making it work


Hi Stu,

It is not the Data Mod Input, but the Modulation Input (for not-data-modes like SSB and FM) which must be changed back to mic. It is also worth checking the microphone gain level and TX Power level.

That’s really all there is that I can think of.

wfview is a very simple program in terms of what it tells the radio to do. It is no different than any other computer software from the point of view of the radio. There aren’t any mystery settings that we are using which you couldn’t otherwise access from the buttons on the radio. We’re following the manual’s listed CI-V commands quite carefully; it’s all by the book and well-documented.

If your IC-7300 isn’t responding to microphone input, check:

  • The current mode, make sure it is a normal voice mode like AM, FM, or SSB
  • The selected MOD input. This is the modulation source for the radio’s transmitter. It should be set to “MIC”
  • The MIC Gain adjustment – set it to 50% or higher for starters.
  • The TX Power adjustment. Mine is generally set to 100% unless I’m driving my amplifier at 50%.
  • Look at the ALC meter for motion while speaking on sideband
  • Look at the RF Output meter (“Po”) while speaking on sideband
  • Try the built-in voice recorder to verify that the microphone is making sound; ths will also let you see the microphone audio level.

de W6EL

Yes , the DATA MOD OFF - isnt that the one ? i have DATA MODE ( for DATA )…and DATA MODE OFF .
Its the DATA MODE OFF that i changed from USB and returned it to MIC .
Thank you for your help . I’ll have to set it up again this weekend and try again. It worked absolutely fine for a while then mysteriously stopped …and thats when i sidelined it for the time being and went back to using normally, however that is when i found i could not restore a functioning Mic .
I hope im not missing another MOD function somewhere , please confirm that its the DATA MOD OFF setting that needs to be MIC for normal mic operation . Cheers Stu

I have both RS-BA1 and wfview installed. Here is how they behave.

With RS-BA1, Data MOD OFF is set to MIC/ACC when normally using the transceiver with local mike. When RS-BA1 remote connects, this is changed to USB to mute the microphone. When RS-BA1 exits, it restores the value to MIC/ACC.

What appears to happen with wfview is that it starts up with whatever is there (in this case MIC/ACC) when installed. If you have setup for server mode, it means wfview must have set this to USB to work. In this case, if it comes up with MIC in the radio, that is what is in the program, and it will not work as a server. It accepts the value from the radio as an override, it would seem. So you change it to USB manually on Radio Settings, then save/restart and it works just fine. So, now it’s time to wrapup and shutdown wfview. While it knew the setting was MIC when it started, it leaves the DATA MOD OFF alone on exit. This leaves the radio in a state where the microphone is unusable in local mode until you finally figure out why. For lots of folks, this is both a long and frustrating process not knowing or using all configuration elements.

A better way for wfview to work would be to have a startup setting (start in local or network mode), and to set DATA MOD OFF to the right setting. THEN, on exit, to put it back to whatever it found at startup. Of course a hard crash messes stuff up, but hopefully not as serious or frequent as could be.

A suggestion for a feature improvement may be floating around here somewhere to make wfview as good and yet better in many ways than RS-BA1.

73 Don

Hi Don.

This is an intentional design decision for wfview to not change any settings on the radio and to leave it to the user to make any changes that are required. It isn’t particularly onerous to go to settings and select the audio source within wfview. Personally I do not like software that forces the radio into a particular mode or setting as it is not always what the user wants. With wfview, you can be assured that the radio settings will remain as-is.

We do have a request in the queue to implement some sort of profile system but this becomes increasingly complex so is likely to be a long-term feature unless someone wants to volunteer to write it…

73 Phil

This is a problem with the IC-7300. For me it doesn’t happen all the time, just enough to be irritating. The only solution is to change the setting on the radio. I have this in my saved notes for future reference.

I haven’t had to deal with this problem lately since I have been using an IC-7610. This may be that the built in server handles things differently.

This works for me on my IC-7300.
(If needed, should also work with and IC-7610)

The problem… you try to use the IC-7300 radio without the remote and get no modulation on transmit.

The fix… from time to time this setting in the radio may change.

To use the local microphone Data Off Mode must be set to Mic or Mic, USB

Menu> Set> Connectors> Data Off Mode>
Mic or Mic, USB (next page on the list of options)

73… Ken - VE5KC

Hi Ken,

The same “problem” could be said to exists in reverse. You try and use wfview remote and get no transmit audio. Of course the solution is to change the modulation input.

I don’t really see it as a problem so much as I see it as just something that “comes with the dinner”.

For radios with three or four inputs (USB, MIC, ACC, LAN), it’s only natural that there will be times where it is set to the wrong input.

The radio is designed for this though, and has simple menu options to change the input, plus we have the combo box in wfview if you have that open, which can change the input as well.

One day we may make wfview so that it can automatically change the input when the program is opened, and change it back when it is closed, but it is not as simple as it sounds due to a number of assumptions that come into play and the kinds of errors one can easily get with automatic systems. I’m not opposed to making it simpler so long as it really is simpler, you see.

One solution you could try, and please do not try this if it is at all confusing, is to use only “data” modes with wfview remote, such as USB-D, LSB-D, etc. You set the data mod to USB Port (or LAN in the case of the 7610 and 9700). And you keep the not-data-mod set to MIC. The radio is definitely fine with transmitting voice audio from your PC microphone when using “-D” modes, it works just fine. The “-D” mode really is just another copy of the not-data mode with different settings applied. But then, you see, you must remember when you sit at the radio, to switch from, say, LSB-D to regular old LSB. Otherwise there would be no transmit audio! Is it easier to switch modes than to switch mod inputs? Maybe it is, but either way, you as the operator have to remember to check it.

It’s kind of how it is though, with additional capabilities come some additional levels of complexity. A radio with multiple audio inputs has to provide the user with a way to pick the method, and it can’t always be automatic.

I’ll remember this email the next time I’m annoyed with my fancy toaster oven and it’s convoluted, I mean fancy, menu system… tisk tisk.

de W6EL

for the shits and giggles, RSBA1 messes more with settings:

the 7851 for instance:

the scan stops.
it puts the rig in VFO mode.
It sets main/sub band tracking off.
it resets ssb/cw synch tuning to off
it switches off the calibration marker
It sets VOX off
it sets ci-v transceive on

none of the above is restored.

if you crash rsba1, the mod selection stays as is
if you wrongly exit rsba1, the mod selection stays as it
if you loose connection, the mod selection stays as is.

We’ll keep continuing the works of wfview and make it better
where applicable.

Before connecting with RS-BA1 save your configuration to the SD card. And then you can load it back and get all your settings they way they were before connecting through RS-BA1.
Doug – K0DXV