Transmit audio stutters using WSJT-X on Windows Surface

I cannot seem to get WSJT-X to transmit on FT8 correctly using WFVIEW on a Surface Go 3 tablet. The WFVIEW software seems to work fine stand alone, as well as with Winlink / VARA, but when trying to transmit with WSJT-X whenever the tablet transmits it seems like an echo or stutter occur. I have the audio settings set to 16 bit single channel with 48k sampling rate in WFVIEW. I have the virtual audio cables set at the same. I tried turning transmit delay to max but that didn’t seem to help.

I posted this in the IC705 page but there have been no real solutions. The only one that potentially worked was setting the audio to 8 bit but the audio signal on the 705 waterfall looks and sounds like crap when doing this. Any help anyone could provide I’d greatly appreciate it. If I can’t get it workng I may buy the Icom software, but would prefer not to if there is a simple solution I can try.

while I don’t know the wholse setup as I use linux, the stutter/echo is something that may exist if the
rigs monitor function is set to on. That gives and echo for sure. I know, a long shot but…

Hi Travis.

Which virtual audio cable software are you using? All of the free ones only provide a single cable. Although some people have made this work, it really isn’t a good idea as using a single cable effectively connects the TX and RX together. This can cause issues.

By far the best solution I have found is to use a commercial (paid for) option. I use Virtual Audio cable and have created a pair of cables:

wfview is then configured as below, this works flawlessly for me:

This may be the issue, the single virtual audio cable. I may try buying the a+b cable option that they offer. When looking at the settings in Windows I see audio on both the input and output when the radio hears audio. I was not even aware of this.

Are there any other virtual cable options other than virtual audio cable ?

Using the virtual audio cable a+b fixed the problem!! Now I seem to be having another issue where WFVIEW is randomly disconnecting from the radio…ugh