trouble using rpi 3b, new rasbian from rpi

I’m not an experienced linux user. Trying to load binary, got
ln: failed to create symbolic link ‘/usr/lib/x86_64-linux-gnu/’: No such file or directory
There are no visible x86_64-linux-gnu/… directories in /usr/lib/. but libqcustomplot2.0 is the newest version (2.0.1+dfsg1-1).
Then I tried compiling wfview; the make failed with multiple errors including
moc_rigcommander.cpp:98:1: error: ‘QT_MOC_L’ was not declared in this scope

make: *** [Makefile:849: moc_rigcommander.o] Error 1

Should it have worked on a 3B with a new Raspian OS?

Thanks, Bill AB4TC

Hi Bill

Those instructions are specific for x86 (PC) based linux, RPi is ARM based.

We will put together some specific Pi instructions.

73 Phil

Hi Bill,

We actually don’t have a binary out yet for the Raspberry Pi. I apologize that the download page doesn’t make it clear as to which systems this binary will work on.

If you feel up for it, here is a link to my build script. You will need to download it to your downloads directory.

Here is the script. Press the little “Download” arrow (far right side, just above the start of the script text, small downward arrow icon) to download it.

Once you download it, run the following commands:

eliggett@thinker:~$ cd ~/Downloads
eliggett@thinker:~/Downloads$ chmod +x 
eliggett@thinker:~/Downloads$ ./ 

Then just follow the directions, it will guide you in.

Let me know if this works – several others have said it worked well for them with the Pi.

de W6EL

Hi Elliot,

I have downloaded your have run it as new install and then rerun again with no errors.

Only whilst the make function there are two warnings.

Cheers Peter

Wonderful, thank you, Peter.

Always good to see the warnings, every environment is a little different.

de W6EL

Your welcome.

Seeing that the script creates a new folder setup base on date/time the “make clean” not necessary right.

Hi Peter,

You can run the script any time to grab the latest master code and build/install. Whenever you wish. Do check now and then that I haven’t released a new script though, as we may have some new dependencies in a few weeks.

And you can remove that folder it created (“wfview-20210525–xxxxx”) in your Download directory too, the program is now installed and you don’t need the extra copy in Downloads.

de W6EL