Tx on LAN ok, on Wlan no tx

Teh setup is like this:
Radio : IC-7300
Server : Rasbperry pi, wfview 1.6 server (connected to Windows 10 PC)

With a LAN connection there is no problem, everything works just fine. As soon as I use a W10 laptop with WLAN, the RX is okay, there is audio with reception, but the Transmit button does not respond.
The configuration is the same on both PCs. (I have checked this several times to be sure)

Is there something different in the configuration between LAN and WLAN?

Check if your setup allows to tx. That is a setting. In the client.

It also depends on the quality of your wireless network, many ‘home’ access points are not good at passing fast streams of UDP packets (like wfview uses) so they can get ‘bogged-down’. You will see this reflected in the wfview log as many retransmitted packets.

Having said all that, @roeland is correct that it sounds like either TX is disabled on the client, or you are using an RX only user profile on the server.

73 Phil M0VSE

Yes Roeland, The client config is Full User, so it can transmit.
Like I said, it works with LAN.

On the right bottom of the “VIEW” screen I can read :
Rx latency between 106 ~ 65 ms, RTT 2 ms en loss 0.
So these numbers are ok. I also thought it was due to the speed or the weak connection. But according to WFview, it’s all fine. I am also 4~5 meters away from the router.

I put the laptop next to the PC and I checked all the data step by step but they are the same. Of course I only log with 1 pc/laptop on the Raspeberry PI. So no two users are active at the same time

These are the client settings

the reason I ask for TX enable is that for me it’s not clear if your client is the same device you were using on WLAN or on LAN.

mesh networks are well known to break things UDP wise too.

I didn’t see a screenshot that shows TX enable on the client like this:


So in order to be able to help anyone we need to have the “full picture”

LAn and WLAN - it’s all the same for wfview. It does not care.

Sorry for the late response
That was the solution.

@ All,
Many thanks for your help and tips!

73 Hans, PD1AHM