Unable to connect Icom 9700 to Wfview

Hi All
Just seen this program but I cannot get it to work for me, The error must be me I am sure
Computer windows 11, Icom IC 7900 with IB board fitted works good
Installed program
Tried to connect using USB port.
Radio Connection Serial USB selected
Sertial Device set to Auto, com3, com 8 and 108.
com 8 and 108 used for another program
tried Auto nothing happens and 3 , log says port opened when i select 3
Also connect radio changes, changes to cancel connection
Thats as far as it goes
Any ideas what I am doing wrong
Many thanks for any help

Guys I solved the collection issue, it turned out by changing the USB cable it connected

Maybe other volunteers now will join the conversation and guide you further in the setup you have.

Hello All

This is a cry for help

I have a 9700

USB no mater what I do I cannot get anything to happen


Connected to 9700 RJ45 port to my switch

Setup Network 3 network selected

4 Where do I find this information?

5 control port 50001 got that

6 Username Where Do I find that information

7 Password Where do i find that information

8 and 9 got that

I have been trying everything but not the right way PLEASE can some one help me out

Many thanks in advance for the help and assistance.

Program looks fantastic on utube


Mike G4NVT

Take the 9700 manuals and make ntp to work first. Eg the automatic time set function on the 9700.

Set the user/pass as per the 9700 manuals.

Now you have user, pass, ip address.

And do not use usb to connect to the 9700 with wfview.


Thanks for the reply

The NTP is already setup, and its set as UTC local time is plus 1 hour

User/pass there are 2 I have set them both to username hello and password to hellohello

ip address i do not have but DHCP valiid after reset, ip address grayed out I have tried both but still nothing, I have powered off several times still nothing

Do you have any more ideas that I can try



The address will be and you should be able to ping the 9700, assuming you are on the same network. (and the 9700 in stby or on)


Yes I pinged the ip address from 2 different computers and it sent 4 packets and 4 were recieved back

What do you think if I reset the 9700 to factory reset and than reset up



And does it ping if it is unpowered? So not in stby but fully off?

In that case we know for sure the right address is found.

Do not reset the 9700.


I have not reset the 9700

powered off, did the ping, 2 timed out that 2 said address unreachable

powered onrepeated ping 4 sent 4 rec



That is good news.
Now you need to follow the settings in wfview, putting in the known user, pass, ip address. Also be sure to have the 9700 powered on, stby mode set. All the other stuff, set too.

I have followered the info but still nothing happens

In the network settings on the radio, what does it say next to “Network Control (Valid after Restart)”?

DHCP (Valid after Restart)

That isn’t Network Control, that’s DHCP. What does Network Control say?

NETWORK CONTROL (valid after Restart)

There is your problem, you cannot control an Icom radio over the network when it has Network Control off. Turn that on and restart the radio.

I was just reading the test you sent me, I turned in on and it works.
Its a Shame all the info that has appeared today is not on a setup sheet.
Many thanks for your help and others

Something like a `Getting Started’ guide? Getting Started | wfview