Under Manjaro Linux (Kernel 5.12.2-1)

wfview istalled after installing two dependencies very fast. Good job guys!!

I own a 7300, 9700, 7000 an G90.
Tested on the 7300 and 9700 simultanously. Works very good, absolut quick response, no overtake of the radio.
for the 7000 and the G90 (might work, because uses CI-V commands of ICOM) i have to do some wiring…

Two small points (most of the others are here in discussion):

  • wfview crashes when changing the theme
  • editable memory list would be useful. maybe switching the freq-input-window to memory window
  • importing / exporting the memories from / to radio via the sd-card would be an option

Will do more testing on next versions

Thanks for the work!

Jonas, DJ4WIL

Hi Jonas,

Did you compile from source or use a pre-compiled binary?


de W6EL

Hi, I used a pre-compiled binary
73, Jonas

Hi Jonas,

I don’t use manjaro, but I see that manjaro supports AUR.

Do you want to try this AUR package from source:


Let me know if it works,


Hi Elliot,
Will try it tomorrow ( as it is late here in Germany )
73 Jonas de DJ4WIL

Hi Jonas,

Sounds good. I could see a minor difference in qcustomplot versions causing us to jump to something invalid when you change themes. I hope that’s all it is.

Let us know how it works out,

de W6EL

Hi Elliot,
compiled from your repository Elliott Liggett / wfview · GitLab and the program runs fine. No issue when changing themes. Will do further testing.

73 Jonas

Wonderful, thank you.

Did you try the AUR by chance? I only ask because I don’t know if anyone has (except the author of the AUR of course).

Let us know if you have any issues or questions,

de W6EL

yes, the AUR works, too. Same result here.

73 de DJ4WIL Jonas

Nice, thank you for testing and letting us know.

de W6EL

Hi Elliot.

I wanted to tell you that I ran tests with the new release, Now the 756pro connects very easily, using the microKeyer and using the external mic input of the micro keyer wf funzina wonderfully, I can’t say the same thing for the 7300…I’ll explain: the 7300 configured with its Com 112000 baud port works all but I have problems making the mic work, whether it is usb or anything else as soon as I click on the transmit audio button it does not come out because on the list of audio cards to be configured there are only those dedicated to com 4 of the 7300 and therefore those of the icom. A little while ago I did a test by configuring 7300 using the microkeyer, and it all worked as 756pto. Now I don’t know if I have to download a special driver to run 7300 with WF. Another thing, the 756pro as I said works, connects I can use the external mic also usb, but there are functions disabled, type rtx tuner, the antenna change and the double vfo.

Thanks again for what you are doing, I look forward to your directions. If you need more information, I am at your disposal.

1 Like