vfview seems to keep CQRLog from getting info from the IC-7300 on a Raspberry Pi

I have been using CQRLog on my Raspberry Pi 4 with an IC-7300. I tried vfview so I could do remote operations through VNC. Once I got vfview working well, I tried CQRLog and it got no data from the 7300. I saw “After config of wfview , wsjtx doesnt work anymore - hamlib error, Dec '21,” The setting displays in that entry are not the same as the version of vfview on my Pi.

I don’t know the linkage between the software so I don’t know the settings. I’ve attached the vfview and CQRLog setting displays. Hopefully someone in this group knows how to set the linkages so CQRLog can work with vfview.

Two programs can’t use the radio directly at once. However, wfview provides some mechanisms so that you can share control of the radio. See our manual for details under “sharing control”

de W6EL

Thanks, Elliot. Hadn’t found the manual yet. I’ll search for it, get on it, and report back.

I found and followed the advice in Hamlib rigctld emulation | wfview. It was very clear but did not work for me. There may be some detailed parameter I didn’t get right. I have three screen-snaps of the wfwiew, CQRLog, and fldigi settings that do not work. I don’t see a link for me to attach or upload images.

Hi Bruce,

I believe your account on the support forum should allow you to post images. Try using the “upload” button when you write a post. It is the 7th button (from left) on the editing controls.

de W6EL

The most common ‘error’ with rigctld emulation is the port that it is listening on. By default, wfview uses TCP port 4533 so as not to conflict with any existing rigctld. Most software will want to connect to 4532 by default. It’s up to you whether to change the wfview port or tell your client software to connect to 4533 instead.


1 Like

also, if you enable rigctld and you are 10000000000% sure you won’t ever have a conflict
with another hamlib instance… you can change it.

however, be warned that many applications have hamlib in some form included in the software so be aware that even if you think it’s a good idea to change it to"hamlib default"… you may get into trouble.

Having a good insight/oversight on what device has what ip address, what ports are in used etc helps a lot.

Thanks, Phil, it was 4533 in wfviewer but 4532 in CQRLog and fldigi. I fixed it. Still didn’t work. There are two images attached that show the wfviewer and CQRLog settings pages.

The plot, she thickens. When I turn off wfviewer, I cannot get CQRLog and flrig (how I usually run fldigi) to connect to the transceiver. Before I got wfviewer to work, they both worked flawlessly. This is one image attached that shows the “before wfviewer” setting that has worked for years.

In CQRLog you have ‘Run rigctld when program starts’ checked. This tells CQRLog to use it’s own rigctld (not the wfview one) so turn this off.


In addition to what Phil said, which is very important, you should know that when you configure a program to work through wfview, the program will not work when wfview closes, until you reconfigure the program to work without wfview.

de W6EL

Thank you both. Phil, I turned off “run rigctl” in CQRLog. It still didn’t work. The image is attached. (The audio seems unaffected. QSSTV just presented a weird picture of a grinning pig on 14.200 while wfview was running.)

Elliot, when I shut down wfview and reconfigure CQRLog and flrig for direct USB connection to the IC-7300, they do not detect it. Frequency, Mode, etc. are neither seen nor can they be changed.

I wonder if some other interface go fried. Thirty years ago when I was a competent computer and software engineer, we had interface diagrams that showed the software API connection, parameter-passing, etc expectations of software. That apparently isn’t done anymore so I cannot understand what setting has which effect. Any suggestions for this conundrum?

(Thirty years ago I crossed to the dark side and became a project manager working on electric, gas, water and sewer systems and computer mapping, so I lost a lot of recent software knowledge. Now I’m retired trying to scratch my way back in.)

does wfview run on the same device where you run cqrlog? e.g. the raspberry pi?

Yes, everything is the same; same pi, same USB cable, same everything. I just start wfview as I did CQRLog or flrig before I tried wfView.

ok cool.

can you telnet to the rigctld port of wfview?
(e.g. start wfview, nothingg else)

My port is 7851 here and enabled

roeland@snowpa:~> telnet localhost 7851
Trying ::1…
Connected to localhost.
Escape character is ‘^]’.

so, any news here? Did you try this? Whats the result?

The only way to eventual give you help is by breaking the parts in pieces and check what piece failed.

This is the first thing. Can you connect to wfview’s rigctld?

Thanks, Roeland. The last week of the month has almost no play time in it so I’ve had to ignore my radios.

I entered “telnet localhost 4533” and got “connected to localhost,” Escape character, etc
4533 is the wfview Settings>External Control>Port

Not knowing the chain of connection, from the outside it’s acting like wfview fails to release software connection to the radio when I shut it down. flrig, etc, cannot “see” the radio even if I reboot the Pi.

BTW, it appears this weekend I’ll have some radio play time.

Mine works by putting in the cqrlog Device box. It didn’t work just putting in I have a IC7610 connected to WFview via lan. I use cqrlog as well for digital modes: JS8CALL, fldigi and JTDX. Following the excellent manual on this website, everything works great. Good luck.

1 Like

look at what Mike mentioned you. Now that to have the port released, you need to exit wfview software.

I start wfview; netstat -tunlp grepping on the port:

:::7851 :::* LISTEN 23211/wfview

and I exit:

(Not all processes could be identified, non-owned process info
will not be shown, you would have to be root to see it all.)


it goes like this:

rig <—> wfview – wfview ip address/port exposed

now, you must configure your software to talk to that IP address and port over TCP.

Now, we have seen that

a) rigctld works, exits fine
b) this means that your software connecting to wfview is not correctly config’d. See Mike’s response.

And if you want to exit:

exit / disconnect the software that connects to wfview
exit (!) wfview.

the port you see is the rigctld port 7851 – it’s not standard. The 7300 has 7300 as port. 9700 has 9700 as port etc

Thank you for your help Mike. It didn’t work for me as you can see. Since logging is more important to me than the spectrum display on the large display, I need to find a way to get wfview to release it’s grip on the interface so I can get CQRLog and flrig running again. Roeland seemed to have advice on that. Sadly it’s not clear to me what all that is. I’m not that deep into the gusts of Linux. I may have to make a fresh copy of HamPi and see if that disconnects wfview.

Thanks Roeland. You assume I have knowledge of the internals of Linux I do not have. There are about a dozen or so terminal commands I know how to use. Grep is not one of them. As I mentioned to Mike, at this point I’ll admit defeat. I just want to get rid of wfview, get it off the system if necessary, and let CQRLog, flfig, and other software work with my radio.