wfserver ini file

I have build a wfserver headless server for a Rockchip64 device running Armbian Bullseye. I am stuck trying to get wfserver to read the wfserver.ini configuration file. Starting the application as my userid or root doesn’t seem to make a difference.

I can’t use the server because I can’t figure out what the password is for the default Username user. What should I be trying?

In the debug output I see:

2022-12-19 13:24:33.822 "wfserver version: 1.53 (Git:8d3406a on Dec 17 2022 at 11:18:27 by dfrappie@rock64-1)\nOperating System: Debian GNU/Linux 11 (bullseye) (arm64)\nBuild Qt Version 5.15.2. Current Qt Version: 5.15.2\n"
2022-12-19 13:24:33.823 Loading settings from: "/tmp/wfserver-20221219132433.log"
2022-12-19 13:24:33.824 Loading settings from  "/tmp/wfserver-20221219132433.log"
2022-12-19 13:24:33.824 Creating new settings file  "/tmp/wfserver-20221219132433.log"

In the log file /tmp/wfserver-yyyymmddhhmmss.log I see what looks like the wfserver.ini file:



Hi Darrell.

The standalone wfserver really isn’t ready for any sort of testing yet and is likely to have many bugs, but the password is just password

73 Phil M0VSE


Thanks Phil,

I can now connect and get a reasonable waterfall, but no sound. The wfview client on Windows says: audio device was found. You probably need to install libqt5multimedia-plugins.

I see some discussion about that error that leads me back to modifying the ini file to select audio. It seems that I will need to wait for the code to be updated.

FYI Phil just pushed an update that I recommend you try out. The update is to the branch “server-fixes” and should ensure that the settings file is read in on startup. When you clone, use the argument -b server-fixes to specify the branch (or fetch, switch branches, etc, however you prefer to operate).

I’ve got a very beta document on how the settings file works with the server version. But keep in mind, as Phil said, this is a very new development. The documentation may be flat out wrong in some places.

de W6EL

I can confirm that the server-fixes branch does indeed read a configuration file. The default file is ~/.config/wfview/wfserver.conf It is not named wfserver.ini The program also allows specifying the file location. Program configuration files should be in /etc so that is where I moved the file.

sudo wfserver -s /etc/wfserver.conf 2022-12-20 11:08:35.442 “wfserver version: 1.53 (Git:e8142a1 on Dec 19 2022 at 21:03:54 by dfrappie@rock64-1)\nOperating System: Debian GNU/Linux 11 (bullseye) (arm64)\nBuild Qt Version 5.15.2. Current Qt Version: 5.15.2\n”
2022-12-20 11:08:35.443 Loading settings from: “/etc/wfserver.conf”
2022-12-20 11:08:35.443 Loading settings from “/etc/wfserver.conf”

Thanks for clearing up how to specify the configuration. When I have time, I’ll try to get it working to replace a Windows box as serving my IC-7300.

Hi Darrell.

Glad that it worked for you.

The configuration files are specifically NOT put into /etc as that is for system wide configuration files. As wfserver is currently designed to run in the foreground as a user with normal privileges, it is good practice for any files to be stored within the home directory of the logged-in user.

I would currently consider it a security risk to run wfserver under sudo.

Eventually wfserver will have an option to fork as a background service (daemon) and then we will likely store the configuration in /etc by default.

73 Phil M0VSE


I think we are in agreement, but for different reasons. Once I get wfserver working correctly, I will make it a daemon. The configuration files will be in /etc and it will log to /var.

I run wfserver with sudo to access /etc just as the install directions use sudo to install programs to /usr. Some argue that is a security risk to allow user programs into system paths. Since I can inspect the source code, I feel confident putting wfserver into a system directory and allowing it access to /etc & /var.

73 Darrell n3jwj