Wfview and SDR-Control

Hi all, so I’m running into an issue. Correct me if I’m wrong but, I understand the server computer will not have any audio coming out of it. I connected my SDR Control app on my iPhone and everything works except the sound. I can’t figure out how to get sound for the life of me. Secondly when I try wfview on a second computer, it connects to the radio but the display shows nothing, like how it is when you first open the program. Any ideas? Any help would be appreciated. Thank you.

Hi Mike.

It is really helpful if people tell us what radio, operating system and version of wfview they are using when asking a question.

Logs from both the client and server are also extremely useful, which is why we have added the ‘send to termbin’ option within the Log window. This generates a URL which you can then add to your post, allowing us to see exactly what is happening.

As for SDR Control, we haven’t done any testing with the wfview server so I can’t comment on whether it will work or not?

73 Phil M0VSE

Oh jeez. I couldn’t have been more unhelpful lol. Server is w7 32 and the remote is w10 x64. I had them flip flopped but got the same result. Radio is an icom7300. I’ll have the logs posted here in a minute. Thanks

HTTPS:// (remote)

HTTPS:// (server)

Hi Mike.

On the server side, the reason you have no audio is because you haven’t told the server where to find the audio!

2023-03-14 09:54:47.026 INF audio: "Server Audio input device Speakers (High Definition Audio Device) [Loopback] found! "
2023-03-14 09:54:47.026 INF audio: "Server Audio output device Speakers (High Definition Audio Device) found! "

In wfview → Settings → Radio Server you need to select the USB audio codec for both RX and TX audio.

As far as the client is concerned, this is your problem:

2023-03-14 10:29:11.353 INF udp: Error obtaining IP Address for : "IC-7300 WFVIEW" :  "Invalid hostname"

This means that in wfview → Settings → Radio Access → Hostname, you have entered “IC-7300 WFVIEW” this should be the IP address of the server computer!

73 Phil M0VSE

Thank you for the help. What should the audio system be? PortAudio, QT, or RT?

It really depends on what works for you. I generally use QT, but if you have issues with that, try one of the others.

Still haven’t gotten the audio side figured out. Here’s the termbin link again.


It’s still showing the wrong devices? In the Radio Server tab, you need to change:

“TX Audio Output” to “Speakers (USB Audio CODEC )”
“RX Audio Input” to “Microphone (USB Audio CODEC )”

Then “Save Settings” and restart wfview.

73 Phil

Sorry, I have it set to those now. Still no audio.


I’m getting audio on SDR control. That’s all I could ask for!! I don’t really need it on the host computer. I appreciate all the help.

You will never get audio on the server computer, it merely passes it through to the client.

Glad that it’s working though.


Right. I guess I have 1 last question that you may be able to help me with. If not no worries. On SDR-Control I’m having bad RX loss on audio packets 2.75%. I know you don’t work with it, just curious if you might have an idea as to why my loss is so high. The audio is very choppy.

You can try one of the other audio systems, other than that it is very difficult to say.

Changed to RT. Works great. I can’t tell you how much I appreciate having someone to help me out. I may be a millennial but I am absolutely technologically inept. This has been a huge help. Thank you so much.

1 Like