Wfview beta release 1.2e available

Hi all.

As part of our ongoing release schedule, we have produced a binary release of the current wfview code v1.2e. for testing and evaluation. This has gone through extensive testing within our team but please let us know of any issues that you discover.

Highlights of this release

Completely rewritten UDP handler which should be more stable and support connecting to/from Icom Remote Utility.

Completely rewritten audio handler. Now supporting the option to select from QT Audio, RT Audio or PortAudio handlers. These have different benefits depending on your hardware and application. QT Audio should work fine for most users but try one of the others if not.

About box updated to include Patreon site
Added 500 Hz step for VFO
Added clock and UTC toggle.
Added forced manual RTS setting
Add RIT function and other rigctl fixes
Adjusted window size for radios without spectrum. Thanks K5TUX.
Allow dynamic restarting of server
New Settings tab
Enable High DPI Scaling
More multi-radio support
Many rigctl improvements/cmpat adds
N1MM+ TCP connection added
Various other stability improvements

73 Phil M0VSE

One other feature is the ability to split or combine spectrum/waterfall data.

This feature is quite difficult to explain but basically Icom rigs send their spectrum data differently depending on your connection to them. USB connected rigs separate the spectrum into 13 individual packets that then must be recombined by the receiving software. LAN or WLAN connected rigs send it all in one large packet.

We have found that certain software expects one format or the other, the scope function within N1MM+ being a good example. This expects USB format packets, so it is impossible to get the N1MM+ scope to work with a network connected rig (until now!)

We have added a feature to the External control settings menu which allows you to select which format wfview will send to other programs (via virtual serial port or the newly created TCP server port). Either Default, Single (the same as network connected rigs) or Multi (the same as USB connected).

73 Phil M0VSE


First i want to thank for all the nice work the WFVIEW team is doing !

I have installed the 1.2e beta version, but i have no audio with this version ? I see the waterfall and S-meter moving but i hear no audio.
(No TX and RX audio , i have have tried chamged several settings, also played with the squelsch and volume settings, but no luck, what do i wrong ?)

BTW Im using a IC-9700 and tried it on either a windows laptop (W11) and on a MAC, both have same audio problem.!?

If i start the older version of wfview everything works okay again.

  1. Chris

Hi Chris

Can you try selecting the audio input and output again as it is possible that they have changed? Try changing them to another device and then select the ones you want to use then click save.



Sweet, I can’t wait to give it a try. I been using the last beta with no problem.


I did try changing several settings, but noluck (audio) only with older version.
I will try some more things tomorrow

73 Chris

you can select three different audio stacks – each stack may require a new audio device selection.
The stack selection itself only works when disconnected by the way.

The documentation by the way didn’t add that you need to include a few extra libs – it’s fairly self-explanatory.

(I need to spin up a few clean setups and fix that part anytine soon when time permits. You know. sometimes work is more important ;-))

Just to clarify Roeland’s point, the additional libraries are already included in the 1.2e release builds for Windows and MacOS, the additional libraries (portaudio and rtaudio) are only required for Linux.

HI again,

just played with the settings, i have now audio working, ‘‘Audio System’’ set to ‘‘PortAudio’’ is the only thing i needed to change :wink:

I think this what Roeland meant with ‘‘audio stacks’’ , but this term didn’t rind a bell for me. i Think the term Audio Stacks = Audio System in the menu Radio setting , and this setting can only be changed when not connected to the transceiver :wink:

Screenshot of my setting:

That’s great Chris. Yes we should really try to be consistent with naming :slight_smile:

One of the main reasons for creating the option to select which audio system (API) to use is that we found some hardware just didn’t seem to work with QT’s own audio API so by giving the option of PortAudio and RtAudio, hopefully this will allow everybody to find a setting that works for them?

73 Phil M0VSE

Hi folks,
I installed the1_2e and all the functions I use come up and seem to work, except for the audio
dropdowns… Running WIN7… Home Premium and PRO

-Jon - WB0VTM

Hi Jon.

When you say the audio dropdowns, do you mean that no devices are listed? Worth trying one of the other audio systems, RT Audio and PortAudio. If you disconnect from the radio, you should be able to change this and it will rescan for audio devices.

73 Phil M0VSE

Just upgraded to 1e on my USB-connected Server (ubuntu 20.04) and Remote (ubuntu 22.04) laptops. I’m happy to find the arrow keys working for frequency movement, but… Would it be possible to have them active when mouse focus is other places besides the dial wheel? I find that whenever I click on the wheel to activate the arrows, the frequency invariably changes. On CW that can be a significant shift. Perhaps the arrows could be active when focus is in the spectrum or waterfall, or even the frequency display?
It’s looking great! Thanks.

1 Like

compiled the new 1.2e yesterday the same way as the 1.2d.
always used the actual ./
problem is now that 1.2e is 2x larger than 1.2d and fills now more than the whole screen.
system rpi4 / xubuntu 20.04 (as far as i rememer correctly.
any hint what to do to get normal size?
73 Michael