Wfview freezes with N1MM Rotator or LP Rotator

I have the radio configured to COM4 and control it through Wfview,
When I try to rotate the rotator with either LP-Rotator or N1MM Rotator configured to COM2 Wfview freezes. How can this be when they run on different com-ports? Any ideas to get it working?
The computer needs to reboot to get it back online with Wfview.

The radio is a IC7300 and the computer is running on Win 11


This is what I get from the log file when trying to restart Wfview (before rebooting computer)

Can we see the entire log file please? I agree this doesn’t make sense, but there’s some strange stuff in your log file as well.

de W6EL

OK. Thank you. The first logfile is produced from when I start Wfview start until I try to turn the rotator. The second logfile is from where I try to restart Wfview after the freezing.

First off, turn off the UDP server in wfview (unless you are using it). That is intended for a second copy of wfview on a remote computer. Keep it off for now while we figure this out.

Otherwise though, it seems that wfview is only using COM4. I don’t see anything grabbing any other ports.

de W6EL

OK. I turned off the UDP server. I have a remote connection so I normally use it. But I can turn it off for troubleshooting. I can reach the server computer with VNC.
Yes, Wfview only uses com4. But that is to be expected, right? The icom driver is assigned to com4 as I can see in device manager.
The strange thing is that wfview freezes when the other program accesses another comport.

Not sure if it is related, but there are a lot of error lines in the logfile regarding the codec…?

While I do see some errors about locating audio devices, I am not sure if they are related.

All I see related to your issue is

2024-01-07 17:38:05.459 INF serial: Could not open serial port  "COM4"  , please restart.
2024-01-07 17:38:05.459 INF rig: Error using port  "COM4"  message:  Could not open port. Please restart.

2024-01-07 17:38:05.460 WRN default: QIODevice::write (QSerialPort): device not open

I’m not a windows user, but if one program opens and it causes another program to lose access to the serial port, does this not suggest a driver issue? Or perhaps the other program is configured incorrectly? On linux I would suggest looking at the kernel messages and also logging from lsof to see what might be trying to use the serial port.

Perhaps someone with more windows knowledget can chime in.

de W6EL

In older windows and DOS systems, serial ports 1 and 3 and 2 and 4 used the same interupts (irq’s) I am not sure if the modern windows systems are still the same but worth exploring .
Why not try a different port and see if if solves the issue.

Peter MM0CEZ

Yes. I have a vague memory of that too. I moved the com port to no end.
I’ll dig some more. But perhaps I should look for another rotor solution.

wfview settings
Settings-External Control
Is COM4 used by IC-7300 set in the “Virtual Serial Port” item?

If it is set, please change it to another unused port.

Tried that. Not working

Time to close this thread. The problem is not solved. But I’m certain this is not related to Wfview. It’s probably an hardware problem with the new computer. I’ll go back to the old computer and take it from there.

Do let us know if you find something, it may help other users. Plus I’m curious.

de W6EL