Wfview runs for a few mins then stops

Back here at my winter home after 6 months absence I updated Wfview to the latest version. When I start it up it works fine for about 5 minutes or so and then stops. Only changes I made to my WIN10 system was a change from USB to Bluetooth audio. I don’t have any problems with the other software I use with the 9700. This happens while running Wfview with no other programs running in the background.
If I disconnect the Ethernet port a few times and turn the 9700 off and back on it will restart for another 5 minutes or so. Any thoughts?
73 Jeff kb2m

Hi Jeff,

Does wfview stop or crash?

Can you send us a log file?

I have left it running for days at a time trying to catch things like this :slight_smile: , so I really appreciate any kind of crash reporting you can offer.


de W6EL

Here is the log data a few entries so I just put it here…

2023-11-25 14:13:50.537 INF udp: CIV Watchdog: no CIV data received for 2s, requesting data start.2023-11-25 14:13:50.546 INF udp: Audio Watchdog: no audio data received for 2s, restart required?2023-11-25 14:13:50.546 INF audioconverter: Closing audioConverter() Input: 1 Channels of 0 48000 Int16 Output: 2 Channels of 0 48000 Float2023-11-25 14:13:50.550 INF audioconverter: Closing audioConverter() Input: 2 Channels of 0 48000 Float Output: 1 Channels of 0 48000 Int16

Could you follow the link Elliott sent?

Share the output link

Here ya go…

73 Jeff kb2m

1 Like

You have an incredibly high number of missed/retransmitted packets. I would suspect a problem with your network. Do you have any bridges (wired or wireless) between your PC and the rig?

Older versions of wfview didn’t implement the Icom retransmission protocol correctly, so it may have appeared to be working OK (while dropping lots of packets) so I would definitely recommend fixing the root cause of the issue (network)


Interesting. I’m hardwired directly to the router with the computer I’m running Wfview on. I have 0 issues with any other programs I’m running. Also I didn’t have this issue at all with the older version of Wfview.

73 Jeff kb2m

I run a lot of programs, Satpc32, DXLab suite, WSJT-X, JTAlert, Chrome, a time server, email, etc but the issue also appears when I running Wfview alone with nothing running in the background. Tomorrow morning I will try the log capture again with Wfview running alone. Thanks for the help…
73 Jeff kb2m

None of which will stress a network anything like wfview. UDP audio streaming is one of the most demanding applications that you can run on a network, and can easily expose weaknesses not previously known.

As an example, for 48KHz 16bit audio (both TX and RX) there will generally be around 200 UDP packets transmitted between wfview and the rig per second. This is why UDP streaming is often used to stress-test network connections!

As I said in my last message, depending on which version of wfview you used previously, it might not have correctly handled retransmissions, so although it may have appeared to be working, it would be losing a lot of audio data.


I have the 9700 running with WFview for over 6 hours on my laptop that is on the same LAN as my desktop. I also decided while I was messing with WFview to get my 705 running via WIFI with WFview on my laptop. I think the problem is with my aging desktop that is next in line to be upgraded. Now, maybe sooner then later. I worked on this for several hours and for the life of me I can’t find out what the issue is. But all is working with the laptop, and that is where I normally run WFview anyway. So all is good. Odd thing is that I run a Flex 6500 with SmartSDR on the same desktop and that works flawlessly for days. Thanks for the help Phil…

73 Jeff kb2m

I had similar problems with a not so old but cheap HP desktop running a non-Intel processor. The problem was related to poor handling of USB ports. I switched over finally to a much older Dell laptop and problems disappeared with all working normally!

Rick, W2JAZ