Windows IC-705 TX Audio dropouts

I am trying to get WFVIew working with a Dell Lattitude 12 Rugged tablet model 7202 running the latest update of Windows 10 and an Icom Ic-705 via the WLAN (firmware ver 1.30).
I’ve set the IC-705 up as an access point and the 7202 tablet connects directly to it via wifi, there is no additional wireless devices or AP.
Running the Icom RS-BA1 software works flawlessly for several hours at a time using WSJTx (latest version).
With WFview, (again latest version 1.5) initially it starts off working perfectly, then, over a period of time which seems to vary from about 2 minutes to up to 8 minutes, the packet loss shown in WFview increase dramatically and the TX audio from PC to radio stops working, RX audio from radio to PC never fails, nor does CAT control.
I’ve tried adjusting the latency up to maximum, that does not make any difference, nor does trying an earlier version of WFview I tried 3 earlier versions, 1.2 c/d/e I think.
This packet loss happens even without Wsjtx running , so just WFview and the wifi connection to the 705.
I have tried using the free VB audio and the non-free Virtual Audio Cable, and exaclty the same thing happens, I also tried my spare Dell 7202 which is running Windows 11, again fully updated latest version and get exactly the same issue.
For some reason, on both 7202’s I am only able to use ‘Port Audio’ , selecting either QT audio or RT audio results in no packet errors, but no tx/rx audio either, when I look in the logs says something like ‘input no channels found aborting setup’ and/or ‘RTAPI get device info: invalid device index’
This is identical on both Dell 7202’s so I have to at this point use portaudio.
In the log file, when it starts to go wrong, I am seeing countless entries of udpAudio : sending (multiple packet) retransmit of “0x xxxx” where the last four ‘x’ are hex characters.

Can anyone suggest anything I can try to get WfView to run for more than a minute or so, or anything I can try to use QTaudio or RT Audio to see if that helps?

I have tried both connections to the 705 using either CATV or FTTH neither help.
If I physically connect via USB, then everything works perfectly for the 2 hours or so I tried it, but for me, Wlan is the way to go as it is so much easier.

Anyone any suggestions please.

Kind Regards

Hi Tony.

I’ve set the IC-705 up as an access point and the 7202 tablet connects directly to it via wifi, there is no additional wireless devices or AP.

There’s your problem. AP mode on the IC-705 just isn’t stable enough (as we have stated MANY times on here!) I use a commercial grade (Cambium) access point and have zero problems.

73 Phil M0VSE

as an addition to what Phil says:

sometimes it’s stable if you are near the rig, like 1m apart from it. If it’s 5m you’re almost out of luck.

Hi Phil,
Thank you for the reply, I would be inclined to agree as it the only thing I don’t have two of to eliminate, except it works fine on both 7202’s using the RS-BA1 and the 705 I have, I tried it on the windows 10 one and the windows 11 one, they both ran for at least 2 hours without any issue whatsoever (unfortunately, it isn’t my copy of RS-BA1 so I am unable to use long term, it it was purely a test).
This was using exactly he same hardware setup, i.e. no router, just radio connected to the 7202 and that works fine.
The only difference may be that the RS-BA! uses it’s own Icom virtual audio cable driver.

The 705 and the tablet are no more that 12 inches apart on the same desk next to each other.
Using an additional piece of hardware is not really practical as ultimately the system will be used for SOTA, so reducing the weight carried is a priority.
I guess the only real solution will be for me to get a copy of the Icom software, which I am loathe to do, but it does work with just radio and tablet.

Tony G1HMO

Ok as a test, I changed the 705 to station, and put an HP access point up on the desk too, both the IC-705 and the Dell tablets are now going through the HP access point.
It is much much worse, the loss shown on the Wfview screen does not start at 0/xxxx with just the second set of numbers counting and the zero staying at zero for a while before it gradually starts climbing, on the access point, both sets of numbers start counting up straight away.
There is no internet / router / firewall connected to the AP, just the AP and the Dell and IC-705.
If I ping the IP of the IC-705 from the tablet, I get solid pings around 2 ms, but looking at the bottom status line in WFview, it is showing rx latency of 750 -820ms.
Again the same sort of numbers are shown on either Windows 10 or Windows 11 devices.

Tony G1HMO

if you connect it to your local wifi setup, be also sure that you are connected to one router/AP. Multiple access points also definitely f* up the sound.

Now you can also use different audio codecs, you have RT, portaudio, qt audio.
Disconnect first from rig before you change; else it won’t be possible to change it at all.
and after the change, reconnect.

the 705’s weak point is wifi for sure.

Hi Roeland

Nope, only a single AP no other network connectivity at all, it definitely seems worse when on the AP than when connected locally direct to the device at least directly connected via Wlan it starts off fine for a minute or so which it does not do when on the AP.
I seem unable to use any other audio codec beside Portaudio, selecting RT audio or QT audio fails, there doesn’t seem to be any dropped packets, but there is no audio either.
I am running Windows 10 and 11 on different devices but on either device, selecting QT audio or RT audio produces no audio, looking in the log, there is a vague message about requiring to install libqt5multimedi-plugins and RtApiWsapi::getdeviceinfo: invalid device index if I choose any format other than portaudio.
Googl’ing those errors, seem to only find stuff relevant to Linux, which I am not running here, so I am assuming that QT audio and RT audio are linux based and not Windows?

Tony G1HMO

all three work. there is no difference between the functionality in linux, macos or windows. even the new vs old mac hardware.

the plugin libqt5multimedia… is linux specific though. No worries there.

Regarding the choosing of different audio stacks – you also need to (re)select the audio devices.
I use linux so I hardly install it on windows so I tend to forget how I get things working.

So maybe just disconnect, use qtaudio, try the audio devices,
if it fails try the other(s).

Phil is more of help but for this very moment a bit busy so I try to get the stuff working there for you.

Hi Roeland

A quick update, I spent most of Boxing Day trying to get WFview to work, QTaudio and RT audio fail, nothing I did would make them work, portaudio will work but only for a few minutes before the errors start creeping up and I lose TX audio.

The fact that I never lost RX audio i.e from radio to tablet, it was always the TX audio that stoped, I decided to install TWO virtual audio cables, one I then used for TX (Line 2) and the second for RX (Line 1).
This time when I selected QTaudio it worked there was no invalid index message in the log file, in WFview, the bottom line showed 8/6648754 after leaving it running for several hours.
As I test, I removed the second set of virtual audio cables, and tried again with QTaudio, it failed with the error message in the log invalid index.
So, back to two sets of virtual audio cables and I am up and running again, this is with the IC-705 setup as the AP and the Dell tablet connected to the IC-705 via wifi, there is no additional AP connected, just radio to tablet, the radio and tablet are about 2m apart on the desk.
I have tested this setup in both Windows 10 and Windows 11 using Dell 7202 tablets

Tony G1HMO