Wireless problems while using Wfview

Howdy all,

My experience with Wfview is somewhat limited and pretty much trouble free since installing it on both a Win10 laptop and a MacBook Pro while using FreeDV and an Icom IC-705

Yesterday I had a problem Using FreeDV and everything was working very poorly.

Choppy communication to and from the IC-705 and Wfview, or between the IC-705 and the wireless router.

Also, when I attempted to transmit, The IC-705 became “stuck” in transmit such that the only way I could return to receive was by rebooting the radio. It didn’t matter if I was at full power or no power.

Transmit commands were being send from FreeDV (and then WFView) and it would transmit but it wouldn’t “release” the PTT

Then I tried Wfview by itself and the same thing was happening…it would become “stuck” in transmit. sometimes closing WFview would release the IC705 and sometimes it wouldn’t

All very strange.

As it turned out, It wasn’t FreeDV, WFView or even the IC705 that was the problem. It appears to have been the wireless router (TPLINK AX1800)

Once I rebooted the router all was good in the “Network Neighborhood”!

This is the second time I have had to reboot the router because a bunch of weird things happened that appeared maybe RFI related or loose connected USB cords

The point here is that when you’re having problems like this and everything worked before, the natural tendency is to blame the newest piece of software if there is one (or RFI) !

In this case, it was clearly the wireless access point. The IC705 and maybe the IC905 are probably the most prevalent (wifi capable) radios out there

I would say ICOM, Kenwood, Yaesu, Elecraft and others will be increasing the number of wifi capable radios they offer in the future.

It might be useful at this point to maybe discus access point/router settings and/or different models of WIFI routers and access points that possibly work “better” than others

I recently bought wifi operable door locks for my house and they worked with one router but wouldn’t work with a different one.

I don’t think it was (wifi) channel congestion because I live on 2.5 acres and my neighbors are pretty far away from me. (I also had no microwave ovens running around me)

Anyone else with similar experiences?


Hi Rick.

My experience has been that ‘consumer grade’ wireless access points often aren’t that good at handling large numbers of UDP packets (which is what the Icom protocol uses) and can often become ‘overwhelmed’

As networking is my job, I tend to always use commercial grade wireless devices from companies like HP(Aruba)/Cisco/Ubiquiti and more recently Cambium. They are more expensive than TP-Link and similar ‘consumer’ brands, but are able to handle high volume traffic much more effectively. I rarely see the sorts of connection issue that many IC705 users report.

As an example, for 48KHz 16bit audio (both TX and RX) there will generally be around 200 UDP packets transmitted between wfview and the IC705 per second. This is why UDP streaming is often used to stress-test network connections!

73 Phil M0VSE

I’ve had issues with consumer grade Wifi in the past, on the WiFi side those issues disappeared when i went with a Ubiquiti access point.

That said I’m now fighting with Unifi controller having an issue with a Raspberry Pi.
I need to re-boot the controller for the Pi to get a lease back.

Today I’m trying a static IP on it, will see how it goes… but i digress.

Consumer networking gear is really actually often terrible.

Here I run Asus routers with whatever the latest OEM firmware is. I have one main router with both 2.4 and 5 GHz WiFi, and a second access point running on the other side of the house, connected back with gigabit ethernet. Additionally, there are several gigabit switches at various places. I like Asus, they are very flexible and the firmware lets you ssh in if you wish to fine tune things.

With effectively four access points, each on different non-overlapping channels and with different SSIDs, it is easy for me plan my network out so that no access point has too many devices connected through it. Additionally, a lot of my equipment is just using wired ethernet, such as the Amazon Firestick, VoIP system, desktop computers, printers, and so on.

If I were in a situation where I had a radio performing poorly, and WiFi was the only means of connectivity (such as the IC-705), I would simply buy another access point (likely from Asus, but choose your own poison here), stick it on a clear channel, name it “RADIO_AP”, and only let the radio connect to it. I’d locate it reasonably close by as well. With a dedicated AP, it really gives the device the best chance.

Ok, that’s my 2 cents. I’m not a network wizard like our other admins on the forum here, but what I’m doing seems to work pretty well.

de W6EL


Asus routers here. Actually three running in a mesh network along with a private VPN on the main router. Asus has been great and has kept providing updates long after other companies have abandoned their products.


I know that these cheap access points are not the best. My problem happened after working well for several days.

Then I connected “the next day” and had the problem until I rebooted the router. After the reboot, everything works ok.

I didn’t disconnect or remove any other wireless devices I had running after the reboot either.

I am thinking I might put together a separate wireless access point and only connect 2 devices (IC-705 + the computer running WFView) and see how that works.

I can also connect the laptop using an ethernet cable and only use the IC-705 connected via wireless.

(I wish ICOM had also included an ethernet port!)

I should also add that the TP-Link router I have is also dual band. I also tried the Macbook connected via 5GHz wireless and the IC-705 via 2.4GHz. (I sure wish Icom had included 5GHz wireless in the 705)



@VK3LOL If the Raspberry pi only has 2.4ghz, make sure “Band Steering” is disabled, so it doesn’t try to move it to 5Ghz. I had the same issue with a wireless camera, once I turned that off, it connected fine.

@HT32BSX115 I used to use a TP-Link router. I would have to reboot it occasionally, although I had the same issue with a netgear router as well. Some of our wifi devices would be connected, show full signal, but couldn’t communicate.

On the TP-Link router, I ended up overwriting the firmware with DD-WRT and after that, no wifi issues. Since then I’ve moved to a Ubiquity system with 4 access points to cover my house and shop building. No more wifi issues since.

+1 for Ubiquiti, have their router, cameras and Wi-Fi on a 1Gbit connection

Probably got their subscription too eh?

Not trying to shit on your Asus setup, but the reason i moved over to commercial grade gear is to avoid exactly the things you need to do to run a smooth network.

With Ubiquity i can have a single SSID and have things work perfectly and have devices switch from one AP to another if they move about the house.

As for subscription… what do you mean?
Not aware of any subscription.

I can do the same with the SSID, but I prefer not to so that I can partition my devices around the network the way I want. That was kind of my point about the radios. Put the one radio with the flakey wifi implementation on its own AP.

I’ve run a lot of ubiquity equipment in the past. It’s great stuff. In college we built a UAV and had several ubiquity APs on the ground to track it. Really quality equipment and I also liked the built in analyzer feature.

What I don’t like these days is their shift towards subscription pricing, for example, requiring Unifi Cloud Controller, etc. I get it, most features work fine without this stuff.

With the asus stuff, you can indeed tweak and tune to your hearts content. There are pages and pages of parameters in the setup UI and even more if you just ssh over (it’s just Linux after all). I feel like it’s a good balance and the stuff works quite well.

I’ve been a lurker here and have never posted. I’m not sure how to send a post that is a new topic so I’m piggy-backing on another post.

I’ve been trying to setup my IC-7300 for remote access. I’ve tried several methods - each with their own set of problems.

I just installed the latest Windows 64 release 1.64 on a Windows 11 machine. I am connected via USB to start with. Configuring audio has me confused. I have this devices:

  1. Microphone USB Audio CODEC (IC-7300 audio source)

  2. Speakers USB Audio CODEC (IC-7300 audio input)

  3. Microphone Realtek High Definition Audio (Ready) (Computer audio source)

  4. Front Headphone jack Realtek High Definition Audio (Computer audio playback)

I have #1 set to listen (Playback through this device:) to #4

This is where I get confused. I have #3 set to listen (Playback through this device:) to #2

But I can’t get any audio from the computer into the radio. My brain is old and I’m sure I’m missing something simple. But whatever it is I’m just missing it.

Thanks in advance for any help.

73, Doug – K0DXV


The reason you are confused is because it’s confusing. I have no idea how I got the audio to work correctly, but it finally did. I am running on Mac OS but W11 is similar. I am attaching a word document I just made of my settings. Server pictures are first; client are second. In “Host Name”, the local IP address of the server goes there. If you are remote, you must have a static IP address and the Static IP6 address goes there instead. I have successfully remote controlled my 7300 from Spain, but lost connections because the Spanish IP provider changed my IP or blocked it. Hope this helps. I am sitting on my back porch logged into my shed so I know these work. I also use RemotePC to display the server on my Macbook and tht works fine for listening. I have not tried Tx yet with a RemotePC connection,


(Attachment Wfview setup Mac OS.docx is missing)


This reply will be worthless to you but at least you know someone replied.

I have used WFView for a month now. It has worked well pushing an Icom IC-9700 across the Nation, NM to NC. Right out of the box it worked well. I am on Windows 11 and I have used the suggested WFView settings.

I think it is a good dependable product but who knows.

Evans NM5ER


Are you running your own wfview server?

If so, we need the details.

If not, there is no need to configure audio in wfview since it is not supported for your configuration. Audio is only needed for situations where you are either running a server or connecting to one.

Make sure to read the documentation and FAQ.

Let me know if you have questions,

de W6EL

Thanks for the reply but I’m still confused. I am running locally through USB as indicated in my post. I’m doing this as a first step before attempting to remote the IC-7300. I understand that audio is outside the control of wfview. I’m asking for a knowledgeable user to offer advice. Logically, I feel I have audio configured correctly. The USB microphone input from the IC-7300 is “listened to” by headphone jack input and the headphone jack microphone is “listened to” by the IC-7300’s Speakers USB Audio. This seems logical to me but obviously I’m missing something. I’m just not getting any audio into the IC-7300 and I’m unsure why.

Thanks, Doug – K0DXV

Wfview does not use the audio system unless you are running a server or network client.

There is no way to “test it out” with just one instance running.

Wfview as a server is effectively a streaming audio server. How can you test a streaming audio server? By running a client to connect to it. Locally you 100% will not be able to tell if it is streaming audio correctly over the network.

Please read over the documentation carefully and see if it makes sense.

Wfview running once on once computer connected to an IC-7300 DOES NOT HANDLE AUDIO IN OUT OR ANY OTHER WAY.
Any appearance of audio settings should be ignored when running Wfview via USB to a 7300.

The audio comes out of the radios speaker…

–(disregard the name and icon of the audio devices, these are my customizations)
You can check the ‘listen to this device’ in windows options.
This will cause the psuedo microphone that is the 7300 to be played back in real time to your default audio output.
This has nothing to do with Wfview.

Now… if you wanted to set that machine up as a server to server the operation of the 7300 to a seperate computer those audio settings you see bet used on the 2nd computer.

You would first setup the first computer with Wfview and the 7300 in the [SETTINGS] tab →

This is where Wfview samples the audio from the radio to send to a client device, so here you’ll choose the IC-7300’s audio devices.

Then on another computer you select what speaker and mic you want to use to hear the audio you send/recieve to/from the other Wfview server.

1 computer connection to an IC-7300 on a USB port… that Wfview doesn’t touch audio (unless you’re setting that Wfview up as a server).

The fact the settings are there kind made it look like they are needed to be set, but this is only if you are connecting to another Wfview or to a radio with a built in network device (705 for example, but not 7300).

The manual does describe it pretty well… must admit I’m not one for manuals, but the Wfview one is pretty good.