WSJT-X and WFVIEW on Ubuntu 20.04

Has anyone successfully run WSJT-X with WFVIEW on Ubuntu 20.04?

I have it set up according to the user manual instructions. The rig control is working properly, and WSJT-X can receive and decode signals. I cannot find a combination of the audio output and WSJT-X output that creates a power out on the transceiver.

The lists of audio cards do not match the ones shown in the manual. Through experimentation, I found setting the WFVIEW Audio Output to sysdefault and WSJT-X input to alsa_input.pci-0000-00_1f.3.analog-stereo works for receiving.

I’ve checked alsamixer and other are two loopback cards listed. I set the level of both to 100, but still no power out on the transceiver.

Any suggestions for fixing this?

TIA

Jim

Are you running your own wfview server or just a wfview client? What radio? What OS?

Elliot,

I’m running the WFVIEW client connecting to an Icom 7610. The 7610 has the current 1.42 firmware.

My OS is Linux Ubuntu (Pop-Os actually, that comes with System76 laptops). This is at version 20.04. Pop-Os is a derivative of Ubuntu.

Jim

To add more details
WSJT-X is version 2.6.1 and WFVIEW is version 1.64.

The options under WFVIEW Audio Input are:

That is helpful.

Please make sure the IC-7610 audio input is set to “LAN” (assuming you are connected over LAN and not a usb port). You can make this audio input change using the Radio Settings portion of wfview.

Enable the secondary meter as “TxRx Audio” so that you can see if it is moving when you transmit audio from WSJT-X. If the TX Audio meter in wfview moves, then you are sending out audio to the radio.

This configuration can work, you’ll just need to play with the audio settings a bit.

–E
de W6EL

Hello,
You have to set up WSJT-X and WFVIEW on Ubuntu 20.04 to receive signals and control your transceiver successfully. You’re facing an issue where despite configuring WFVIEW’s audio output to sysdefault and WSJT-X’s input to alsa_input.pci-0000-00_1f.3.analog-stereo, there’s no power output from the transceiver during transmission attempts. You’ve adjusted alsamixer settings for loopback cards but haven’t seen improvement.