WSJT-X over remote server Icom 718

Have the rigctrl option enabled without any virtual port config in wfview server side but getting a PTT State Error when testing CAT in WSJT-X on the remote client.

Anyone any ideas?

Not sure where to look for this error … any help? This is locally on the pc with USB to radio. wfview works fine using the com port.


Did you restart wfview after changing the rigctld port?

Yes. I also see the connection open in netstat.

Could this be an Icom 718 PTT over RTS thing?

Yes quite possibly as I don’t think it was ever tested with rigctl (as none of my rigs need it!)

I’ll see if I can duplicate it.

Can you try VOX on the 718, and uncheck RTS, just to see if that gives you a temporary workaround?

de W6EL

Thanks for your reply. Unfortunately same error in WSJT
Oh wait… i need to enable it in the 718 …

No same error

Hope you find the time to look into this.

Was playing around with virtual ports but no luck.

We will test this out some more with our V2 testing.

As for the version you are running, I kind of doubt we will get to fixing it, if I am being honest. But there may be a workaround.

Can you confirm that PTT commanded within wfview (client side and server side) works?

de W6EL

Yes I have the server and client setup to transmit via the button on client end using a usb mic. Made some contacts and even short skip was more fun than ever :stuck_out_tongue:

I’m all for a workaround even.

WSJT also works on the server pc ( setting icom 718 and RTS PTT with same com port) if wfview is not running.

I think you should be able to use the virtual serial port (see our manual) on the client side. You will need to lie to WSJT-X and tell it your Icom supports a CI-V (“CAT” in hamlib radio parlance) command for transmit. I believe, and I could be wrong, but I believe at the server side, we will intercept a PTT command and change it into RTS if the “Use RTS” checkbox is checked on the server.

Since WSJT-X and hamlib know the 718 doesn’t have a CAT command for PTT, you will have to tell it you have an IC-746, IC-7000, IC-7100 or IC-7200. You then need to go through the IC-718 menus and set the CI-V address to be the same as an IC-746/7000/7100/7200 (see the owner’s manual for the radios). This is because the backend of WSJT-X uses hamlib with hard-coded CI-V addresses.

Then wfview will have to contend with thinking the radio is the wrong radio. But that should be ok since these radios have similar commands. You just need to make sure the CI-V address is manually put in and correct for how you have set it, at both server and client sides.

It will be far easier to mess this up than to get it right, so proceed carefully.

de W6EL

First, a real big thank you for your time, effort and commitment in all this!

Second, tried your workaround but did not get it running. On the server pc, when configured with address 56 (ie Icom 746) and use model as address, wfview connects fine, but does not transmit even though RTS as PTT is selected. When only using the hex address, wfview sees it as 718 with just a different address. WSJT does not test ptt successful (using CAT as PTT) in both scenario’s with virtual port created and selected in wfview settings. This also applies to address 76 (7200).

On the remote pc I basically did the same thing to create a virtual port, configure this in wfview but also there WSJT was not able to test PTT successful.

For fun I just tried the direct as possible solution again on the server pc to have wfview see the 718 with default address and run WSJT on the same pc with virtual port for Control, RTS as PTT and 718 in settings. To my surprise it tested CAT successful although it took very long and any attempt after that failed unfortunately and also took long. During these attempts the freq in wfview jumped back and forth to 28.074 and the freq wfview started up with.

Possibly any other suggestions or time to duplicate and verify my outcome?

BTW: I noticed echo over wfview coming from the usb speaker on the server pc? If I lower the volume on that device, the echo removes but so is the power output …

The audio issue is part of how the 718 handles audio. I don’t think you can do much about it other than putting a headphone jack in to mute the speaker. It’s not the only Icom to have this issue.

As for your initial issue, we are going to put our focus on getting version 2 out which should address this.

I have a 718 with the xggcomms adapter and I’ll be testing it.

I’m surprised vox keying didn’t do the trick, but maybe the vox sample location is not seeing the ACC audio.

de W6EL

I do use a headphone jack in the radio to silence the radio speaker but the echo is coming from my remote mic over wfview on the remote end. When not transmitting, I hear my mic with some delay?

Looking forward to V2!

It’s a manifestation of the same issue. In V2 there is “forced half duplex” mode which may take care of this.

Ok Thanks, I volunteer to test V2 if that may help any :slight_smile: