Client on PC to control 7300 partly working

I have setup a server on a Windows 10 pc to control my 7300. On the server pc I see the waterfall and can control the 7300. On the cliënt side is a Windows 10 laptop. Both computers run v1.1a on a local network. On the cliënt side I see the 7300 frequncy and the s-meter Reading… The audio can be heard. Changing frequency, band, mode is not possible and no waterfall is visible. What setting have I missed to get the cliënt fully working?

73, Fred

Hi Fred,

On the client, is the radio model listed as “NONE”?

You might need to re-enable “CI-V Transceive” on the radio, or, on the client, manually define the CI-V address.

de W6EL

on the client setting tab I have set the Manual Radio CI-V address to 94. Now I can change the band, frequency etc but still no waterfall… The rig is shown as NONE.
I think I am almost there, any suggestions?

I noticed that I loose contact with the server as my server pc goes into sleepmode due to inactivity… Can this be eliminated by wfview? When I run the WSJT-x program the sleepmode is also eliminated and my pc stays on. Shutting down WSJT-x returns my pc into sleepmode after a period of no activity.

73, Fred

Hi Fred,

If the rig name is staying as “NONE”, it means wfview has not received a reply to our query to the radio. You might want to close down both sides (server and client), power-cycle the radio, and try again. Receiving that rig-type reply is really important, without it wfview operates in a sort of “limp mode” where you only have partial functionality.

Are both sides running the same version of wfview?

With regards to computers falling asleep, I suggest just changing your computer’s energy settings to allow it to stay awake when you’re using it as a server. Mine is set that way, and I’ve had wfview running for weeks on end without any issue.


de W6EL

Running wfview 1.1a on both Windows 10 machines.
On the server side the radio is detected as ic-7300 however at the client side it shows NONE. Can control the radio at the client side but no waterfall is visible.

73, Fred


I have had the same problem. Took me a couple of days to find out I hade a logging program connected to the CIV port on the 7300. When started, that program changed the CI-V transcieve to off. The server still worked but not the remote client. Had to restart radio, server and client to get it running. Just changing back to transcieve on was not enough.

George SB7S

Hi George, Elliott,
I have set the 7300 CI-V Transceive to ON,powered off and on the 7300, restarted both computers, launched wfview 1.1a on both PC’s. The server shows IC-7300, the client NONE.
In both server and client I have to manually set the radio address to 94 otherwise no contact with the radio. There is also a CI-V USB-REMOTE Transceive address in the 7300 that is on 00h.
Don’t read any reference to this setting in the manual so assume this is not relevant.
How about the CI-V USB Echo Back setting?
The client stays on NONE what ever I do while everything works on the client side except for the waterfall.
Checking the 7300 CI-V Transceive setting ON No program overwriting this setting.
Any further suggestions?

73, Fred - PA3BZT

Just a long shot… there is a setting in ic7300 ,link to remote or unlink from remote. That must be set to unlink.

I also know some software uses the same port range 50000-50003. The screen sharing software Anydesk caused me a lot of gray hair in RS-BA1 remote before I changed ports. That can give very unpredictable results.


Hämta Outlook för iOS

I think George is on to something, have a look here at these setup directions, please make sure each item is per the presentation:

de W6EL

So far I have not managed to get the rig type shown on my client pc. Like I explained before, the sound and control to my 7300 works fine from the client, except no waterfall.
Decided to give it another try and have installed version 1.2a on both of my Windows 10 pc’s .Both pc’s are on my local network.
Checked all the 7300 settings based on the document link. All settings meet the requirements.
The server is working fine, the client too except rig type is still shown as NONE and no waterfall.
In the server I see Server connections: Control:1 CI-V:1 Audio:1.
Closing the wfview client program, these Server connections all change to zero.

I have no idea how to fix the problem. Any help is highly appreciated. I like the concept of wfview.
Anybody with a 7300 rig, two windows 10 pc’s, local newtwork, has managed to get wfview fully operational?

73, Fred

Hi Fred.

Yes that is exactly the configuration that lots of users have and I have written much of the server and client code using a similar configuration (ic705 over USB rather than ic7300). If the rig type isn’t showing then that is almost certainly because CI-V Transceive is disabled in the rig (or some other setting is incorrect).

At this point, I would probably recommend taking a backup of your rig and then reset it to factory defaults. Then enable CI-V transceive and see if wfview works.

If you EVER use any software that uses Omni-rig, this WILL disable CI-V transceive.

73 Phil

1 Like

Yes I use the same configuration and it all works fine.I had to do the same as Phil adviced you. When trying to use it outside your LAN (remote) - you must check that the ports are not used by other services.

I saved the 7300 settings (all) to my sd card, did a factory all reset , load my previously saved settings back, restarted the 7300, and the two pc’s. The result, still no Rig shown on the CLIENT side and no waterfall.
When switching CI-V transceive to off, the wfview server frequency display is delayed in following the 7300 dial knob. Switching it on again the 7300 dial knob is displayed in wfview server w/o any delay.

The only thing left is maybe to change standard ports 50001-50003 to something else. Any suggestion to change this to? Is there a way to check if one of the Ports is in use by another program in Windows?
On the CLIENT side I only see Radio Control Port (50001) can be changed.

73, Fred


I have changed my ports starting on 55001. On the client you only change one port. The rest will asume the 2 ports above I think. I changed mine not to interfere with RSBA-1 and I have some leftovers from Anydesk that dont want to go away. Anydesk is a big virus for Hams since it uses the same ports as RSBA1, win4icom and WFview. Given me some gray hairs as well.


thanks for your information. I have set the ports to 55001, 55002 and 55003 at the server side and at the client side changed the port to 55001.
I have not used Anydesk on both pc’s so far but I think it is even better not to use the standard ports that other Ham Radio software are using too.
I restarted both pc"s but the result was still the same, Rig type NON and no Waterfall.
So for me this means there is no other program that uses the standard port 50001.

I decided to take a closer look to the wfview CI-V address setting.
I configured the wfview server settings at the first release of wfview and had to enable the Manual Radio CI-V address as my 7300 was not dedected automatically. By enabling Manual address setting and using 94 the Rig type was detected on the SERVER side. Same for the CLIENT, I had to use Manual otherwise no frequency display and audio came through.
I decided to disable the manual address setting on both server and client side to see if wfview is automatically able to detect the rig type. Re-started the server first. The Rig was shown as IC-7300. Did the same at the CLIENT side, and by surprise the rig type was displayed and the waterfall appeared too!

So far so good. Now let"s see remote operation is working.
I normally use LOG4OM and WSJT-X with Omnirig. I know Omnirig disables CI-V Transceive but I believe another beta release will cover this issue.
I guess when using Rigctld to share COM3 with Omnirig will result in a disable too(?).

73, Fred

Phil, is the Omni-Rig thing common on all the supported rigs or is it an issue in the 7300 ini file for Omni-Rig?


Fred, in windows control panel, Power Options, change settings (in the plan your using), change advanced power options, go into USB settings and turn off selective sleep mode for the USB ports. That will keep the USB connection alive as long as your computer doesn’t go to sleep. If you want the computer to stay awake when plugged in set sleep, sleep after, when plugged in to none. Then you might want to set the display to time out after being on for a while. This might be an issue depending on how they are scanning the server computer display. Some programs return a blank screen when the screen goes to sleep. If this is the case you’ll just have to Display to not turn off (in the same settings screen on windows as the USB and Sleep settings - down to the bottom).


Hi Mike, Welcome to the forum.

Yes there is an issue with all versions of wfview and OmniRig (hopefully other than 1.2b which will be released later today).

wfview tries to detect and block OmniRig’s attempt to disable CI-V transceive, but when I wrote the original code, I didn’t realise that the command to do this is different for every supported rig!

In 1.2b wfview takes a more complete approach to this which should stop CI-V transceive being disabled.

73 Phil M0VSE

Thanks Phil,
Glad to hear that, I really hate hamlib.