Display resolution?

Hi all,

I have a 705 which I have got work well with Wfview on the desk top through WiFi using an full HD monitor…

I tried this morning to use my HP laptop which has a recommended display resolution of 2736x1824… Wfview connects and work but the frequency display and buttons are squashed and not fully visible… I can obviously go into the screen settings and change to an HD format aspect ratio which then works as per my desk top… But I’d prefer not to keep changing the settings when I use Wfview if possible…

Anyone else had this and found a work around?

Many thanks

Dave de G7EPE

1 Like

Hi Dave.

This is a known issue with High DPI displays. I have the same issue on my Microsoft Surface 6. The issue is because by default your Windows scaling is probably set to something like 200%. If you change it to 100% everything will be displayed correctly ‘but’ it will probably be very small!

One workaround is to set the environment variable QT_AUTO_SCREEN_SCALE_FACTOR to 1

Eventually we will make wfview High DPI aware and it should be able to resize areas of the screen to account for this but the workarounds above should work in the interim.

This site describes the process of changing Windows environment variables How to change environment variables on Windows 10 | Architect Ryan

73 Phil

Thanks Phil,

I’ll give the environment workaround a go :+1:

Great it of software, very much enjoy using it…

Thank again

Dave de G7EPE

@phil Thanks for the tip. I have the same issue as I have a 4k screen on my Lenovo X1 Carbon laptop. I keep it set to 225%. Anything above 150% causes the “view” screen to overlap individual elements. Figured I’d add the “me too”…

1 Like

Hi Dave.

Yes the environment variable workaround should help with this. High DPI display support is much better in Qt6.2 which should be released in just over a month. I have begun testing wfview with a beta of Qt6.2 and so far it is working but obviously we won’t be able to base a release of wfview on it until after it is released.

73 Phil M0VSE

Hi Folks,

I just “discovered” wfview over the weekend, and I’m having a blast – like a child with a new toy! First post here…
I have an IC7300 USB-connected to a small ThinkPad laptop with remote access set up. This box seems to work perfectly. (Running version 1.2d on Ubuntu 20.04).
My “remote” machine is a larger laptop, also running wfview 1.2d on Ubuntu 20.04. My only issue here so far is the forementioned font sizes for the Freq display, Meter, and slider labels. The native display resolution is 3840x2160 with 200% scaling. The fonts at this scaling/resolution overflow the respective box. I’ve tried various scaling/resolution settings, and nothing changes the window “overflow”. Same with Gnome Tweaks and changing the font sizes. Not a huge issue, but it would be nice to see the full freq readout and a couple meters. Any clues? Thanks!

Hi Don,

I’m glad you’re enjoying it as much as we are!

Have you tried Phil’s suggestion?


You might have to undo some of the font tweaks to see the effect.

de W6EL

Hi Elliott,

I saw Phil’s suggestion, but I must have been in a caffeine deficit – I thought it was Win10-specific. I just tried this from the Ubuntu command line, and wfview comes up beautifully. Don’t I feel like a clone! :wink:

Thanks tons, this is great! …DonA N4TH

Hi Don,

It’s all good man, some portion of the commits to our codebase come from similar incidents.

de W6EL

I use WFView on a Win10 Dell 13 inch laptop with the 1920x1080 display scaled to 125%.

Freq readout looks OK but Signal strength fonts have the top of the letters cut off.

Followed the linked guide and tried setting my QT VAR to 1. Also tried 2 and 3. No changes at any value. Closed and reopened WFView each time.

Signal strength fonts still have the top of the letters cut off. Changing scale and layout from 125% to 100% does fix the problem but everything else is too small.

Anything else to try?

Hi N3umw,

Did you log out and back in to make sure the variables are set? Was the variable named “QT_AUTO_SCREEN_SCALE_FACTOR” ? Just checking.

de W6EL

Thanks W6EL.

I cut and paste variable name “QT_AUTO_SCREEN_SCALE_FACTOR” to make sure it was correct.
Closed and reopened system properties to verify it was set to 1.

Log out win10 or WFView? Rebooted PC and closed/opened WFView multiple times.

WFView is beta version but that should not matter.

What is QT?


QT is a collection of libraries that we (and many others) use to do things like draw buttons on the screen or manage network connections and other common things like that. It is a very nice kit and is cross-platform, so we can compile the code on many different operating systems without any changes.

If the beta is recent, I wouldn’t expect any issues.

If you were to set your scaling factor to 100%, does the issue clear up?

de W6EL

Hello Sir,

Hate to bother you, really, but if you could help me out would

be most appreciative.

Have a brand new Icom R8600, and would like very much to use it with your wfview.

My eyesight isn’t too great anymore (in my mid 80’s now), so the

possibility of controlling the program from my pc screen would truly be great.

But, I’m lost in configuring the program (and probably also the radio to get it to accept the program commands)

I guess the first question is: am I using the correct rear radio Port ?

Remote Control Jack:

Connects to a pc for remote control using using CI-V commands

I have a cable from the USB B Type B Port):

Connects to a PC

Outputs the decoded FSK…

Outputs the demodulated AF Signal

Interface for the optional CS-R8600 or RS-R8600

Intertface for the remote control by the CI-V commands

Or, should the cable go to the IQ Data Output Port:

Outputs I/Q data

Connect a USB


a. What would you suggest for (all) the Settings in the Program ?

b. Do I have to select COM Ports, or does “Auto” do it all ?

c. Is there some setting in the radio menus to tell it to allow Control from your program ?

Let me say again how much I appreciate your time and help.

If I can get your program working, would really help
me use the radio a lot. Eyesight a real problem these days.

Best regards,

Hi Bob,

Yes, the radio has to have some things set up. For the most responsive experience, we recommend only connecting to the radio over Ethernet. But you can use USB if you wish. When using USB, we just need the CI-V capability. We do not need I/Q and we do not need FSK. You’re going to want to go with the most default and benign settings you can come up with for the Icom menus. I don’t have an R8600 myself, so you’ll have to be patient with me while I guess what to do on there. I can tell you that many people use that particular radio with wfview.

You will not need any of the OEM Icom software when using wfview. And you must not try and run both at the same time – that isn’t a configuration we have tested.

wfview is pretty friendly with screen readers and accepts lots of keyboard commands, so once you get it up and running, you may well find it is easier to use the radio from wfview than from the radio (for most tasks). And of course, you can run the waterfall on as large a screen as you wish.

Let me know if this helped any. We’ll figure it out.

de W6EL

Yes, works fine at 100% if I could see that small!

Beta is latest version and works well.