Icom 7600?

Has anyone got Wfview to work with a 7600? I’m getting cat to work. But no audio.
Is it worth troubleshooting or is Wfview just not compatible with a 7600?
73’s - Ulf - SM0NOR

hi Ulf,

we haven’t tested the 7600 but there should be no reason not to work…

How did you connect the rig? Did you select the right audio devices?
What OS at the server side and what at the client side?

Hi Ulf,

The IC-7600 does not provide a waterfall output for wfview to display, so essentially you only get basic radio controls. If you set up a Raspberry Pi or a normal PC as a “server”, then you can remotely access the radio controls and the radio’s audio over the network using wfview, which should work pretty well.

What is your use case?

de W6EL

Clarification. There is no audio and no control.
Client side says “found radio at address…IC7600 model ID 122”.
That seems to be correct. So, there is some kind of connection.
At server side, I can control the radio with Vfview.

Yes. I now there will be no waterfall for 7600. Thinking of getting a 7300 for the remote QTH. Meanwhile I wanted to play around with it with my 7600.

Ahh ok.

Can you tell me what operating systems you are using for the client and server, and what versions of wfview are at each side?


de W6EL

Okej. Thanks.
Server side is Win 10 21H2 and client side is Win 11 22H2 RC
Wfview is 1.2e on both sides.

It seems like you are close.

Can you verify that the ports (all three) are definitely the same on each side? Make sure the radio has CI-V Transceive turned on and is using the default CI-V address (makes things easier).

If all that checks out, can you send us your log files from the server and the client?


de W6EL

Deafult ports on server side: 50001, 50002 and 5003. On the client side there is only one box; Control port = 50001. On the radio CI-V adress is deafult; 7Ah Wfview only accepts 7a. CI-V Transceive is set to ON.
Cannot attach logfiles. "New user cannot attach files!

I will see what I can do about the new user limitation, sorry about that. The next version of wfview lets you send the log file with the click of a button!

I usually recommend not checking the “Manual Radio CI-V Address” box; rather, just let wfview find the radio. This way you will not find the radio if CI-V is malfunctioning. To be clear, both checkboxes under “CI-V and Model” should be not checked. These checkboxes are generally for older radios that don’t respond to our CI-V Rig-ID query.

Can you make sure you can ping between the two computers?

de W6EL

Ok, I bumped you off the “new user” group, hopefully you can attach files now.

de W6EL

Alright. No, I can’t ping them. I’ll dive into that and resolve it.
Then it may work.
I’ll get back when I got the pinging to work

Sounds good.

de W6EL

Pingning now works. Changed Inbound rules in defender settings. Still Wfview is a no go…
Attaching logfiles
Logfile client.txt (1.8 KB)
logfile server.txt (2.1 KB)

Hi Ulf,

Thank you for the log files. It seems like both copies of wfview are still set to manual CI-V addresses. Can you try setting them to automatic by not checking the two boxes under “CI-V and Model”? Possibly you will need to press “Save Settings” and re-start the program.

The reason this is important, is it will establish if we are really able to talk to the radio on the server side properly or not. When we manually assign an address, the program proceeds as though communication is fine, but it may not actually be the case.


de W6EL

OK. Now the control works.
Still no audio. But I’m working on that!

Great progress!

I noticed in the log file the audio devices were, in some cases, specified as blank strings. Make sure that after you select an audio system (QT, Port, or RT), you then re-visit the audio device combo boxes and select the correct audio device on your system. Then press “Save Settings” to save this setting for future use. FYI the audio device and audio system cannot be changed during a connection.

You can check the log file for a string like this: INF audio: Audio Input device . Make sure it has the right device. If you add or remove devices from your computer, you may need to re-launch wfview and might even need to re-select the correct device.

Let us know how it goes. I’d really like to see your 7600 working with wfview.

de W6EL

Just to add, on the server you must select the audio devices within the radio server tab not in the main radio access tab (this is really only for network connected radios like the IC-9700, 705 etc.)

73 Phil M0VSE


I also see you are running 1.2e, there is a problem saving the server audio devices with this version. I would recommend replacing wfview.exe with the latest weekly build from Index of /public_builds/

Or you can wait a while as we are poised to release 1.5 imminently!

73 Phil

That is a time saving advice! :slight_smile: Less combinations to try in the trial-and-error process :slight_smile: