Installation on Ubuntu 21.04

Hi all, I tried to install wfview on ubuntu 21.04 and when I try to give the command: sudo apt install libqcustomplot2.0 libQt5Multimedia libqt5serialport5 gives me error libqt5serialport5 library not found, the same thing with the command sudo ln -s / usr / lib /x86_64-linux-gnu/ /usr/lib/x86_64-linux-gnu/, any suggestions?


I see two problems. I see you can’t find a required library – I’ll check if I have mistyped the name there.

secondly – I am not sure – some package managers don’t install anything if an error occurs and the softlink itself definitely fails if libqcustomplot2.0
is not installed. So I’ll spin up an ubuntu 21.04 image and let you know.

can you in the mean time do a separate:

sudo apt install libqcustomplot2.0
sudo apt install libQt5Multimedia

If these work, can you redo the softlink command without the spaces:

ln -s /usr/ lib/x86_64-linux-gnu/ /usr/lib/x86_64-linux-gnu/


Hi Roeland , I have already tried to give single commands
sudo apt install libqcustomplot2.0
sudo apt install libQt5Multimedia
libqcustomplot2.0 installs it without problems while for the libQt5Multimedia package it always gives me the error.


Hi Antonio,

I may be way ‘off base’ with this but I thought the package was called libqt5multimedia5 (all lower case)?

sudo apt install libqt5multimedia5

73 Phil

Hi Antonio,

Could you please tell us the output of this command:

apt-cache search serial | grep qt

It may help us find the exact package name.


de W6EL

ok. I’ll redo the 2104 install ina vm and copy/paste what I wrote. Given me 30 minutes and I can confirm
the issue – hopefully with the fix.

I’m at work right now, I’ll let you know when I get home.


Hi all, I am trying to install the software on Ubuntu Mate 20.04.2 but when I give the command:
sudo ln -s /usr/lib/x86_64-linux-gnu/ /usr/lib/x86_64-linux-gnu/
tells me that the package cannot be found, suggestions?

thaks for the report. I recall I messed up the install instructions.

Can you tell me if the installing of the packages work? I know that some package managers will not install anything if there is a single package not found. So let’s split into three installs:

sudo apt install libqcustomplot2.0
sudo apt install libqt5multimedia5
sudo apt install libqt5serialport5

sudo ln -s /usr/lib/x86_64-linux-gnu/ /usr/lib/x86_64-linux-nu/
(that’s a single line)

start wfview

can you specify where it fails? Eventually copy/paste the whole text.

fails with this line

sudo ln -s /usr/lib/x86_64-linux-gnu/ /usr/lib/x86_64-linux-nu/

This is the error:

ln: failed to create symbolic link ‘/usr/lib/x86_64-linux-nu/’: No such file or directory

Hi Antonio,

Sometimes the filename is slightly different. Can you try this to help narrow it down:

ls -l /usr/lib/x86_64-linux-gnu/customplot


de W6EL

ls: cannot access ‘/usr/lib/x86_64-linux-gnu/customplot’: No such file or directory

It looks like libqcustomplot isinstalled in a strange place? OK try this command:

find /usr/lib -name "libqcustomplot*" -print

73 Phil M0VSE

1 Like

iz2twx@iz2twx-desktop:~/dist$ find /usr/lib -name “libqcustomplot*” -print

ok. you can now modify the link yourself with the right paths. something like

sudo ln -s /usr/lib/aarch64-linux-gnu/ /usr/lib/aarch64-linux-gnu/

1 Like

by the way. my ubuntu 21.04:

roeland@ubuntu:~$ cat /etc/release
VERSION=“21.04 (Hirsute Hippo)”
PRETTY_NAME=“Ubuntu 21.04”


roeland@ubuntu:~$ locate

weird that we differ here

Just fyi - I had the same identical issue with Mint 20.1. Correcting the path/filename fixed it. Thanks.

1 Like

Hi, It depends maybe on whether you use 20.04 as update or fresh install.
I had the same issue and found that the line given for Debian 11 contains the right path for Mint 20.1 to create the symlink.
73 and keep up the good work!
Peter - PA0PJE

1 Like