Mac OS 12.5 with M1 processor

Is there anybody running Mac OS Monterey version 12.5 for both Client and Server for Wfview 12e ? I have been trying for a week - but do not succeed with the sound.
Can anybody give me som help regarding settings for the sound that might help me?

Hi Pal

I have similar problems with the latest M2 silicon. Strangely, I got sound for a while with the previous Wfview, but now have lost it with vers 12e. I seem to have a choice of 3 audio systems, none of which work:

If I select QTaudio, there is no sound and the log file says “You probably need to install libqt5multimedia-plugins”
If I select Portaudio, I get a crash in Wfview and its log file says:
2022-09-08 16:37:02.253 INF audio: PortAudio version: PortAudio V19.7.0-devel, revision 147dd722548358763a8b649b3e4b41dfffbcfbb6
2022-09-08 16:37:02.253 INF audio: Pa_CountDevices returned 4
2022-09-08 16:37:02.253 INF gui: Got Server Audio Input: “”
2022-09-08 16:37:02.253 INF gui: Got Server Audio Output: “”
2022-09-08 16:37:05.103 INF audioconverter: Closing audioConverter() Input: 1 Channels of “audio/pcm” 48000 Float 32 Output: 1 Channels of “audio/pcm” 24000 SignedInt 16
2022-09-08 16:37:05.103 INF udp: Closing UDP stream : “” : 50003
2022-09-08 16:37:05.104 INF udp: Closing UDP stream : “” : 50002
2022-09-08 16:37:05.104 INF udp: Sending token removal packet
2022-09-08 16:37:05.105 INF udp: Closing UDP stream : “” : 50001
2022-09-08 16:37:05.105 INF udp: Starting udpHandler user: “ICOM7100” rx latency: 150 tx latency: 150 rx sample rate: 24000 rx codec: 4 tx sample rate: 24000 tx codec: 4
2022-09-08 16:37:05.109 INF system: Received CommReady!!
2022-09-08 16:37:05.109 INF system: Skipping automatic CIV, using user-supplied value of 136
2022-09-08 16:37:05.109 INF default: Setting rig state for wfmain
2022-09-08 16:37:05.109 INF default: Setting rig state
2022-09-08 16:37:05.110 INF udp: UDP Stream bound to local port: 55909 remote port: 50001
2022-09-08 16:37:05.601 INF udp: udpHandler : Received I am here from: QHostAddress(“::ffff:”)
2022-09-08 16:37:05.601 INF udp: udpHandler : Received I am here
2022-09-08 16:37:05.606 INF udp: udpHandler : Received I am ready
2022-09-08 16:37:05.606 INF udp: udpHandler : Sending login packet
2022-09-08 16:37:05.612 INF udp: Got connection type: “WFVIEW”
2022-09-08 16:37:05.612 INF udp: udpHandler : Received matching token response to our request
2022-09-08 16:37:05.612 INF udp: udpHandler : Detected connection speed WFVIEW
2022-09-08 16:37:05.618 INF udp: udpHandler Received radio capabilities, Name: IC-7100 Audio: ICOM_VAUDIO CIV: “0x88” MAC: 0 : 144 : 199 : 48 : 49 : 58 CAPF 20481
2022-09-08 16:37:05.618 INF udp: Got Connection status for: IC-7100 Busy: 0 Computer IP “”
2022-09-08 16:37:05.619 INF udp: Got Radio 0
2022-09-08 16:37:05.619 INF udp: Find available local ports
2022-09-08 16:37:05.620 INF default: Received serial port baud rate from remote server: 4800
2022-09-08 16:37:05.621 INF system: Delay command interval timing: 120 ms
2022-09-08 16:37:05.631 INF udp: Starting udpCivData
2022-09-08 16:37:05.631 INF udp: UDP Stream bound to local port: 64157 remote port: 50002
2022-09-08 16:37:05.632 INF udp: Starting udpAudio
2022-09-08 16:37:05.632 INF udp: UDP Stream bound to local port: 61698 remote port: 50003
2022-09-08 16:37:05.633 INF audio: Input PortAudio handler starting: "AK5370 "
2022-09-08 16:37:05.633 INF audio: Output PortAudio handler starting: “”

If I select RT Audio, there is no sound and log says:
"INF audio: Output Device exception: 1870411512 : “RtApiCore::getDeviceInfo: device ID is invalid!”
2022-09-08 16:32:31.780 INF audio: Output *** Attempting to reconnect to audio device in 500ms
2022-09-08 16:32:32.281 INF audio: Output RTAudio handler starting: " "

This keeps repeating.


I found on this Ubuntu page

that the correct name for the plugin is:

Package libqt5multimedia5- focal (20.04LTS) (libs): Qt 5 Multimedia module [universe]

5.12.8-0ubuntu1: amd64 arm64 armhf i386 ppc64el s390x

Package libqt5multimedia5-plugins- focal (20.04LTS) (libs): Qt 5 Multimedia module plugins [universe]

5.12.8-0ubuntu1: amd64 arm64 armhf i386 ppc64el s390x

with the extra “5” at the end - just trying to use the ‘brew’ command to install, but it can’t find any of these plugins. Hopefully the experts here can help us.


Thanks for info Tony.I have tried the same - same result. I Hope as you that an expert on mac and wfview can give us some hope.


No that is not a fix for this problem!

Wfview contains all of the necessary qt addons. That message is only relevant for Linux users who manually install qt.

I don’t currently have a machine running this version of Mac OS and the current package is built on Big Sur.

I will try to investigate this issue as I suspect something has changed in newer MacOS versions.

73 Phil M0VSE

I’m running on a MacBook Pro M1 with Monterey and IC-7610, no problems, audio QT Audio.

73, John N1JM

Ok. That means your are using the server in the ic-7610, and the Mac as a client. I am using ic-7300 so I need a separate server which also is an Mac M1 with Monterey. Perhaps the problem is in the server part? Thanks for info. 73 Pål La7hm

There is an issue with server audio device details not always being saved correctly in 1.2e, this is fixed in newer builds, but we haven’t released this yet. You will probably need to wait until we release a build. Alternatively if you have a Linux machine (RPi 4 or similar) you could use that as the server and compile the latest source using the provided build script.

73 Phil M0VSE

Hi Phil

That shouldn’t be my problem as I am using a mini-PC and W10 for the server, and Macbook Pro M2 Silicon for the client. I have got some audio by going back a version or two, but only receive, not tx.
I have played with so many different combinations now, I am getting confused, particularly as it’s an IC7100 and you have already told me there may be problems with its USB i/f - too many variables!
I can try other clients as well - later.
Remote PC works quite well with HDSDR, and shows waterfall and received sound, but I need Wfview for the transmit audio.


Hi Phil. I have an raspberry pi mod4 so I will install linux version and trye this in the weekend.
Thanks 73 Pål la7hm

Hi. I have tried to install wfview on raspberry pi but at end getting this message:Press enter to start.
Starting build process.
qmake: could not find a Qt installation of ‘’
Error in qmake step.

Tried to run it twice. same result.

That usually happens if you already have Qt4 installed,


sudo apt-get install qt5-default

Then run the build script again.

73 Phil M0VSE

Thanks Phil - I am now running wfview on the Pi. Continue to morrow.

I have wfview running on raspberry pi -and using Mac/OS M1 as a client. Where can I find how to set up wfview on Raspberry regarding audio. The rest seems to be working.

mvh Pål la7hm

Hi Pål,

All you need to do is select the IC-7300 USB audio ports in wfview for transmit and receive audio. This setting is under Settings (surprise), then Radio Server. On this screen, you need to select the RX Audio Input and TX Audio Output to the corresponding USB devices which your radio creates. I know it’s a bit outdated, but here is our User Manual chapter on Remote Operation, which covers this (although with the older UI, so read carefully).

On my system, the IC-7300 was called something like " alsa_input.usb-Burr-Brown_from_TI_USB_Audio_CODEC-00.analog-stereo". Yeah, not the most descriptive name, but look for something like this.

If you don’t hear anything, or don’t have transmit audio, check the logs on both the client and the server. In the logs, you will see the audio device called out, and it may list the wrong audio device or even return an error. You have to check both the client and server logs, because it will be next to impossible to identify the error without a glance at each.

It may also be that, for optimal performance, you need to specify a different audio system on the server. To do this, as odd as it may seem, you need to first disconnect your clients, and then go under Settings and Radio Access. You’ll actually have to check the Radio Connection “Network” checkbox so that you can select the desired Audio System using the pop-down combo box. I use Port Audio on my linux system and it works quite well. Once you have selected the desired subsystem, don’t forget to leave the Radio Connection set to “Serial(USB)”. This is just a little UI quirk that we’ll work out in coming versions. Next, go back under “Radio Server” and make sure to check the Audio Output and Audio Input combo boxes. Check the devices available as they have almost certainly changed with the change to the audio system.

Again, you have to select the audio devices under Radio Server on the Server, and they will have unusual audio device names.

Let us know if it works,

de W6EL

Tnx - The trouble is that under Server settings - and RX Audio Input only have 2 - hw:USB Audio Codex and hw:default.
Under TX audio output only 3 - hw:USB Audio codex
hw: bcm2835 Headphones

Nothing else to choose among.

73 Pål La7hm

The “hw:USB Audio Codec” should be the correct one as this is the rigs USB audio device.

I have never tried the wfview server on MacOS though as my Mac is the other side of the room and the USB cable won’t reach to my rigs, but it should work!

73 Phil M0VSE

Sorry ignore that last bit, I forgot that you are using the Pi for the server now!

I used USB Audio Codex. - both RX and TX. I get no sound. rx-latency turned red and =0, When pushing Radio Status - all ok but nothing in AF and MOD.
Audiosystem RT. This is on client side. On server side all seems ok.

mvh Pål La7hm

What audio system is selected on the Pi?

Please check the log on the Pi to see what audio, if any, audio errors may be present.

de W6EL