No audio or waterfall efter remote switching on/off

I am using Wfview 1.63 on Rasperry Pi server and client for a remote setup for an IC 7300 over a fiber connection. This works nicely, but after switching the transceiver off from the client, and then switching on the next day, the waterfall or the audio, or both, does not appear on the client side. I know that the 7300 is beeing switched on, as I also have a linear amp that is switched on by the 7300, and that indicates that the 7300 is indeed switched on.

The cure for this is rebooting the server Pi, which I can do remotely by the command sudo reboot. But it would be better if I understood what is causing the audio/waterfall to not appear after switching the transceiver off and then on remotely. The indication for received bytes is ticking on as it should on the client side, but the audio/waterfall does not start, if I don´t reboot the server Pi.

do you have persistent USB devices confg’d ? And does it work if you only restart the wfserver part?

This is exactly it. The USB device has to be re-opened and if the device name has changed then wfview cannot find it. udev is your friend as documented on our website.

de W6EL

Thanks, I will try the last suggestion and report back.
I am not sure what persistent USB devices are. I do have USB connections to the 7300 and to the linear amplifier. They are assigned different USB ports randomly on the Pi after reboot, but wfview seems to find the 7300 anyway after reboot.

Thanks, I witt try assigning fixed devices with udev. I actually tried it earlier, but gave up because of difficulties, perhaps to early.



SUBSYSTEM==“tty”, ATTRS{idVendor}==“10c4”, ATTRS{idProduct}==“ea60”, ATTRS{serial}==“IC-7851 03001140 A”, SYMLINK+=“IC7851A”
SUBSYSTEM==“tty”, ATTRS{idVendor}==“10c4”, ATTRS{idProduct}==“ea60”, ATTRS{serial}==“IC-7851 03001140 B”, SYMLINK+=“IC7851B”

my “A” port of the 7851 will always be /dev/IC7851A

and if you look in /dev you will see that sometimes it’s /dev/ttyUSB0, sometimes /dev/ttyUSB7. etc

but again while the /dev/ttyUSBx port wil have numbers that depend on many possible things, will always be /dev/IC7851A

this way you even can have multiple same rigs defined as the serial numbers differ between, say 7300’s.

Thanks, I should be able to do it. I hope…

I managed to set up a udev rule. The command ls -l /dev/IC* provides the answer /dev/IC7300 → ttyUSB1

But the device IC7300 is not available as an alternative in wfview. What am I doing wrong?

Do I need a mode statement in the udev rule?

Did you put in by hand?

Also show the udev rule and your serial

Copy and paste from your exempel above for the 7300, I just substituted the serial no for my device, and the symlink name IC7300. Everything by copy and paste to not mess it up.

IC7300 is listed as a device pointing to a USB port as I showed above. But it not shown as an available device in Wfview.

Because you put that in manually

This is the content of my rules.d file by copy and paste:

SUBSYSTEM==“tty”, ATTRS{idVendor}==“10c4”, ATTRS{idProduct}==“ea60”, ATTRS{serial}==“IC-7300 03025077”, SYMLINK+=“IC7300”


If you copy pasted, you are as user in the dialout group, you have manually entered /dev/IC7300, right serial…

But again be aware you need to EN ter the device in wfview by hand

Yes, and there comes my problem. AUTO, dev/ttyUSB0 and dev/ttyUSB1 is avaiable as serial connection choices, but dev/IC7300 is not visable as a choice.

What am I doing wrong?

But it is listed by the command above.

You have to type the new device name manually into wfview. It won’t show up by itself.

Said that thee times already, didn’t I?

Yes, thank you. But I am still doing something wrong, although your advice is good.

In the Wfview server, there are tthese alternatives for serial:

If I choose Manual, save settings and reboot, it defaults to Auto anyway.

In the config file, the correspomding line is also still:

I was thinking the config file was corrupt, so I renamed it so that it was built fresh, but still the same after doing the settings from scratch.

Is there something I still dont understand about entering the new device? Should I edit the config file manually?

Please excuse me, if I missed something obvious!