Sr. Citizen. Can't Connect To Icom R8600?

Hi Elliott:

Looks like a terrific program, and would really like to use it.
Sr. Citizen now, take pity, very, and eyesight not too great anymore.
Not too sharp with this “stuff” anymore, but enjoy sw listening still.

Have a Icom R8600.

Have tried most everything that the msgs have suggested, installed Drivers correctly (I think), but program will not talk to radio.
Trying to use over “Connect over USB Device”

Is there “something” that is perhaps not too obvious that I may be missing ? What is the most likely thing I am doing incorrectly ?

I selected a COM Port from dropdown menu that I am pretty sure is not
being used by anything else.
**Is there (also) something in the radio to tell it to use this Port ?

What Baud rate should I select ?
Must the radio also select this rate ? How ?
If the choices don’t agree (aren’t the same options for), then what ?

Is it possible to send you a log file ?
If so, would that be helpful ?

Must be something in the radio just not configured properly, but am out of ideas as to what it might be, or what I should verify ?

Is there a list of items to verify ?

Thanks, really appreciate the help,

Hi Bob,

Is this a new take on your prior thread: Getting Started: Sr. Citizen Level Questions ?

In any case, you must select the radio’s comm port from the wfview drop down menu. I do not know what it will be called, you can either try each one or dig around in the windows device manager to try and find it. The radio is the comm port, this port is inside the radio and is created in windows when you plug the radio into the PC, so all you have to do is make sure you haven’t picked some other comm port that might for whatever reason also be on the same PC. Maybe there’s only one, I don’t know, every PC is different.

Baud rate should be 115200, and you should verify that the radio has this same baud rate set in the menu. I don’t have that particular radio, so I do not know the exact procedure. Perhaps someone can chime in here.

Yes, there is a log file, but please try the above steps first, and see how far you get. I don’t know what is or isn’t working, but my guess is that you have not established communication to the radio yet.

de W6EL

Hi Elliott,

Thanks for previous help, but still no luck.
That old age problem again, I guess.
I did read your excellent Manual, and have verified the basic required settings for my new Icom R8600.

Still confused over COM Port setup and required extra Drivers, if any ?

Are any Drivers from Icom required ?
If so, Exactly which ones, please ?
Where should I place them.

Here is a copy of my Device Manager with radio on.
Anything not there that should be ?

Again, thanks for help; really appreciated.


Hi Bob.

Yes that is exactly the problem, the exclamation mark means that those devices are not working (most likely due to missing drivers).

As I mentioned in my message to your original thread, you must download and install the Icom driver from there is also a full installation guide available on that page.




Thanks for taking all the time to help me out.
Eyesight poor, and would really love to use your program.

Have done the installation, per the instructions, etc. but no luck.

I see the program is x86, but my pc installer “insisted” it could be only
loaded into the x64 Folder.
Any problem ?

*And, any other Drivers needed ?

Best regards, and thanks again,

Hi Bob,

When I downloaded the driver from the ICOM site and extracted the files from the .zip file, I found two installation executables: CP210xVCPInstaller_x86.exe and CP210xVCPInstaller_x64.exe. I think you need to run the CP210xVCPInstaller_x64.exe if your system is 64 bit.

IMPORTANT: Make sure that the USB cable from your radio is DISCONNECTED from your computer until after you install the driver.

Hope this helps,

Hi Dave:

Thanks for help.

Have done the x64, several times.

Is there only one Driver File to download from the IcomJapan site,
or possibly more than this one to download ?

I am really stumped.
Everyone has been so nice and offered suggestions, but can’t get the radio to talk to the program. Probably something very simple.

a. Only one file to download ?
b. Just for me to be sure, what is the File name/No. you downloaded ?
c. **Radio Settings ?


Hi Bob.

If you download the file (scroll down to the bottom of the page, click that you understand the licence terms and click Download) this will download a file called

Unzip this using either the built-in unzip function of Windows or your preferred unzip program. Then in the Driver directory, select the folder matching your operating system (Win10) and run CP210xVCPInstaller_x64.exe (CP210xVCPInstaller_x86.exe is for 32 bit windows ONLY)

Once complete check Device manager to make sure that the exclamation marks are no longer there (you may need to reboot your PC). You then select the first COMx port within wfview.

73 Phil M0VSE

Hi Phil,

Have done all of that, except the re-boot of pc.
Will try that next.

In Device Mgr. under Ports (COM & LPT) I have two illuminated icons:
Silicon Labs CP210X USB to UART Bridge (COM 5)
and the other one has (COM 6)

Title is: Silicon Labs CP210x USB to UART Bridge (COM 5)

Location: Port # 0001 Hub# 0008

The icon has a exclamation mark.
When opening that up, it says:

This device is Not working properly because Windows cannot load
the Drivers required for this device (CODE 31)
Object Name Already Exists

In Driver Fole Details: Driver Files: C\windows\System 32\Drivers\silabser.sys

Anything here interesting or incorrect ?
I’m assuming that this is the only download from Icom required. True ?
What’s Code 31 ?

Regards, and thanks,


I think it is suspicious that he shows two Silicon Labs devices. What do you think of this?

  1. Disconnect 8600 USB cable from PC
  2. From Device Manager, uninstall both Silicon Labs devices
  3. Reboot
  4. Run the CP210xVCPInstaller_x64.exe from the Win10 folder extracted from the .zip file AS ADMIN
  5. Reboot
  6. Connect the USB cable from the 8600 and give it a minute to locate the driver
  7. Use Device Manager to see if the driver shows without error and note the COM port assigned
  8. Report the results

Let me know if you agree before Bob tries this.

Hi Dave.

the ICR8600 creates two serial Devices (so does the 9700 and 7610)

Yes I was going to suggest deleting the devices and let them install again. Sometimes Windows doesn’t like installing drivers for devices that already exist so I would recommend trying your process.

73 Phil

Ok, thanks, Phil. Didn’t know about the dual devices but no matter. If they are both 32-bit, could be the problem.

Bob, try this if you want and let us know.

Bob, did you try the remove/reinstall that I outlined for you? (message #9)
If so, let us know if it worked or not.


Hi Dave,

First, a most sincere thanks for all the time and help you’ve been giving me. Really nice of you, and most appreciated.

Took a lot of math courses in college days, but should have taken
more computer courses !

Yes, I tried all the suggestions; most several times.

The problem is, I think, that my W10/pc is just not allowing the install
of the Driver (correctly). No idea why not.

Will take a look at the security setting and permissions this am, but
have never run into this before. Actually, that’s not 100% true, as I also can’t get the software I purchased from RTSystems to work either.
Some “commonality” here ?

Please do keep the suggestions coming.
Probably something very simple.


Sorry that this didn’t help, Bob. I am currently out of ideas, but will let you know if I come up with something else. Maybe someone else has a suggestion?


Bob -

Did you try updating the driver from within Device Manager ?

Go to the devices with the exclamation points, right click, and select “Update Driver”. In the next dialog box, pick “Browse my computer for drivers”. Go to the location where you have the Icom driver downloaded and select it.

See what, if anything, that does.

Let us know.

Brad D.


Yes I did. A few times.

Msg. always appears that it won’t update, as the best is already installed.

Think I’m learning more about Drivers than I ever want to know !

Sure is funny.
Seems like some setting in my W10 is preventing the Installer to install properly.
Can’t imagine what it might be.

All the security settings, firewall, etc. are set such that they shouldn’t be preventing this.

Regards, and thanks,

Have you tried a clean reboot?

de W6EL


If a clean reboot is shutting down the pc, and re-booting it, then
the answer is yes. A few times tried.
No changes.

Do, please, keep the thoughts coming.

Is there any free software that does a good job diagnosing
Driver installation problems that you might know of ?


Bob, if you are interested, and we can time it well, I would be willing to try a team viewer or go2meeting session with you, to see if we can sort it out together.
Greg, KC8HXO

1 Like