I have the 7610 setup and running on Lan, Win 10 - all works well but no Waterfall. If I use USB I can get the waterfall to work on the desktop but USB connection does not work on the Laptop only the Lan connection works. I am sure I am missing something simple.

John ND1X

1 Like

the USB rate should be 115k2.

The question though is: why would you use USB instead of LAN? USB is unbearably slow to me.
However, you may probably have different ways of runnign the rig there. So just wondering.

Hi John.

The waterfall will only work if it is actually being displayed on the rig (otherwise the rig doesn’t output waterfall data). It should work over LAN or USB but as Roeland says, USB is much slower.

Can you confirm that CI-V Transceive is enabled on the 7610 as per Getting Started | wfview if it is, you can check the log to see what is going on Log file | wfview

73 Phil M0VSE

Phil, Yes, the CI-V transceive is enabled. If I just the USB connection the waterfall comes up on Wfview but only on the computer that is attached by USB cable to the radio. The laptop does not show the waterfall, But I can do everything such as volume control, tuner on and off, transmit etc. If I use Lan All works on Laptop but no waterfall. Actually I saw a note that the main computer does not need to be on last night. So I shut it down and the laptop picks up the Lan on the 7610. The 7610 I have the waterfall on all the time.

Tnx, John

Hi John.

Only one instance of wfview should be connected to the radio at a time which probably explains why you are having the issue.

To be honest, I don’t think that anybody has ever tried connecting one PC via USB and another via LAN to the same radio before?

I suspect that the radio can only send the waterfall data to USB or LAN but not both at the same time.

73 Phil M0VSE

Phil, Tnx for the help. I will try the Laptop and see if the waterfall comes up. I’ll keep in touch.

Tnx, John

I tested my 9700 and 785x and both show USB waterfalls etc as well as ethernet waterfalls – a 7610 may be different though.

Phil, The laptop still does not show the waterfall? Also, the S meter does not work. I think, IMHO, the Audio Codec input/output from the IC-7610 is not getting to the laptop. The Laptop audio is only showing in Wfview the Realtech input and output. I do not know how to make that change? I did make a few remote contacts on the laptop this morning and it did work very well and I was told that my audio was very good but there was a slight echo that was being heard. I was using a gaming headset/mic and that might be the reason? I know Wfview is still work in progress, but I do see that many have had no issues.

Any more ideas ?

I appreciate your input.

Tnx, John

did you hear the echo at tx or also rx?

what’s the monitor setting on the rig? Should be off.

furthermore, if your s meter does not work and wf does not work, as well as the audio codec…
I think the rig is not set up right. Can you ping the rig?

Roeland, Just on TX, but I was able to fix that using a different mic. So that is okay, As far as the Monitor it’s off. I am not sure how to “ping” the rig. Is this something that is available in Wfview? I have many programs that run well with the 7610. WSJT-X, N1MM, Fldigi etc. I do not use HRD. I hate it with a passion.

Tnx, John

it’s known that some headsets have internal feedback that can cause some echo yes.

ping is a basic command that sends a predefined piece of data to the rig and you would thenreceive a response (like an echo).

can you tell us the LAN settings in the rig and check that you have an user/pass set too?

Roeland, I am connected to the Lan. The 7610 has an easy way for me to know that. I go into Network settings then to Time set and click on Date/Time then click on NTP Time Sync. It connects all the time. As far as Lan settings
IP address 192.168. 1. 24
Subnet 255.255.255, 0 (24bit)
Default Gateway 192.168. 1. 2
I have a network name, Network control is On.
Control port UDP 50001 - Serial Port UDP -50002 - Audio Port UDP - 50003
Yes I have a network username and password and Network Radio name
CI-V transceive is On
CI-V USB Port - Unlink from (Remote)
CI-V USB Baud Rate 115200
CI-V USB Echo Back ON
Lan Mod Level 50%
Data off Mod Mic / USB
Data1 Mod USB
Data 2 Mod USB
Data 3 Mod LAN

As far as pinging the radio, that’s not something I can do being not to computer literate. But I can follow instruction okay.

The Laptop has 1.1 Wfview latest update and I turn off the main computer that the radio is connected to being the 7610 has a built in Lan. The Laptop connects to the radio very quickly. I have the radio in the Standby (for Remote Control)



the fat that you used the NTP sync to test is a good job! Really!

to ping the 7610:

  • open a command prompt (cmd iirc) – and type there


and it should reply with some timing in ms.

You did try to switch on the rig I assume remotely – does that work? Eventually you can send us the logfiles but I should check where they are in windows – I am a linux guy ;-)).

In order to be sure that there is not an issue logging into the rig, can you set u a second user
temporary with an easy user/pass like

user: test1234
pass: secret

and test with that. (don’t use above examples and don’t forget to remove them either; these are too easy)

Roeland, I pinged the laptop and ping with 32 bytes of data and this is what came back
Reply from Bytes=32 time = 8ms TTL-255 - this was sent 4 times

Png Statistics for
Packets: sent = 4, Received = 4, Lost - 0 <0x%. loss>
Approximate round trip times in milli-seconds:
Minimum = 2ms, Maximum = 8ms, Average = 4ms.

Yes, I did turn on the rig remotely and that works.

I also did a 2nd user and pass.

The outcome is, I can transmit, I worked a lot of EU etc. today , received great audio and signal reports, I can turn the tuner on and off, I could change the filter and change bands etc. But no waterfall. I still am suspicious about the input and output on the laptop. The default is the laptop mic and speaker. But am I supposed to use virtual audio or should I see the Codec input and output from the radio?

My audio codec on the radio works fine with all of the programs such as N1MM, WSJT-X, Fldigi and others.

Tnx John

Hi John,

Does the lower-right corner say “NONE” or the radio model?

de W6EL

Elliot, it shows the radio model 7610.


Hi John,

We’re really stumped here.

All I can recommend is to make sure and try the following:

  1. No USB connection to anything
  2. Waterfall enabled on the radio
  3. Only one receiver active
  4. Make sure CI-V Transceive is on
  5. No other programs running on the PC, just wfview

If none of that works, I’d backup your radio’s settings to SD card and do a reset on it.

And of course, if you can send us a log file that would really help out. Perhaps even running wfview with the --debug flag on startup (this makes for a more verbose log file).


de W6EL

Two other ideas:

  1. Make sure “Unlink from [REMOTE]” is set to ON. You can’t reliably get the USB serial port at 115200 if the traditional “remote” port is activated.
  2. Make sure the USB baud rate is set to 115200. The spectrum will not come out at any other rate, and perhaps the LAN connection respects this setting too (why I have no idea).

Let us know how it goes,

de W6EL

what version of f/w do you use in the rig?
If it’s not the latest, can you update it to the latest version?

We’ll wait if Phil has a suggestion, else I would think the rig may need a reset or something.

No I really can’t think of anything that hasn’t already been mentioned…

At this point we really need to see the log Log file | wfview to diagnose this issue further I think.

It would also help if you can run wfview in debug mode “wfview --debug” as that generates a lot more debugging information.

As Roeland suggested, knowing the firmware version of your 7610 will also help us, as if it is an older version, there may be an issue that we are unaware of.

73 Phil M0VSE