Wfview 1.62 released


Today we have released wfview 1.62 with binaries available in Download | wfview

This is a minor release with the following new features/fixes:

  • Various fixes in CW window and add (experimental) local sidetone
  • Add missing rigctld commands (most are currently non-functional)
  • New USB controllers added, EESDR E-Coder and XenceLabs Quick Keys
  • Add CI-V collision detection (should help with 1/2 duplex radios)

73 Phil M0VSE

1 Like

Cannot compile this version on Raspberry Pi. Says “DefaultStepType” is not a member of “QAbstractSpinBox”. when trying to setSetType in dashSpin.

Dennis Engdahl

Hi Dennis.

I suspect you have a fairly old version of Qt as that should be in all newer versions. We have come across this before when adding ‘spin boxes’ to wfview. The quickest fix is simply to remove lines 412-414 from cwsender.ui :

    <property name="stepType">

We will make sure these get removed ASAP as they aren’t actually needed!

73 Phil

Those lines are now removed, so please try updating your repository and recompile.

Yes, It now compiles correctly! Thanks!


I have connected my Contour Shuttle Express and seems KNOB is not changing frequency… JOG is working but not KNOB…

Hi Dawid.

Just tested both my ShuttleXpress and Pro2 and both “shuttle” and “jog” work fine, so you might want to double-check your hardware?


True, solved.
Problem was with “Sensitivity”. It was setup for another KNOB. Maybe it should reset from one to another?:slight_smile:

I will look at that, but as you and me are probably the only people that use multiple knobs, it’s not really a priority :slight_smile:

For sure not!:slight_smile: Thanks for fast reaction as usual;)

I really do not like complaining, but with 1.62, my RC-28 no longer works. I get ‘No USB controller found’ when I click on the ‘Setup USB Controller’ button.
Windows 10 Pro, build 19044.2604
Works with 1.61

Any and all assistance appreciated.

log below

wfview-no-RC-28.txt (15.1 KB)

Hi Gordon.

Sorry it looks like I have broken support for the RC28 in v1.62. Not exactly sure how that happened, but some testing code made its way into the release. You are probably best to go back to your previous version if you want to use the RC28.

I am currently working on a bit of a re-write of the USB controller code, which will hopefully be ready soon.


@phil do you need some support in testing RC28 fixes?


Yes, I do need some support and posted on the forum. Basically, I am running wfview on a mac mini OS 14 connected to an IC 7300 via USB. All is well there. I set up a wfview client on a macbook pro running OS 13 and had to download an older version of wfview due to incompatibility. It’s v 1.2. The client is communicating with the server and I see meters responding and waterfall signals, but no audio on the client. Tried to change audio settings on both client and server with no improvement.

Probably not the first time this has occurred!

Thanks for any help provided!


Hi Steve.

I think that message was directed at me!

If you can post your log files in the question you have asked, we can have a look at them.

@sq6emm I will let you know once I have pushed the USB controller code. It is a massive re-write but seems to work pretty well so far.

73 Phil

Hi Phil:

I don’t see a way to forward log files from my client v 1.2. It is running High Sierra 10.13.6 MAC OS. But I can send them from the mac mini server as I see the log forward button there.

Will do in a bit and thanks for your help!



Where can I find a descr. of the changes that result in 1.62 please ?


Also look for the WHATSNEW file there

hello i might be wrong but WFview does not support the IC7100
the older version did connect to my IC7100 but only i could see and change the frequency of my IC7100
no audio or remote function did work

I think there is no support for the IC7100

a pity since the IC7100 is a great radio covering the whole range low HF MW! to UHF

6m 4m 2m 70cm very good receiving low internal noise
Icom rsBA1 is useless wFview as good as it looks also useless
i think Skype can be used to work remote
or a 3rd party comercial hw solution is possible

73 Jaap