Wfview linux install fails

Ive followed the instruction for this install and all commands are working till I get to “make -j” then it dumps with these errors:
wfmain.o: file not recognized: File truncated
collec2: error: Id returned 1 exit stratus
Makefile:249: recipe for target ‘wfview’ failed
make: *** [wfview] Error 1

Im not a Linux wizard and can get most stuff done. This one has be baffled.

Allen WB7SWW

Hi Allen.

That sounds like it might be the remnants of a previous build?

Can you try:

make clean
make -j

Then post the results?



I use

make clean && rm .qmake.stash && qmake-qt5 …/wfview/ && make -j && echo y | sudo ./

to keep stuff clean. (takes 11…12 seconds total)

make clean did allot of things but in the end it crashed. Will try the second suggestion.
Thanks guys this is a tough one.

Well I just cant make it work. Tried all the above and still crashes to Desktop.

Going to take a break. My brain hurts :slight_smile:

what if you do a make instead of make -j?

I can try that. I gave up on the OrangePi and now working with a RaspberryPi 4B. Hoping it works this
time. Im not giving up on the OrangePi yet. Its too powerful to ignore :slight_smile:

Well installed Ubuntu 21.04, install went all the way through which I “assumed” (that word again), that it had worked, Even did a reboot after install. But no Icon on Desktop, or anyway to launch that I can see. This version have a very weird desktop and some things dont work like I think they should. Had heck of time finding Terminal so I could input lines of code.

Any ideas why no Icon. Or what file starts the software.?

Hi Allen,

The install script ( will install the program into /usr/local/bin/wfview, and the launcher desktop icon to /usr/share/applications/wfview.desktop.

Please let me know if either of these work for you.


de W6EL

Well trying another build and it worked all the way to the end
few commands:
3. Create a build directory, compile, and install:
mkdir build
cd build
qmake …/wfview/
make -j
sudo ./

qmake is making the in the directory wfview then make -j doesnt work says “nothing to do”
sudo ./ stalls

Hi Allen,

It is important to be very precise with the commands. qmake should not be making anything in the source folder (“wfview”). It should make in the “build” folder. Looking at your message there, you do have an extra dot in the qmake line. It should be:

mkdir build
cd build
qmake ../wfview/
make -j
sudo ./

Let me know if that helps any.



Wish I could copy from screen to text:
in Documents/build I enter make -j (get this error “make: *** No targets specified and no makefile found. Stop.”

enter sudo ./ (get this error “./ command not found”
This is where it always gets messed up. Got though all the commands in the, and these are the last few files. Nothing is being generated to other directories as noted above in Elliots post on this subject.

Hi Allen,

Can you verify something for me?

When you do this:

    mkdir build
    cd build
    qmake ../wfview/

Do you see any files created? There should be two files. After you run those commands, do this:
ls -a
And see if you see “.qmake.stash” and “Makefile”

Here is my text from my terminal doing these things:

    eliggett@chi:~/Documents/dev/wfview-ui-enhance$ git clone [snip]
    eliggett@chi:~/Documents/dev/wfview-ui-enhance$ ls -l
    drwxrwxr-x 7 eliggett eliggett 4096 Apr 29 17:04 wfview/
    eliggett@chi:~/Documents/dev/wfview-ui-enhance$ mkdir build
    eliggett@chi:~/Documents/dev/wfview-ui-enhance$ ls -l
    total 16
    drwxrwxr-x 7 eliggett eliggett 4096 Apr 29 17:04 wfview/
    drwxrwxr-x 2 eliggett eliggett 4096 May 13 17:32 build/
    eliggett@chi:~/Documents/dev/wfview-ui-enhance$ cd build
    eliggett@chi:~/Documents/dev/wfview-ui-enhance/build$ qmake ../wfview/wfview.proInfo: creating stash file /home/eliggett/Documents/dev/wfview-ui-enhance/build/.qmake.stash
    eliggett@chi:~/Documents/dev/wfview-ui-enhance/build$ ls
    total 52
    -rw-rw-r-- 1 eliggett eliggett 51401 May 13 17:32 Makefile
    eliggett@chi:~/Documents/dev/wfview-ui-enhance/build$ ls -a
    total 64
    drwxrwxr-x 6 eliggett eliggett  4096 May 13 17:32 ../
    -rw-rw-r-- 1 eliggett eliggett   739 May 13 17:32 .qmake.stash
    drwxrwxr-x 2 eliggett eliggett  4096 May 13 17:32 ./
    -rw-rw-r-- 1 eliggett eliggett 51401 May 13 17:32 Makefile

Let me know what you get there.



The wfview and are where they should be.
running ls -a only shows .qmake.stash. There is no Makefile.

This is so strange. can you post the output like I did? Copy-paste right into the email, let’s see what’s going on.

The documentation for qmake says it will drop the makefile in the current working directory. I don’t even see a flag to manually set the destination!

You may have found a very interesting bug in… something…

Thanks for your patients while we investigate this issue,

de W6EL

pi@WB7SWW:~/Documents/build $ qmake …/wfview/
Project ERROR: Unknown module(s) in QT: multimedia
pi@WB7SWW:~/Documents/build $ ls -a
. … .qmake.stash
pi@WB7SWW:~/Documents/build $

NOTE: the …/wfview/ files are where they should be. I just did the command to show what happens when you repeat the command. Whats after that is the results of ls -a in build directory.


Hi Allen,

The error you’re getting is the key. “Project ERROR: Unknown module(s) in QT: multimedia”. There won’t be a Makefile until qmake can find that module.

Did you make sure to run these two commands:

sudo apt-get install libqt5multimedia5
sudo apt-get install libqt5multimedia5-plugins

Maybe try again and see if it will work.


de W6EL

This is the result of the apt-get installs:
/Documents/build $ sudo apt-get install libqt5multimedia5-plugins
Reading package lists… Done
Building dependency tree
Reading state information… Done
The following additional packages will be installed:
libqt5multimediagsttools5 libqt5multimediaquick5 libqt5multimediawidgets5
libqt5qml5 libqt5quick5
Suggested packages:
The following NEW packages will be installed:
libqt5multimedia5-plugins libqt5multimediagsttools5 libqt5multimediaquick5
libqt5multimediawidgets5 libqt5qml5 libqt5quick5
0 upgraded, 6 newly installed, 0 to remove and 0 not upgraded.
Need to get 2,367 kB of archives.
After this operation, 9,564 kB of additional disk space will be used.
Do you want to continue? [Y/n] Y
Get:1 buster/main armhf libqt5multimediawidgets5 armhf 5.11.3-2 [35.0 kB]
Get:2 buster/main armhf libqt5multimediagsttools5 armhf 5.11.3-2 [64.1 kB]
Get:3 buster/main armhf libqt5qml5 armhf 5.11.3-4 [1,001 kB]
Get:4 buster/main armhf libqt5quick5 armhf 5.11.3-4 [1,049 kB]
Get:5 buster/main armhf libqt5multimediaquick5 armhf 5.11.3-2 [37.9 kB]
Get:6 buster/main armhf libqt5multimedia5-plugins armhf 5.11.3-2 [180 kB]
Fetched 2,367 kB in 3s (737 kB/s)
Selecting previously unselected package libqt5multimediawidgets5:armhf.
(Reading database … 102112 files and directories currently installed.)
Preparing to unpack …/0-libqt5multimediawidgets5_5.11.3-2_armhf.deb …
Unpacking libqt5multimediawidgets5:armhf (5.11.3-2) …
Selecting previously unselected package libqt5multimediagsttools5:armhf.
Preparing to unpack …/1-libqt5multimediagsttools5_5.11.3-2_armhf.deb …
Unpacking libqt5multimediagsttools5:armhf (5.11.3-2) …
Selecting previously unselected package libqt5qml5:armhf.
Preparing to unpack …/2-libqt5qml5_5.11.3-4_armhf.deb …
Unpacking libqt5qml5:armhf (5.11.3-4) …
Selecting previously unselected package libqt5quick5:armhf.
Preparing to unpack …/3-libqt5quick5_5.11.3-4_armhf.deb …
Unpacking libqt5quick5:armhf (5.11.3-4) …
Selecting previously unselected package libqt5multimediaquick5:armhf.
Preparing to unpack …/4-libqt5multimediaquick5_5.11.3-2_armhf.deb …
Unpacking libqt5multimediaquick5:armhf (5.11.3-2) …
Selecting previously unselected package libqt5multimedia5-plugins:armhf.
Preparing to unpack …/5-libqt5multimedia5-plugins_5.11.3-2_armhf.deb …
Unpacking libqt5multimedia5-plugins:armhf (5.11.3-2) …
Setting up libqt5qml5:armhf (5.11.3-4) …
Setting up libqt5multimediawidgets5:armhf (5.11.3-2) …
Setting up libqt5multimediagsttools5:armhf (5.11.3-2) …
Setting up libqt5quick5:armhf (5.11.3-4) …
Setting up libqt5multimediaquick5:armhf (5.11.3-2) …
Setting up libqt5multimedia5-plugins:armhf (5.11.3-2) …
Processing triggers for libc-bin (2.28-10+rpi1) …
pi@WB7SWW:~/Documents/build $ qmake …/wfview/
Project ERROR: Unknown module(s) in QT: multimedia
pi@WB7SWW:~/Documents/build $ make -j
make: *** No targets specified and no makefile found. Stop.
pi@WB7SWW:~/Documents/build $ sudo ./
sudo: ./ command not found
pi@WB7SWW:~/Documents/build $

and this is the result of ls -a in build directory:
pi@WB7SWW:~ $ cd Documents/build
pi@WB7SWW:~/Documents/build $ ls -a
. … .qmake.stash
pi@WB7SWW:~/Documents/build $

Hi Allen,

This is a good step. I think we found the missing library. However, before you proceed, can you please make sure you ran each line in Step 1 of the file? Each of those items must be installed in order to build.

Once you’ve run those (and it’s totally fine to run the apt-get stuff more than once just to be sure), remove your build directory entirely, make a new build directory, and continue.

eliggett@chi:~/Documents/dev/wfview-ui-enhance$ rm -rf build
eliggett@chi:~/Documents/dev/wfview-ui-enhance$ mkdir build
eliggett@chi:~/Documents/dev/wfview-ui-enhance$ cd build
eliggett@chi:~/Documents/dev/wfview-ui-enhance/build$ qmake ../wfview/
Info: creating stash file /home/eliggett/Documents/dev/wfview-ui-enhance/build/.qmake.stash

At this point, make sure there aren’t any errors. If there aren’t any, then check with the ls -la command to see if the Makefile was created. If so, continue:

eliggett@chi:~/Documents/dev/wfview-ui-enhance/build$ make -j

Let us know how it goes.


de W6EL

It Worked! Did all from 1 to redoing the build directory. All ran with no problems. Ive included the last part of the install including the ./

pi@WB7SWW:~/Documents/build $ cd
pi@WB7SWW:~ $ cd Documents
pi@WB7SWW:~/Documents $
pi@WB7SWW:~/Documents $ ls
build wfview
pi@WB7SWW:~/Documents $ cd build
pi@WB7SWW:~/Documents/build $ sudo $0
root@WB7SWW:/home/pi/Documents/build# sudo ./
This script copies the following items into your system:

icon: wfview.png to /usr/share/pixmaps/
wfview application to /usr/local/bin/
wfview.desktop to /usr/share/applications/
qdarkstyle stylesheet to /usr/share/wfview/stylesheets

This script MUST be run from the build directory. Do not run it from the source directory!

Do you wish to continue? (Y/N): y
Copying files now.

root@WB7SWW:/home/pi/Documents/build# done
bash: syntax error near unexpected token `done’
root@WB7SWW:/home/pi/Documents/build# exit
pi@WB7SWW:~/Documents/build $ ls -a
. moc_qledlabel.cpp qrc_resources.cpp
… moc_qledlabel.o qrc_resources.o
audiohandler.o moc_repeatersetup.cpp qrc_style.cpp
calibrationwindow.o moc_repeatersetup.o qrc_style.o
commhandler.o moc_rigcommander.cpp repeatersetup.o
freqmemory.o moc_rigcommander.o resample.o moc_rigctld.cpp rigcommander.o
logcategories.o moc_rigctld.o rigctld.o
main.o moc_satellitesetup.cpp rigidentities.o
Makefile moc_satellitesetup.o satellitesetup.o
meter.o moc_udphandler.cpp udphandler.o
moc_audiohandler.cpp moc_udphandler.o udpserver.o
moc_audiohandler.o moc_udpserver.cpp udpserversetup.o
moc_calibrationwindow.cpp moc_udpserver.o ui_calibrationwindow.h
moc_calibrationwindow.o moc_udpserversetup.cpp ui_repeatersetup.h
moc_commhandler.cpp moc_udpserversetup.o ui_satellitesetup.h
moc_commhandler.o moc_wfmain.cpp ui_udpserversetup.h
moc_meter.cpp moc_wfmain.o ui_wfmain.h
moc_meter.o pttyhandler.o wfmain.o
moc_predefs.h qdarkstyle wfview
moc_pttyhandler.cpp qledlabel.o wfview.desktop
moc_pttyhandler.o .qmake.stash wfview.png
pi@WB7SWW:~/Documents/build $