X6100 New firmware with Wfview server problem

Just downloaded new X6100 firmware with Wfview server. I can not get it to work with Wifi. Does it require a usb cable, or can it be Wifi only?

Details please. There’s not enough here to really help you. Yes, it works over wifi.

I set wifi in radio to connect with my router. Radio says it is connected. I copy my ip address from the radio into hostname in settings of Wfview. username -user - password 123. Press connect to radio and nothing happens. Will not connect. I see the wifi symbol on the X6100. I am using 1.64 Wfview. What should I do?

Bring it extremely close to your ap and try again.

Hi platy,

What operating system?

Can you ping the radio’s ip address from your computer reliably?

Have you checked any of the CI-V related checkboxes in wfview? If so, please uncheck them.

Can you share the log from wfview with us? That will help us understand your issue better.



Using Windows 10. Radio is close to computer. I can not ping the radio so I assume that is the problem. I used an ip scanner program and it shows the ip address of the radio, but it is not open. Regular ping from computer via the command line does not work. Any ideas?

radio needs to be close to the access point – if it’s 4m from my access point, The speed drops to 6 Mbit/sec and ssh access (22/tcp) is choppy.

now we need to know all the settings you have put in the X6100 and confirm it’s teh same subnet as the rest of your network and you correctly use the right gw address. e.g. the basics.

Just tried out the wfserver on the X6100. It connects but the process creates a lot of interference on-frequency. It doesn’t matter what frequency it is tuned to so it is interference at the IF frequency. When I disconnect, it goes away. The wfview interface is rather sluggish, as frequency updates take as much as 10 seconds to appear. There are a lot of packets being lost, like 1400 out of 5000 but then levels off. Seeing 1456 out of 15000 now. Rx latency is red at 5ms, RTT varies from 50-100ms. The spectrum works only sporadically. I posted the log to termbin but wasn’t able to label it.

Hi Gary,

With termbin, the one and only way we can see it is if you paste the URL that wfview gives you, after sending to termbin, in our forum. Then we can click it and see the log file. We don’t operate the termbin site and we can’t go and browse it for specific labels or mentions of wfview (I wish we could!).

Anyway, from the initial reports, it seems that the X6100 needs to pretty much be right next to your wifi access point. Or you can use a USB-Ethernet dongle with the X6100. Live UDP streaming really is tough on wifi devices and networks. You might have 150 mbit download speeds over TCP/IP on wifi but still have poor real-time UDP streaming. And then things like wifi congestion and mesh topologies can be a factor as well.

Sluggish performance is probably a reflection of network performance. You can, of course, alleviate some of this by choosing a ligher-weight audio connection in wfview. For example, set the codecs to uLaw 1 ch 8-bit and the sample rate to 16000. Or try the Opus codec for even more reduction in required bandwidth (I still have not heard how well this works with the X6100 though). You can also bump your RX and TX latency in wfview up to around 250ms.

Don’t forget to look at wfview’s lost packet indicator (lower-right) and RTT stats (round trip time). These will tell you right away if there is an issue with the network.

Give this all a try, see if any of it helps. I am very curious as to what you find out!

de W6EL

I connect to my router - radio says connected to router - with the radio and it automatically populates the ip address and the gateway. I did try to edit them to see what would happen, but the radio will not let me. From what I have seen on the internet videos about this, all you need to do is copy that ip address into the Wfview program. However, I think there is a problem with the router communicating to the radio. I can not ping the radio. I am only a few feet from the access point and get a strong signal from the radio.

Make sure your computer is connected to the same network. If you have two routers cascaded then you can end up with a situation where you have several networks.

de W6EL

It fills the address automatically and says connected but somehow it’s out of your network range and you can’t ping to the radio from PC. I had the same experience.
Turn off Auto Connect and DHCP. If the network prefix is 24, then only last digits should be different from your PC’s IP.
e.g. If your PC’s IP is, then the radio’s IP should be 192.168.1.x. (x is between 2 and 254, and make sure it’s not used by other devices in your network) And gateway is usually, but it depends on how your network is configured.
Then ping to the radio from the PC. If ping works, then you should be good to go.
Or use Realtek r8152-based USB Ethernet dongle and run the Ethernet cable to your switch. The radio picks up the IP automatically and you look up on the AP’s DHCP pool info or use IP scanner.

Putting the radio next to the router, the interference and lost packets went way down and the interface was more responsive and the spectrum was good. But the spectrum controls are unresponsive and the frequency range of the spectrum is fixed (displayed) to 11.5-16.5 MHz. Mode selections are responsive as well as volume, but the volume seems low.

Yeah I think the units on the spectrum display aren’t coming out right. But I’ll need to play with it a bit more.

I’d say it’s a pretty good start though!

de W6EL

I tried what you suggested with the IP. Problem is that it reverts to Auto Connect when I toggle the WiFi switch, and the settings automatically revert back to what I had before. I guess it is a problem with my router. I have a mesh system in my house.
I suppose my only solution is the dongle you mentioned. Thanks for the help and your videos.

It does not necessarily have to be Realtek r8152. Many others should work but Realtek is what I have and it works.
BTW, if you use WSJT-X or flrig (USB CAT control), you will want to downgrade to 1.1.6.

I have some fair work done on dhcp servers, switches, routers and all. Hp, Cisco, zyxel, fritz stuff, arista, Netgears etc.

I don’t even understand what you do or see.

Crazycats100 (above) had a similar problem, but was able to get it to work via the above instructions. I can not. My x6100 will not let me change its IP address. It automatically picks up an address from my router and uses that. I have tried to turn off the Auto Connect in the X6100, but every time I turn on radio WiFi, it automatically turns on Auto Connect and I am back to the same problem. Unfortunately, the X6100 IP is not in the same range as all my other devices on my network. There is another poster on Youtube that had the same problem, and had to try it a few times to get it to work. Others commented that they could not, even after a few tries. I have a mesh router, so that could be the issue, as others don’t seem to. I mention all of this so you have an understanding of what is happening. I now believe it is a problem with the X6100 and mesh routers.

With the new firmware, the Xiegu CAT commands n longer work, so WSJT-X, JTDX and others no longer work with x6100 config. I noticed on wfview that it was set to IC-705. I tried IC-705 in the above programs and it still did not work. Do you have any suggestions? Else I am going back to 1.1.6.

Hi Gary,

CAT commands (CI-V ones, to be specific) must be working to some degree for wfview to connect over to the radio. So there’s hope!

I don’t have an X6100 (yet…) but here is what I would do:

  1. Connect the X6100 to solid network, strong wifi or ethernet.
  2. Connect to the X6100 with wfview
  3. Follow directions on our website to “share control” via wfview, using wfview’s built-in rigctld-compatible server, which is known to work well with WSJT-X, fldigi, etc.

It should work, this is how we generally share control with the other radios that wfview supports. However, I have not tested it. It does seem that there is room for improvement on the X6100, from what I’m hearing.

Let us know how it goes. Keep an eye on the wfview log (press “Log”).

de W6EL